Jump to content


Photo

Modded Firmware for CyanogenMod10 + GApps


  • Please log in to reply
12 replies to this topic

#1 BlueEyes

BlueEyes

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 61 posts

Posted 09 October 2012 - 04:57 PM

So two days ago I installed CM10 on my Gemei G9 and since then my G9 is flying. It was perfect with CM9 as well, but
now it feels faster and as a plus the compatibility to apps and games seems to be better. A few EA Games like Need For Speed which didn't ran before
now run fine.

In order for CyanogenMod10 and Gapps to work on our beloved Gemei G9 Tablet we need the system partition to be bigger than 318 MB.
So I took the (simple buy annoying) task on myself and modded the G9 4.17 version firmware for the system partition to be bigger than 318 MB
and also CWM is also included. So just flash my modded firmware with livesuit and after that CyanogenMod10 with CWM.

Notes:
I own the Gemei with silver back but it should equally work for the ones with black back as well.
I modded the 4.17 version for no particular reason other than it was the only one I just had hany on my computer and didn't want to download a new one.
Also note that the system partition gets only bigger once you flash on CM10. Because CM10 formats the partitions before flashing. Something the original Gemei G9 firmware doesn't do for a reason before flashing.

Finally here are the necessary links:

Modded G9 Firmware with system bigger than 318 MB and CWM
https://www.dropbox...._system+cwm.img
(I will deliver a new link shortly, for now I just put it on my dropbox folder)

Thread for CyanogenMod10 and Gapps
http://www.slatedroi...nmod-10-tweaks/

Compatibility Zips for CM10
Gemei with silver back: http://www.androidfi...ility_1.2.0.zip
Gemei with black back: http://www.androidfi...ility-jb_v4.zip

Thread with the tutorial for LiveSuit
http://www.slatedroi...pilation-files/

If you still have questions just let me know.

Thanks go out to:
MrTasselhof for creating all the nice and helpful tutorials for this wonderful tablet
Christian Troy for creating CM9/10 and the compatibility zips
Shaun2029 for continuing the work of Christian Troy

Edited by BlueEyes, 09 October 2012 - 04:59 PM.

  • jpagesbri and javera like this

#2 kenantz

kenantz

    Member

  • Jr. Member
  • PipPip
  • 10 posts

Posted 10 October 2012 - 04:03 PM

First, thank you for your work. Could you explain how to install all step by step?
I always do something wrong installing roms... wipes...
Thank you.
Sorry about my english. :-)

#3 DLS

DLS

    Newbie

  • Jr. Member
  • Pip
  • 9 posts

Posted 15 October 2012 - 07:58 AM

i flashed your modded g9 firmware and booted in to cwm but
i get error when i try to install cm10_a10_20121011.zip
symlink: some symlinks failed
error in /emmc/cm10_a10_20121011.zip
(status 7)
installation aborted.

Edit
Got it to work with cm10_a10_20121006.zip :)

Edited by DLS, 15 October 2012 - 08:59 AM.


#4 apollo_el

apollo_el

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 84 posts

Posted 18 October 2012 - 11:12 AM

Before I moved to CM10, I had the latest stock ROM (gemei G9 V4.20.02_ROM), since it came out (so for a while now). I was not happy with it.
My first impressions on CM10, are remarkable. What a change! Smoother & faster. Wi-fi is improved, and boy am I happy to see this! Opera/Firefox browsing experience is much better. Battery life seems to be better too (only have it for a couple of days). Overall, it feels like what Gemei should have had on G9 to begin with :-).

Two questions:

1) Non-HD videos play fine both with MX and BS players. HD-videos do not! With MX they are smooth (no lag), but there is no sound (it says "unsupported audio codec:dts"). With BS player there is sound, but they are not smooth. This is an important issue to me, at least. Suggestions?

2) CWM (v.5.5.0.4) above won't mount extsd card(??) I was only able to use the inside storage.
Thanks!

Edited by apollo_el, 18 October 2012 - 12:03 PM.


#5 skigill

skigill

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 21 October 2012 - 10:30 AM

I have the same problemproblem. Hd video wont play

#6 apollo_el

apollo_el

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 84 posts

Posted 21 October 2012 - 03:00 PM

I have the same problemproblem. Hd video wont play



I have tried this : http://www.slatedroi...0/page__st__880 (about the no-DTS sound with MX player). It did not work for me, however. Take a look (if you already haven't).

#7 slicker

slicker

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 22 October 2012 - 11:30 PM

This is a great start BlueEyes, but like Kenantz I need to ask some for a little more procedure information. I'm new to this area so excuse my lame questions.

I used LiveSuit to flash this firmware
Modded G9 Firmware with system bigger than 318 MB and CWM
https://www.dropbox....ystem%2Bcwm.img

It seemed successful in LiveSuit. The tablet booted up with the Gemei splash screen but eventually the Gemei disappeared and just showed a blank screen. Nothing further happened. It doesn't come up with usual screens with other factory G9 images I've tried.

This is on a silver backed tablet. Is this expected?

Next step - load CM10. (If the previous steps were normal). Boot into CWM with internal or external SD card (Using volume power button - or PC connection?) As you can see I'm lost.

Any tips would be useful.

thanks

#8 apollo_el

apollo_el

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 84 posts

Posted 23 October 2012 - 01:04 PM

This is a great start BlueEyes, but like Kenantz I need to ask some for a little more procedure information. I'm new to this area so excuse my lame questions.

I used LiveSuit to flash this firmware
Modded G9 Firmware with system bigger than 318 MB and CWM
https://www.dropbox....ystem%2Bcwm.img

It seemed successful in LiveSuit. The tablet booted up with the Gemei splash screen but eventually the Gemei disappeared and just showed a blank screen. Nothing further happened. It doesn't come up with usual screens with other factory G9 images I've tried.

This is on a silver backed tablet. Is this expected?

Next step - load CM10. (If the previous steps were normal). Boot into CWM with internal or external SD card (Using volume power button - or PC connection?) As you can see I'm lost.

Any tips would be useful.

thanks


***For using LiveSuite correctly***

Follow this guide (scroll down to my post):

http://www.slatedroi...3/page__st__120

In your case, try it again with the Modded G9 Firmware with system bigger than 318 MB and CWM and make sure to format.

***Upload zips to your external MicroSD or internal memory (in my case the first wouldn't let me)***

***CWM***

Once installed, turn off the tablet. Holding down the volume (-) button, press now the power-on button and keep pressing both, UNTIL, you enter the CWM menu.
Use Vol(-/+) to navigate (as up/down) and the power-on button to confirm your highlighted choice.

Then follow the usual instructions at http://www.slatedroi...cyanogenmod-10/, that is:

***Select "wipe data/factory reset"***

***Select "install zip from sdcard" -> "choose zip from sdcard" (or "choose zip from internal sdcard" if your files are into internal memory) and flash, in this order, rom / gapps / compatibility zip (not sure why this order, I did it: rom/ compat /gapps, and it seems fine, but follow what the experts say)***

***Now go back, and select "Reboot system now"***

***Enjoy cm10***

Take it easy :-)

Edited by apollo_el, 23 October 2012 - 01:10 PM.


#9 apollo_el

apollo_el

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 84 posts

Posted 24 October 2012 - 12:50 PM

***For video-playback issues/UPDATE***

There is some discussion going on at: http://www.slatedroi...s/page__st__220 (e.g. pages 11,12 etc).
For G9 black, I am using MX-player and Diceplayer, with the tricks suggested in the link above. For now, it works.

#10 BlueEyes

BlueEyes

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 61 posts

Posted 09 November 2012 - 02:57 AM

I never got around to replace the dropbox link, but it seems that it is working very good so far, but I promise that I will replace the link if I happen to delete it from my dropbox. Nothing is worse than a broken link if you desperately need a file ;-)

I never really tried the newest November release because the one October one is working really good so far and it is giving me great battery life. I will revisit my instructions once the new jelly bean sourcecode version 4.2 gets merged.

Edited by BlueEyes, 09 November 2012 - 02:58 AM.


#11 gringohero

gringohero

    Member

  • Jr. Member
  • PipPip
  • 17 posts

Posted 05 December 2012 - 09:55 AM

I've tried and tried with this one, still can't get it to work. the "modified g9 firmware..." installs but won't run - I can only boot to the cwm, however it cannot read the internal sd card so i can't run the rom etc.
So I tried used the latest gemei firmware v#.20? and installed cwm via sausagemod - now it reads the internal sd card fine but it wont install the rom. just says Installing Update then screen goes black and returns to cwm main menu. If i select an older rom, it sticks at "installing update" for hours till I give up waiting.
Anyone any ideas? I'm also wiping a fresh stock firmware before trying each modified firmware to make sure it's a clean install btw.

#12 toomdrix

toomdrix

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 24 December 2012 - 10:09 AM

I've been trying to get this to work for over a day now and I am having no luck. Here is the process I've followed:

- Used LiveSuite to flash the image file - no problem
- Entered CWM - no problem
- Wipe data - no problem
- Install CM10 rom - FAILS every time with error status 0

I've tried using cm10_a10_20121011.zip and also cm10_a10_20121006.zip both doing exactly the same thing. Incredibly frustrating! Can anyone shine some light on this for me? I'm using a black back g9

thanks a lot

#13 Mjhieu

Mjhieu

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 173 posts
  • LocationVietnam

Posted 18 January 2013 - 03:37 AM

Me too, exactly the same. No hope for this work on our black back gemei g9. I did flash successful with many tablets from ainol, gemei but totally fail with this G9 :)

I've been trying to get this to work for over a day now and I am having no luck. Here is the process I've followed:

- Used LiveSuite to flash the image file - no problem
- Entered CWM - no problem
- Wipe data - no problem
- Install CM10 rom - FAILS every time with error status 0

I've tried using cm10_a10_20121011.zip and also cm10_a10_20121006.zip both doing exactly the same thing. Incredibly frustrating! Can anyone shine some light on this for me? I'm using a black back g9

thanks a lot


Nexus 7 Wifi 32 gb with Mostley Kernel 1.6ghz cpu 520 mhz gpu under Cm10.1 Fusion 4.8
Novo 7 Venus/Fire/Aurora
Haipad M7 - C8 owner
Samsung Galaxy Note 2

My Site




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users