Jump to content


Photo

Problem: Internal SDCard Partition Damaged (SOLVED)


  • Please log in to reply
12 replies to this topic

#1 leandross

leandross

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 42 posts

Posted 29 September 2012 - 03:33 AM

Here is my case:

Rom: CM9 --> DS24

I formated the internal sd (storage), one partition ext4 1gb (app2sd) and the rest fat32.
Everything worked ok, until i by mistake touch the format sd card option, on the "storage" menu.

Then, when i reboot, it says "Internal SD Damaged" Try to Format, nothing happens.

I can access to the rom perfectly, even can change it (now is DS24), but no access to the internal sd.

Tryed with adb shell and parted:

Here are the logs:

root@android:/dev/block # ls
ls
avnftli
avnftli1
loop0
loop1
loop2
loop3
loop4
loop5
loop6
loop7
mtdblock0
mtdblock1
mtdblock2
mtdblock3
mtdblock4
mtdblock5
mtdblock6
mtdblock7
mtdblock8
vold

These are the only two can access:

Model: Unknown (unknown)
Disk /dev/block/avnftli: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  14.2GB  14.2GB  primary               boot, lba

(parted)

print
Model: Unknown (unknown)
Disk /dev/block/mtdblock8: 15.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      16.5MB  14.2GB  14.2GB  primary  fat32

(parted)

The others say:

print
Error: /dev/block/mtdblock1: unrecognised disk label

The result of mount command:

127|root@android:/dev/block # mount
mount
rootfs / rootfs rw 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600,ptmxmode=000 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
ubi0_0 /system ubifs rw,relatime 0 0
ubi1_0 /data ubifs rw,nosuid,nodev,relatime 0 0
/dev/block/mtdblock6 /cache yaffs2 rw,nosuid,nodev,relatime 0 0
none /proc/bus/usb usbfs rw,relatime 0 0
root@android:/dev/block #

Here are the result of Fdisk command:

root@android:/mnt/sdcard # fdisk -l /dev/block/avnftli
fdisk -l /dev/block/avnftli

Disk /dev/block/avnftli: 14.2 GB, 14227079168 bytes
256 heads, 63 sectors/track, 1722 cylinders
Units = cylinders of 16128 * 512 = 8257536 bytes

             Device Boot      Start         End      Blocks  Id System
/dev/block/avnftli1   *           1        1723    13892608   c Win95 FAT32 (LBA
)

root@android:/mnt/sdcard # fdisk -l /dev/block/mtdblock8
fdisk -l /dev/block/mtdblock8

Disk /dev/block/mtdblock8: 15.2 GB, 15233712128 bytes
255 heads, 63 sectors/track, 1852 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

                Device Boot      Start         End      Blocks  Id System
/dev/block/mtdblock8p1               3        1729    13872127+  b Win95 FAT32

root@android:/mnt/sdcard # cat /proc/partitions
cat /proc/partitions
major minor  #blocks  name

  31        0       8192 mtdblock0
  31        1       8192 mtdblock1
  31        2       8192 mtdblock2
  31        3       8192 mtdblock3
  31        4       8192 mtdblock4
  31        5     524288 mtdblock5
  31        6     262144 mtdblock6
  31        7    1048576 mtdblock7
  31        8   14876672 mtdblock8
 250       32   13893632 avnftli
 250       33   13892608 avnftli1

What to do?

Edited by leandross, 29 September 2012 - 03:59 PM.


#2 Gum2

Gum2

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 36 posts

Posted 29 September 2012 - 04:02 AM

In general, first partition of sd card is expected to be in FAT32.
And kernel should support ext4 for it to be recognised.

#3 leandross

leandross

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 42 posts

Posted 29 September 2012 - 11:45 AM

The problem is like the partition table or the partition is corrupted.

If anyone can show me the structure of the partitions/sd of the aurora ii, will try to repair the partitions.

EDIT:

Well, solved.

I was getting this:

Using /dev/block/avnftli
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p
p
p
Model: Unknown (unknown)
Disk /dev/block/avnftli: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  14.2GB  14.2GB  primary               boot, lba

Applied this "mkfs 1 fat32" then:

Model: Unknown (unknown)
Disk /dev/block/avnftli: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  14.2GB  14.2GB  primary  fat32        boot, lba

And on "avnftli1" set mklabel to "msdos"

Edited by leandross, 29 September 2012 - 03:58 PM.


#4 j.satriyo

j.satriyo

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 24 November 2012 - 07:00 PM

The problem is like the partition table or the partition is corrupted.

If anyone can show me the structure of the partitions/sd of the aurora ii, will try to repair the partitions.

EDIT:

Well, solved.

I was getting this:

Using /dev/block/avnftli
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p
p
p
Model: Unknown (unknown)
Disk /dev/block/avnftli: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  14.2GB  14.2GB  primary               boot, lba

Applied this "mkfs 1 fat32" then:

Model: Unknown (unknown)
Disk /dev/block/avnftli: 14.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  14.2GB  14.2GB  primary  fat32        boot, lba

And on "avnftli1" set mklabel to "msdos"

i got the same problem for my ainol aurora II
can you kindly teach me step by step to solved this problem,

i have tried my self, but not working,,

thanks before,,

and sorry for my bad english

#5 minimalist

minimalist

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 57 posts

Posted 25 December 2012 - 07:23 PM

Bump. I am having this error too. Apps download fine but for instance, Beautiful Widgets does not have successful theme downloads, etc. How can I fix this? I cleared the SD from the storage menu in CM10, problem persists in CM10.1

Edited by minimalist, 25 December 2012 - 07:24 PM.


#6 y.pango

y.pango

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 112 posts

Posted 26 December 2012 - 11:22 AM

I'm also having this problem on my Aurora I (v3) after flashing multiple roms. It's appeared some time after flashing from factory 0709 ROM to Quarx 1209... I haven't experienced this problem in the past and have been on at least >10 different ROMs...
My NOVO 7 Aurora experiences and info @ pango's world

#7 leandross

leandross

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 42 posts

Posted 28 December 2012 - 09:08 PM

Use the recovery image, that should fix the problem

#8 y.pango

y.pango

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 112 posts

Posted 29 December 2012 - 05:31 AM

OMG! After sooo many hours of re-flashing and trying various terminal commands, I realised that Quarx CM10 + touch patch works perfectly; no problems with sdcard00. It's the gapps that I was using that caused problems. I was using gapps-jb-20120726-signed as it was working fine with earlier roms.... I simply needed to use an updated version of gapps. I fixed the problem using: gapps-jb-20121011-signed

Reference: http://wiki.rootzwik..._4.1.x-4.2.x.29
My NOVO 7 Aurora experiences and info @ pango's world

#9 vrossi46

vrossi46

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 06 January 2013 - 06:40 AM

I got this problem(damaged SD card) on my Eken A90 using CM9 released 2012-09-13
Help please

#10 MNSiw

MNSiw

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 148 posts

Posted 05 March 2013 - 06:43 AM

print
Model: Unknown (unknown)
Disk /dev/block/mtdblock8: 15.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      16.5MB  14.2GB  14.2GB  primary  fat32

(parted)

Flashed CM 10.1 ext4 (multiuser), for SOD and other reasons flashed back to CM 10.1 ubifs (single user) bricked my Aurora II with no back light, unbricked with unbrick kit but lost 6GB internal storage, SD is 5GB (+1GB for apps), tried autoscript, Image Tool, wipe media of different recoveries, repartitioning using BusyBox, fdisk, parted, adb shell etc.

Problem is in mtdblock8, instead of 14.2GB it has one 5GB partition, tried deleting and creating new partition using BusyBox fdisk and parted, both can delete 5GB partition and create new 14.2GB partition but giving error (fdisk: WARNING: rereading partition table failed, kernel still uses old table: Invalid argument) on saving (w) new partition table.

Edited by MNSiw, 05 March 2013 - 06:44 AM.


#11 ochiotteom

ochiotteom

    Member

  • Jr. Member
  • PipPip
  • 18 posts

Posted 26 March 2013 - 01:56 PM

Hi

I also Flashed CM 10.1 ext4 (multiuser), for SOD reasons I came back to CM 10.1 ubifs (single user) but I have a problem with internal storage. There was none. So I flashed Stock Rom 0626 and I got 9GB of internal storage instead of 15GB.

Problem is with mtdblock8, it has one 9GB partition instead of 15.2GB. I used parted to rescue partition, I now I can see through parted this:
Disk /dev/block/mtdblock8: 15.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
        32.3kB  16.5MB  16.4MB           Free Space
 1      16.5MB  9870MB  9854MB  primary
        9870MB  15.2GB  5363MB           Free Space

So I can see my 15,2GB space on internal card.

But I can't resize or delete and create new partition with fdisk or parted.
fdisk sends an error when writing partition table. And Parted sends an error about I/O error.

Can someone help?

#12 popcorn

popcorn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 73 posts

Posted 27 March 2013 - 03:10 PM

Hi

I also Flashed CM 10.1 ext4 (multiuser), for SOD reasons I came back to CM 10.1 ubifs (single user) but I have a problem with internal storage. There was none. So I flashed Stock Rom 0626 and I got 9GB of internal storage instead of 15GB.

Problem is with mtdblock8, it has one 9GB partition instead of 15.2GB. I used parted to rescue partition, I now I can see through parted this:

Disk /dev/block/mtdblock8: 15.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
        32.3kB  16.5MB  16.4MB           Free Space
 1      16.5MB  9870MB  9854MB  primary
        9870MB  15.2GB  5363MB           Free Space

So I can see my 15,2GB space on internal card.

But I can't resize or delete and create new partition with fdisk or parted.
fdisk sends an error when writing partition table. And Parted sends an error about I/O error.

Can someone help?


Have you tried the Aurora II Unbrick Kit 2.0? Follow the instructions in the read me file. If done correctly, it may solve your lost partition space problem.

#13 ochiotteom

ochiotteom

    Member

  • Jr. Member
  • PipPip
  • 18 posts

Posted 03 April 2013 - 03:46 PM

Have you tried the Aurora II Unbrick Kit 2.0? Follow the instructions in the read me file. If done correctly, it may solve your lost partition space problem.


It worked but I used this kit
http://www.slatedroi...738#entry653738
Seems that aml_autoscript file is the key to resize and format internal storage.
Without this, it did not worked.

I keep this file and the unbrick kit! :clapping: