Jump to content


Photo

Unbrick tool for Fire


  • Please log in to reply
230 replies to this topic

#41 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 12 October 2012 - 01:48 PM

Are you using a german OS? AML flashtool isn't able to find mounted sd-card, because mass-storage device is no Massenspeicher ;). Try with an english-OS..


Find it software wise or what eget you want to call it. Any orter way if all direkt do it automatically...?

#42 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 October 2012 - 01:58 PM

Find it software wise or what eget you want to call it. Any orter way if all direkt do it automatically...?


Where are you from?

#43 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 12 October 2012 - 02:00 PM

Where are you from?

Sweden. Phone *screwed the spelling, sorry.

Edited by Ludvig, 12 October 2012 - 02:02 PM.


#44 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 October 2012 - 02:13 PM

Sweden. Phone *screwed the spelling, sorry.


Probably. You can check the powerstate of FIRE by having a look in device manager. If it's on, there should be a mass storage device ( connected by micro-usb-cable ).

Now you could try to copy all files from the update zip to the root directory of a small ( 2GB FAT32 card , is said elsewhere ) sd-card.
As far as i know you need:

  • factory_update_param.aml
  • uImage_recovery
  • firmware_xxx.zip

then turn off the FIRE and turn it on again by holding the softer key and wait...

#45 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 12 October 2012 - 02:35 PM

I get it into recovery and it starts install but fails at same point with what ever firmware I use. When all tool get to step 18 the it fails due to fact that it can not find ms device

#46 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 October 2012 - 03:13 PM

I get it into recovery and it starts install but fails at same point with what ever firmware I use. When all tool get to step 18 the it fails due to fact that it can not find ms device


I know. But you should try the manual method. Copying the 3 files manually to SD-Card ..

Another idea is to change language of you OS. What's your OS? WinXP Prof, Win7 Ultimate ;) ?

Still another method is: Setup a VM-Ware-PC and download a Win7-32 ISO english. A little bit time consumable, but should do the trick too.

Edited by Vanilla2001, 12 October 2012 - 03:18 PM.


#47 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 12 October 2012 - 03:21 PM

I run 64 bit everywhere ultimate english. If it would be something like that i would be sick to ny stomach.

Edited by Ludvig, 12 October 2012 - 03:24 PM.


#48 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 October 2012 - 03:35 PM

I run 64 bit everywhere ultimate english. If it would be something like that i would be sick to ny stomach.


Then maybe i'm wrong. I made same experience with my german OS. Next try was a Windows-XP prof. english. This worked for me.

Have you already tried to copy the 3 files to the sd-card by card-reader?

Edited by Vanilla2001, 12 October 2012 - 03:37 PM.


#49 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 12 October 2012 - 04:15 PM

Yeah i tried. Will try the other version. Have no problem connecting device to PC. Connects with m3 chip. It won't load the internal drive when flashing. Fails.

#50 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 October 2012 - 04:41 PM

I'm not sure we are talking about the same procedure, i mean the external sd-card. But maybe it doesn't work this way. I used fw 0921 for aml-tool. Then i updated to 0930 with update pack copied to root of sd. I assumed if the bootloader is working, aml tool copies the content to sd-card and runs the procedure..

Aml tool stops at 75 percent,am i right?

#51 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 13 October 2012 - 09:26 AM

Anything I can do to get around this?

AML Flash fail.

After this I try to update from recovery with sd-card. This happens:

Recovery.

Edited by Ludvig, 13 October 2012 - 09:30 AM.


#52 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 13 October 2012 - 12:45 PM

Anything I can do to get around this?

AML Flash fail.

After this I try to update from recovery with sd-card. This happens:

Recovery.



Yes, all okay so far. I had all done in the same way.

Your Windows7 is not configured for english language! But if it's an ultimate edition you should change the language with no problems.

#53 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 13 October 2012 - 01:27 PM

I tried it on the other computer as well. Did you see second video. That is what happens with every firmware

#54 Vanilla2001

Vanilla2001

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 13 October 2012 - 02:11 PM

I tried it on the other computer as well. Did you see second video. That is what happens with every firmware


Yes i saw it. Little kind of unlucky.

My last idea is to try to find a PC with good old WindowsXP, that was my second try and worked for my FIRE.

#55 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 14 October 2012 - 10:30 AM

I tried a virtualized winxp but it connects on multiple ports in aml tool. Think I need to make a clean install.

#56 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 16 October 2012 - 01:07 PM

is there any other way to unbrick the fire expect the AML tool or unbrick sd disk?

#57 Steve8x8

Steve8x8

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 260 posts

Posted 17 October 2012 - 02:57 AM

@Ludvig: Nothing I'm aware of that doesn't require to open the device. There's always JTAG... something you probably don't want to do at home.
With virtual machines, I have run into any possible problem (with other devices as well). Nothing can replace a real XP setup when it comes to USB access.

#58 Ludvig

Ludvig

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 70 posts

Posted 17 October 2012 - 03:23 AM

Yeah. Guess i need to do it the hard way. Will get back with results. Wife away this evening. Gives me time for tech geeking.

#59 N3000

N3000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 20 October 2012 - 10:55 AM

My touchscreen works but there is an offset. From what i have tested it seems than if i touch from right to left it will act as if i touch from left to right, and the touch screen surface is 2 centimeters below the top of the screen.

I have tried to recover by reflashing some firmwares, then the aml flash tool where i even checked the NAND ERASE OPTION and my Fire was not booting anymore but with the use of the UNBRICK TOOL i managed to have the original rom back... but the screen calibration is really wrong. I wonder why, as i thought i had erased everything.

Is there something i can do to calibrate the touch screen ?

edit : reading about this for others tablets it looks like that when i flashed the cyanogenmod10 and i rebooted before applying the compatibility pack I had the elf 2 parameters for the touch screen, that would explain the offset but it's strange that i flash again and it doesn't restore the parameters.

Edited by N3000, 20 October 2012 - 11:14 AM.


#60 N3000

N3000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 20 October 2012 - 02:43 PM

Problem solved !!!

http://translate.goo...age%3D1&act=url

Just put what's inside the rar file in the external sdcard, reboot in recovery and just flash the fire-tp-fix.zip

I just can't believe my fire is working again...

I wonder if those who had the initial dead touchscreen failure could flash this ?