Jump to content


Photo

Flambe - Custom ROM


  • Please log in to reply
1358 replies to this topic

#81 iFX

iFX

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 49 posts
  • LocationAustralia

Posted 02 September 2012 - 06:40 PM

Regarding the lack of keyboard ... you need to wait about 5 to 10 minutes for the keyboard to install. The new keyboard has a spelling dictionary and is huge.


In case anyone else has the same problem - I waited 20 min still no keyboard, so then skipped through the section without being able to enter anything (it accepts a blank name for the owner) - then after waiting a further 20 min at the home screen etc, trying to run apps/browser etc - still no keyboard... so I rebooted and instant keyboard.

So looks like if you're not getting the keyboard, just reboot and it should work straight away.

Oh! and after that I tried the camera and just got a green screen and then the app would freeze - another reboot fixed that.

However, just wondering if the following message is normal to see on the recovery menu?:

E:Bad bootloader arguments
"(null)"
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: cannot mount/ sdcard(No such file or directory)
E: Can't mount/sdcard/factory_update_param.aml
E: unknown volume for path [/udisk/factory_update-param.aml]
E: Can't mount/udisk/factory_update_param.aml

The reason, I installed this custom ROM (I was going to wait for JB ;) ) was because my stock set up just went pear shaped yesterday.

Well a few days ago, I noticed that even in so-called "standby", screen off, wifi off etc... it would only last 8 or so hours before turning itself off... and when I checked the battery stats, I could see that for some weird reason (even in standby when it wasn't being used) the battery drain looked normal for standby up until about the 40% remaining mark and then it just did an almost vertical drop and in another hour or so was down to 3% and turned itself off... this was concerning, but then yesterday for no apparent reason the internal SD just disappeared and nothing I tried could get it back - without wiping the media from recovery - of course I lost everything and all my data etc.

So, what's my point in all this? Don't bother sticking with stock, it's gonna go bad - too many bugs... go straight to this ROM - it already is running so much better than even when stock was running well ;)

Just one other question though - Other than the "Bad bootloader arguments" and "unknown volume for path" errors in the recovery menu...
Is anyone else finding that performance mode is the slowest? and power saving the fastest?

When I run quadrant, in power saving mode the tablet beats the Transformer TF201 - but in performance mode and normal, it's lower, with performance getting the lowest results. :huh:

#82 Pat Moss

Pat Moss

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 585 posts
  • LocationRedondo Beach, CA

Posted 02 September 2012 - 07:39 PM

In case anyone else has the same problem - I waited 20 min still no keyboard, so then skipped through the section without being able to enter anything (it accepts a blank name for the owner) - then after waiting a further 20 min at the home screen etc, trying to run apps/browser etc - still no keyboard... so I rebooted and instant keyboard.

So looks like if you're not getting the keyboard, just reboot and it should work straight away.

Oh! and after that I tried the camera and just got a green screen and then the app would freeze - another reboot fixed that.

However, just wondering if the following message is normal to see on the recovery menu?:

E:Bad bootloader arguments
"(null)"
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: failed to mount/ sdcard(No such file or directory)
E: cannot mount/ sdcard(No such file or directory)
E: Can't mount/sdcard/factory_update_param.aml
E: unknown volume for path [/udisk/factory_update-param.aml]
E: Can't mount/udisk/factory_update_param.aml

The reason, I installed this custom ROM (I was going to wait for JB ;) ) was because my stock set up just went pear shaped yesterday.

Well a few days ago, I noticed that even in so-called "standby", screen off, wifi off etc... it would only last 8 or so hours before turning itself off... and when I checked the battery stats, I could see that for some weird reason (even in standby when it wasn't being used) the battery drain looked normal for standby up until about the 40% remaining mark and then it just did an almost vertical drop and in another hour or so was down to 3% and turned itself off... this was concerning, but then yesterday for no apparent reason the internal SD just disappeared and nothing I tried could get it back - without wiping the media from recovery - of course I lost everything and all my data etc.

So, what's my point in all this? Don't bother sticking with stock, it's gonna go bad - too many bugs... go straight to this ROM - it already is running so much better than even when stock was running well ;)

Just one other question though - Other than the "Bad bootloader arguments" and "unknown volume for path" errors in the recovery menu...
Is anyone else finding that performance mode is the slowest? and power saving the fastest?

When I run quadrant, in power saving mode the tablet beats the Transformer TF201 - but in performance mode and normal, it's lower, with performance getting the lowest results. :huh:


The bootloader stuff is normal, I can put out aml files, but that will screw people who are just trying to patch things.

The performance on this is awesome, and the CPU is is tuned to respond to demand. Leave it alone. Performance ignores the feedback governor -- it will do worse. I am thinking of removing the options, and letting the governor do the work rather than a hardcode.

My bad on the installer. I screwed up. Install and then reboot. I've got couple of things in the wrong order. So sorry.

As to the wipe, we need this. The default format for Fire and Aurora is flawed for the userdata space.
Pat Moss

Double Stuff ROM - NOVO Flambe ROM - NOVO Crystal ROM
Donate and support firmware development

IRC://chat.freenode.net/#ainovo

#83 Pat Moss

Pat Moss

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 585 posts
  • LocationRedondo Beach, CA

Posted 02 September 2012 - 07:42 PM

Thanks Pat keep up the good work.
Only getting a chance to flash Flambe looking forward to seeing what else you cook up, plus has me itching to learn how to do it myself.


Trust me, you don't want this. The MALI400 doesn't play well with our resolution, and I'm having problems convincing it that the density is 213 and not 160. I'll get it working ... either by force or by trick. I'd like to do it elegantly though.
Pat Moss

Double Stuff ROM - NOVO Flambe ROM - NOVO Crystal ROM
Donate and support firmware development

IRC://chat.freenode.net/#ainovo

#84 Mr. Splodge

Mr. Splodge

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 239 posts

Posted 03 September 2012 - 02:49 AM

Great ROM - installed this stright away after receiving my Fire. One question though, how can I get the torch/flashlight app back that was in the original ROM? Is the apk available anywhere? I've tried a few from the market and haven't found one that works on this tab yet.

#85 Lythala

Lythala

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 43 posts

Posted 03 September 2012 - 05:56 AM

Copy the three files to your update TF
Pull out your data TF
Place on update TF in the tablet


Whats mean TF?

#86 Matzen

Matzen

    Member

  • Jr. Member
  • PipPip
  • 17 posts

Posted 03 September 2012 - 06:52 AM

Whats mean TF?


Trans Flash, in other words an external SD-card that you put in your tablet.

#87 Liquidin

Liquidin

    Newbie

  • Jr. Member
  • Pip
  • 9 posts

Posted 03 September 2012 - 07:59 AM

Can someone help me with my question? This ROM have many language options like a ICS ROM for mobiles?

I'm looking for Brazilian Portuguese language.

Thanks

#88 torankusu

torankusu

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 03 September 2012 - 09:56 AM

Can someone help me with my question? This ROM have many language options like a ICS ROM for mobiles?

I'm looking for Brazilian Portuguese language.

Thanks

Hi all,

it has Portuguese, for sure but i don't know if there is a specific "brazilian-portuguese" that you are referring to. again it does have "portuguese".

#89 Pat Moss

Pat Moss

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 585 posts
  • LocationRedondo Beach, CA

Posted 03 September 2012 - 10:57 AM

Great ROM - installed this stright away after receiving my Fire. One question though, how can I get the torch/flashlight app back that was in the original ROM? Is the apk available anywhere? I've tried a few from the market and haven't found one that works on this tab yet.


here you go.

Orphaned Apps

Edited by Pat Moss, 03 September 2012 - 10:59 AM.

Pat Moss

Double Stuff ROM - NOVO Flambe ROM - NOVO Crystal ROM
Donate and support firmware development

IRC://chat.freenode.net/#ainovo

#90 iFX

iFX

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 49 posts
  • LocationAustralia

Posted 03 September 2012 - 11:34 AM

...how can I get the torch/flashlight app back that was in the original ROM? Is the apk available anywhere? I've tried a few from the market and haven't found one that works on this tab yet...


That's this one isn't it?
https://play.google....vuni.flashlight

Looks similar, but the built-in version has no ads.


Ahh... sorry, I only used it once so didn't realise.
Hmmm... I wonder if it's a bit like those other apps that were available in that Ainol marketplace app that appeared to have quite a few apps for free that normally aren't? ;)

Edited by iFX, 03 September 2012 - 12:09 PM.


#91 mmaacc

mmaacc

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts

Posted 03 September 2012 - 11:38 AM

That's this one isn't it?
https://play.google....vuni.flashlight

Looks similar, but the built-in version has no ads.

#92 iFX

iFX

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 49 posts
  • LocationAustralia

Posted 03 September 2012 - 12:01 PM

The bootloader stuff is normal, I can put out aml files, but that will screw people who are just trying to patch things.


Cool :) just wanted to make sure... as I hadn't tried going into recovery mode until after my internal SD stopped working ;)


The performance on this is awesome, and the CPU is is tuned to respond to demand. Leave it alone. Performance ignores the feedback governor -- it will do worse. I am thinking of removing the options, and letting the governor do the work rather than a hardcode.


So... are you saying it's best to leave it on normal?


My bad on the installer. I screwed up. Install and then reboot. I've got couple of things in the wrong order. So sorry.


Don't be sorry ;) I'm so glad you're doing this - without your ROM I'm not sure my Fire would be useable right now... I say *my* Fire, even though I originally bought it for my wife, but at the moment it's a bit too unstable to hand over to her. It was running great for the first couple days, but over the weekend it started playing up and has since been freezing and rebooting randomly multiple times a day - hopefully it's not a hardware thing and will be fixed with a future firmware update.

Today the wifi started playing up, after waking from sleep it had lost the connection (even though I had it set to keep wifi on) and the wifi option was grayed out so I couldn't turn it on... I had to reboot to get it working again - but then I found if I changed the setting to turn off wifi when it goes to sleep, it fixed it... more weirdness ;)


As to the wipe, we need this. The default format for Fire and Aurora is flawed for the userdata space.


Oh yes, I understand needing to wipe when installing a new ROM, I was just talking about me having to wipe the media partition to get access to my internal SD again - nothing to do with the ROM ;) I wanted to back up my data before wiping, but the internal SD just wouldn't mount no matter what I tried - just went from one minute working fine to the next it disappeared (but that was on stock).

My main concern with this tablet at the moment, (and the most annoying thing) is that it doesn't like to wake up from sleep, I end up having to push the button about 4 or 5 times before it finally turns the screen back on... and sometimes even that won't work and I end up having to reboot it - it started doing that around the time the internal SD disappeared.

Anyway, thanks so much for all your work on this I really appreciate what you're doing :)

#93 Tango One

Tango One

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 145 posts

Posted 03 September 2012 - 12:14 PM

I have that problem with a family member elf II it just doesn't like to wake up

#94 Mr. Splodge

Mr. Splodge

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 239 posts

Posted 03 September 2012 - 12:50 PM

here you go.

Orphaned Apps

Awesome. Thanks for that.

#95 iFX

iFX

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 49 posts
  • LocationAustralia

Posted 04 September 2012 - 12:09 AM

I have that problem with a family member elf II it just doesn't like to wake up


You know, I'm not sure if it's two problems here... but sometimes I know it's on, but it won't wake up... then finally it comes on after about the 4th press (waiting about 5 - 10 seconds each time after pressing the button)... if it still doesn't come on, I'll start pressing the button a little longer - sometimes it then flashes on for a second and then goes off again (and during that flash I can see that it's now got a prompt up asking whether I want to switch it off - due to my longer presses of the button)... if it does finally come on after that I usually have to close multiple dialogs asking whether I want to turn it off ;)

But sometimes it doesn't come back on even after 10 presses... at which point I'm not sure it's still on or not... and that's what happened this morning - I unplugged it from the charger at about 3:30am - 4am this morning and made sure nothing was running, turned off wifi and put it to sleep (I tested waking it up a couple times over the next 10 minutes - it usually takes a count to 4 to wake up when it's working and it was working fine)... then I went to bed (yeah I was working late).

When I woke up later at around 8:30 - 9am I checked the tablet and it wouldn't wake up... tried about 10 times and nothing, so did an extra long press and it started booting up - I'm not sure if it was off or it just wouldn't wake up and I then caused it to reboot, but it did feel slightly warm (very slight) and when I checked the battery stats it was at 74% left and said it'd been on battery for just over 3 hours... I don't know about you guys, but 4am + 3 hours doesn't add up to 9am to me... so it's like it decided to turn itself off?? very strange as the battery was no where near empty :S

Anyone know what might be the cause? or a possible fix?

#96 Dima_2005

Dima_2005

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 96 posts

Posted 04 September 2012 - 01:08 AM

No wake up issues with wifi off.

#97 MichaelChou

MichaelChou

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 71 posts
  • LocationBeijing, China

Posted 04 September 2012 - 02:03 AM

I attached a mouse, but it showed a black square instead of a pointer. And I couldn't use the touchscreen after I detached it.

Even after I reboot it, the touchscreen still doesn't work. I'll try to reflash the ROM.

Edited by MichaelChou, 04 September 2012 - 02:16 AM.


#98 kamelot

kamelot

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 31 posts

Posted 04 September 2012 - 02:54 AM

I attached a mouse, but it showed a black square instead of a pointer. And I couldn't use the touchscreen after I detached it.

Even after I reboot it, the touchscreen still doesn't work. I'll try to reflash the ROM.


Fire touchcreen bug?

#99 MichaelChou

MichaelChou

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 71 posts
  • LocationBeijing, China

Posted 04 September 2012 - 03:43 AM

Fire touchcreen bug?


I think it is. Oh, s**t.

#100 iFX

iFX

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 49 posts
  • LocationAustralia

Posted 04 September 2012 - 06:23 AM

I think it is. Oh, s**t.


Now I'm scared :o