Jump to content


Photo

FBReader 1.5.5


  • Please log in to reply
1 reply to this topic

#1 BillJ

BillJ

    Member

  • Jr. Member
  • PipPip
  • 25 posts

Posted 21 August 2012 - 05:32 PM

Uname -a says I'm running 2.6.32.9benya-a2p2 armv7l on my Herotab Mid816.

I've used FBReader for a good long while but now it's crashing. I use Z4Root at times but not for installing or uninstalling software. Since upgrading Ghost Commander I no longer can open an epub in Ghost Commander and see a choice of programs with which to read the book while previously I could choose between FBReader, Aldiko, B&N Nook. I later added Amazon Kindle. Now Ghost Commander informs me there is no application associated with the epub file.

When I open FBReader I'm told it's opening a book while showing my choice of page paper then flashes to black and closes back to the desktop. If I go to ES File Explorer and open an epub file, e.g. The Green Eyes of Bast from Project Gutenberg, FBReader opens, shows my background paper, then crashes.

Aldiko and Nook work fine and I don't use the Kindle.

I had been using AndFTP to download books from one of my computers but had gone to removing the external SDcard, copying the book to the card, then opening the file from the FBReader.

I've uninstalled the 1.5.5 and installed an early FBReader and it worked but was unsuitable as I couldn't find the library. I uninstalled the earlier version, reinstalled 1.5.5, and it fails. I tried renaming Books directory to Books.bak and opening a book but no go.

I have deleted books from the Books directory using Ghost Commander. Some Android phone users have posted this caused crashes of their FBReader but their fix, renaming the Books directory to Books.bak, doesn't work for me.

I went to look at traces.txt from the root directory and was told it wasn't there (#cat /data/anr/traces.txt) but went into /data/anr/ and could cat traces.txt there (#cat ./traces.txt) so I wonder if it's a path problem. Traces.txt had no mention of the FBReader crash.

Advice on how to fix this will be appreciated. It's my preferred e-book reader.

Thanks.

BillJ

#2 BillJ

BillJ

    Member

  • Jr. Member
  • PipPip
  • 25 posts

Posted 21 August 2012 - 10:37 PM

I uninstalled version 1.5.5 and installed version 1.2.1 from old.fbreader.org and it seems to be working. I note that this time I uninstalled the 1.5.5 using Market and installed the 1.2.1 from a download link on old.fbreader.org. Previously I had uninstalled from Settings, Applications, Manage Applications. I previously mentioned an earlier version, 0.9.x wasn't satisfactory.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users