Jump to content


Photo

Onda Vi30 Dual-Core Official Market Fix & Gapps Repacks


  • Please log in to reply
141 replies to this topic

#21 chainer

chainer

    Member

  • Jr. Member
  • PipPip
  • 29 posts
  • LocationPhilippines

Posted 15 August 2012 - 05:23 AM

I think some people are confusing repacked firmwares with custom roms.



Sent from my ONDA MID using Tapatalk 2
One musnt criticize other people on grounds where he can't stand perpendicular himself.
-Mark Twain

#22 F&LSuperstore

F&LSuperstore

    Advanced Member

  • Authorized Business Seller (ABS)
  • PipPipPip
  • 1,026 posts
  • LocationTampa Bay, FL

Posted 15 August 2012 - 05:11 PM

People call it a custom ROM. I call it a custom repack. Because since I'm not editing source codes for the Kernels, etc. then all I'm doing is adding pertinent Android files that change the way Android behaves and packing them into a new zip.

What I mean by that is making sure that it is english default, has the proper Google Apps, and has the proper files that the market looks for to tell whether or not your device is compatible with certain apps. (App makers set standards for devices to run their apps but these standards can be easily maniuplated.) With my ROM/Repacks though I try and leave the canvas as blank as possible. I have always hated bloatware and pre-defined homepages. I leave that up to the user to figure out.

So call it a ROM, call it a Repack. Call it a fix. Whatever it is, I can assure you that it's better than stock & their so-called patches to fix the market. So if your reading this wondering if you should upgrade your tablet with this ROM. I will ask you why not? If I sell the tablets that I'm writing these ROM/Repacks for then I must be using them on my own tablets right?

Right.
Posted Image
Frank, President
F&L Superstore - www.flsuperstore.com
email: frank@flsuperstore.com
blog: flsuperstore.wordpress.com
MSN: flsuperstore@gmail.com

#23 LastFrontier

LastFrontier

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 33 posts

Posted 15 August 2012 - 06:33 PM

I don't if you're aware but there is a new **OFFICIAL** build of the v1.2 firmware. Maybe you can work some of you're magic if you've the time :-)

The firmware is in the official chinese onda site.

Thanks in advance

Sent from my Onda Vi30D

#24 F&LSuperstore

F&LSuperstore

    Advanced Member

  • Authorized Business Seller (ABS)
  • PipPipPip
  • 1,026 posts
  • LocationTampa Bay, FL

Posted 15 August 2012 - 06:41 PM

I don't if you're aware but there is a new **OFFICIAL** build of the v1.2 firmware. Maybe you can work some of you're magic if you've the time :-)

The firmware is in the official chinese onda site.

Thanks in advance

Sent from my Onda Vi30D


Ok so there's another another 1.2? I downloaded that 1.2 direct from Onda. Is it different now?
Posted Image
Frank, President
F&L Superstore - www.flsuperstore.com
email: frank@flsuperstore.com
blog: flsuperstore.wordpress.com
MSN: flsuperstore@gmail.com

#25 LastFrontier

LastFrontier

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 33 posts

Posted 15 August 2012 - 08:35 PM

Ok so there's another another 1.2? I downloaded that 1.2 direct from Onda. Is it different now?

yeah i guess so cause it was realesed y-day and the changelog is different. Used google translate to understand that giberish and it seems that they fixed the youtube problem and optimized scanning speed of the HDD

Sent from my Onda Vi30D

#26 chainer

chainer

    Member

  • Jr. Member
  • PipPip
  • 29 posts
  • LocationPhilippines

Posted 16 August 2012 - 05:11 AM

Tested the new official v1.2 firmware rel0807. Same market app issues. Youtube does work if you manage to install the app cause you cant download it from google play. Facebook app also works now. But you will not be able to access youtube and facebook websites.

Sd does seem to mount faster tho.

Vi40 guys on the other threads say their cameras are not working with their new firmware. Our cameras work just fine with our version.

Sadly i cant reach the 9000+ score in antutu, which i only managed with v1.0. Scored 7208 only and this is in performance mode (7000+ was managed in normal mode with v1.0 before. Booooo).

Going back to flsuperstores version.

Sent from my GT-N7000 using Tapatalk 2

Edited by chainer, 16 August 2012 - 05:14 AM.

One musnt criticize other people on grounds where he can't stand perpendicular himself.
-Mark Twain

#27 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 16 August 2012 - 07:28 AM

Ok, changed to another sdcard and it sees F&L's repack. BUT it doesn't like its signature. I think there's a post on here somewhere about that. It seems the Tablet mounts the internal card at two mount points /sdcard and /mnt/sdcard, and mounts the external card at /mnt/sdcard/external_card. It mounts the "OS" at /, of course.

Edited by Sassinak, 16 August 2012 - 07:59 AM.


#28 F&LSuperstore

F&LSuperstore

    Advanced Member

  • Authorized Business Seller (ABS)
  • PipPipPip
  • 1,026 posts
  • LocationTampa Bay, FL

Posted 16 August 2012 - 01:29 PM

Ok, changed to another sdcard and it sees F&L's repack. BUT it doesn't like its signature. I think there's a post on here somewhere about that. It seems the Tablet mounts the internal card at two mount points /sdcard and /mnt/sdcard, and mounts the external card at /mnt/sdcard/external_card. It mounts the "OS" at /, of course.


I've updated 20 tablets with this ROM and it works perfectly. Are you unpacking the zip to the root directory of a SD card?
Posted Image
Frank, President
F&L Superstore - www.flsuperstore.com
email: frank@flsuperstore.com
blog: flsuperstore.wordpress.com
MSN: flsuperstore@gmail.com

#29 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 16 August 2012 - 03:30 PM

Yup, I just put the zip file as is, then boot into recovery mode. It (the tablet) offers to install it, then balks at the signature.
The mount points annoy me because I can't move apps to the external card, just the "bigger" partition of the internal one.
You say I should unzip the files?
Do I need a working internet connection? Mine got cut yesterday due to clumsy renovation dorks.

Edited by Sassinak, 16 August 2012 - 03:39 PM.


#30 F&LSuperstore

F&LSuperstore

    Advanced Member

  • Authorized Business Seller (ABS)
  • PipPipPip
  • 1,026 posts
  • LocationTampa Bay, FL

Posted 16 August 2012 - 03:39 PM

Yup, I just put the zip file as is, then boot into recovery mode. It (the tablet) offers to install it, then balks at the signature.
The mount points annoy me because I can't move apps to the external card, just the "bigger" partition of the internal one.
You say I should unzip the files?


Yes, you need to unzip the files into the root SD. It shouldn't even go into recovery since I put a script in the zip that will take care of everything for you. What you will see is the little android guy and a progress bar. Then it will boot after it's done.
Posted Image
Frank, President
F&L Superstore - www.flsuperstore.com
email: frank@flsuperstore.com
blog: flsuperstore.wordpress.com
MSN: flsuperstore@gmail.com

#31 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 16 August 2012 - 03:58 PM

Yes, you need to unzip the files into the root SD. It shouldn't even go into recovery since I put a script in the zip that will take care of everything for you. What you will see is the little android guy and a progress bar. Then it will boot after it's done.

Ok, it's installing. Stopped at 10% for now but I read that it should finish anyway. Fingers crossed.
edit2: hmmm. It's been 20 mins. Nothing more is happening....:-/

Edited by Sassinak, 16 August 2012 - 04:19 PM.


#32 chainer

chainer

    Member

  • Jr. Member
  • PipPip
  • 29 posts
  • LocationPhilippines

Posted 16 August 2012 - 04:30 PM

Use v1.1 first. That will resolve the mount issue. I believe this is due to the wipe_media command in the aml file which is not included in v1.2. After that you can flash flsuperstores version.

Sent from my GT-N7000 using Tapatalk 2
One musnt criticize other people on grounds where he can't stand perpendicular himself.
-Mark Twain

#33 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 16 August 2012 - 04:46 PM

Use v1.1 first. That will resolve the mount issue. I believe this is due to the wipe_media command in the aml file which is not included in v1.2. After that you can flash flsuperstores version.

Sent from my GT-N7000 using Tapatalk 2

oh. Now they tell me. Now what, shut down? Will do, as I have to go home....
I'm looking at that aml file:

--update_package=/sdcard/update.zip
--wipe_data
--wipe_cache

I could just add --wipe_media...
@F&L's If it's dead...can I send it to you ? (for a fee, of course, I understand...)

Edited by Sassinak, 16 August 2012 - 04:50 PM.


#34 F&LSuperstore

F&LSuperstore

    Advanced Member

  • Authorized Business Seller (ABS)
  • PipPipPip
  • 1,026 posts
  • LocationTampa Bay, FL

Posted 16 August 2012 - 04:56 PM

oh. Now they tell me. Now what, shut down? Will do, as I have to go home....
I'm looking at that aml file:

I could just add --wipe_media...
@F&L's If it's dead...can I send it to you ? (for a fee, of course, I understand...)


It's almost impossible to brick.

I think for some reason --wipe_media wasn't working so I took it out. I have no clue why. And again not a ton of time to expirement with it. But if someone figures it out let me know.

Edited by F&LSuperstore, 16 August 2012 - 04:57 PM.

Posted Image
Frank, President
F&L Superstore - www.flsuperstore.com
email: frank@flsuperstore.com
blog: flsuperstore.wordpress.com
MSN: flsuperstore@gmail.com

#35 chainer

chainer

    Member

  • Jr. Member
  • PipPip
  • 29 posts
  • LocationPhilippines

Posted 16 August 2012 - 05:04 PM

wipe_media isnt in the initial v1.2 from onda... tho its now in the latest v1.2.
One musnt criticize other people on grounds where he can't stand perpendicular himself.
-Mark Twain

#36 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 17 August 2012 - 12:23 PM

Sorry, I was away from the internet for 24 hrs.
Latest news: I stopped it, and tried to boot it "as is". It turned on and got as far as the wavy Onda logo, then stalled.
I put the Onda V1.2 firmware on my new sdcard and upgraded. It does include the wipe_media command. The upgrade was successful. <phew>
So now I have rebooted. In chinese.
I will add the line --wipe_media to the aml file and re-try with F&L's repack. See how that goes....

Edited by Sassinak, 17 August 2012 - 12:23 PM.


#37 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 17 August 2012 - 12:34 PM

Hmmm, Stopped again a tenth of the way. I am downloading a "Fresh" version.
Just not working. With or w/out --wipe_media. Something it doesn't like in the update.zip file itself...<sigh> I'm in Canada, could that affect it ?

How long should the update take ? Their firmware took 5 mins (but I was stuck in chinese XD)

Re-setting is not working, soft or hard. last working option: their option and dicking around to set to english.

Edited by Sassinak, 17 August 2012 - 02:08 PM.


#38 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 17 August 2012 - 02:40 PM

Comparing the firmwares; since I have copies of both, I am re-packing my own version. Playing Frankenstein, Muhahahaha!
edit: almost there: getting a build.prop error

assert failed: getprop("ro.poduct.device")=="g12refM805" || getprop("ro.build.product") == "g12refM805"

error in /sdcard/update.zip
(status 7)


I ended up just flushing their fengshui.zip and replacing the update.zip with the US one, when I had a look at the manifests. changed the aml file.
I will change those lines in the build.prop

Edited by Sassinak, 17 August 2012 - 03:14 PM.


#39 chainer

chainer

    Member

  • Jr. Member
  • PipPip
  • 29 posts
  • LocationPhilippines

Posted 17 August 2012 - 05:04 PM

no need to modify anything... just flash using v1.1... then let it bootup... afterwards, delete all v1.1 files, then extract flsuperstore's v1.2... then flash again..
One musnt criticize other people on grounds where he can't stand perpendicular himself.
-Mark Twain

#40 Sassinak

Sassinak

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 69 posts
  • LocationCanada

Posted 17 August 2012 - 05:37 PM

no need to modify anything... just flash using v1.1... then let it bootup... afterwards, delete all v1.1 files, then extract flsuperstore's v1.2... then flash again..

I can't find a link to V1.1 for the vi30w (dual-core. w stands for "plastic edition", foolish me). http://www.onda-tablet.com/download/
Which one is it ?
Is there a hidden link elsewhere ?