Jump to content


Photo

New Firmware update for G9T


  • Please log in to reply
94 replies to this topic

#21 mpman

mpman

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 31 July 2012 - 12:37 AM

Yes, you have the correct content of file needed on SD root. Glad to hear that you got the firmware update going.

The 更新内容.txt has the same content as the information (详情) link that was on the left side of download link. Most information is relate to the software update / upgrade.

http://www.gemeitech...Down.asp?id=218

Piggy



I can't seem to get full market on this newest firmware. Angry Birds 1, Rio, Seasons... are all missing...

Tasselhoff's root works, but the market update & build prop don't seem to work with this.

Anyone else?

Which of the last few firmwares has full market?

Thanks!

#22 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 31 July 2012 - 02:37 AM

I can't seem to get full market on this newest firmware. Angry Birds 1, Rio, Seasons... are all missing...

Tasselhoff's root works, but the market update & build prop don't seem to work with this.

Anyone else?

Which of the last few firmwares has full market?

Thanks!


Tasselhoff's script for build.prop doesn't work.

In the thread [Script] - Gemei G9T Dual Core - STOCK - Tasselhof - ROOT, Market, Build.Prop & Tweaks SuperScript though, there are information on how to get it working.

To make a long story short:

Go to settings > apps and clear cache and data for play store. Uninstall updates.

Use es file explorer and using root permissions, copy file build.prop to /system and the rest of the .xml files to /system/etc/permissions

Use again es file explorer and change the permissions for all 4 files that you copied to rw- r-- r--

I attach for you the needed files.

It took me some time and a couple of reboots for some unknown reason to get all the apps showing, but still I get some problems such as, Google+ downloads and install a really old version!!

So I guess it will do it's job, but it's not perfect.

Attached Files


Edited by Jason Matsoukas, 31 July 2012 - 02:52 AM.


#23 mpman

mpman

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 31 July 2012 - 10:20 AM

Tasselhoff's script for build.prop doesn't work.

In the thread [Script] - Gemei G9T Dual Core - STOCK - Tasselhof - ROOT, Market, Build.Prop & Tweaks SuperScript though, there are information on how to get it working.

To make a long story short:

Go to settings > apps and clear cache and data for play store. Uninstall updates.

Use es file explorer and using root permissions, copy file build.prop to /system and the rest of the .xml files to /system/etc/permissions

Use again es file explorer and change the permissions for all 4 files that you copied to rw- r-- r--

I attach for you the needed files.

It took me some time and a couple of reboots for some unknown reason to get all the apps showing, but still I get some problems such as, Google+ downloads and install a really old version!!

So I guess it will do it's job, but it's not perfect.



THANNNNNNK YOUUUUUUUUU! This worked! I was trying but I wasn't setting the permissions right initially :)

Are you getting a red border around the screen when shutting down or choosing some options...??

#24 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 31 July 2012 - 10:35 AM

THANNNNNNK YOUUUUUUUUU! This worked! I was trying but I wasn't setting the permissions right initially :)

Are you getting a red border around the screen when shutting down or choosing some options...??


Yes! It's the option found in settings/developer but I guess it's enabled from a line within those files. It's not bugging me that much though...

If you notice any other strange behavior in play store, let us know!

#25 Mozzz

Mozzz

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 31 July 2012 - 04:00 PM

Are you getting a red border around the screen when shutting down or choosing some options...??


You can get rid of the red flashing frame / border by changing

ro.build.type=eng

to

ro.build.type=user

in build.prop

and push that again.

#26 Mozzz

Mozzz

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 31 July 2012 - 04:03 PM

Does anybody of you know if updating a rooted G9T to the newest firmware can result in root not being possible anymore? I know there are only few devices out there were no way to root was found. But I would rather not loose root by updating the firmware.

#27 mpman

mpman

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 31 July 2012 - 05:01 PM

I'm using the NEWEST firmware (20120726) and was able to root it using Tasselhoff's script.

All is working fine now that I got an almost full market (tune in radio is 'incompatible' but I was able to sideload it fine. Also the market Youtube app force closes, so I had to fine an older version and sideload it too.)

My screen is coming off the base on my tablet on the side with all the ports. Seems like the glue is not holding it down... we'll see what the seller can do about it.. otherwise, it's a great tab!

I'll keep updating on future problems...

Thanks everyone!!

#28 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 31 July 2012 - 06:12 PM

I'm using the NEWEST firmware (20120726) and was able to root it using Tasselhoff's script.

All is working fine now that I got an almost full market (tune in radio is 'incompatible' but I was able to sideload it fine. Also the market Youtube app force closes, so I had to fine an older version and sideload it too.)

My screen is coming off the base on my tablet on the side with all the ports. Seems like the glue is not holding it down... we'll see what the seller can do about it.. otherwise, it's a great tab!

I'll keep updating on future problems...

Thanks everyone!!


YouTube is not working, and Play Music not working as well. :(

Some files from latest gapps are probably missing..

#29 mpman

mpman

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 31 July 2012 - 06:57 PM

YouTube is not working, and Play Music not working as well. :(

Some files from latest gapps are probably missing..



A lot of tablet owners are having issues with the newest Youtube update. I found version 3.5.5 works perfectly on this tablet. Google "Youtube Apk For Ics [Version 3.5.5]‎".

#30 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 01 August 2012 - 02:57 AM

A lot of tablet owners are having issues with the newest Youtube update. I found version 3.5.5 works perfectly on this tablet. Google "Youtube Apk For Ics [Version 3.5.5]‎".


Newer version 4.0.8e works fine as well.

http://depositfiles....files/huwap4tph

#31 piggysd

piggysd

    Member

  • Jr. Member
  • PipPip
  • 14 posts

Posted 08 August 2012 - 09:53 PM

Gemei has released another firmware update G9T_A4.0.4_V2.30.0808. However, the old root script no longer works since this is 4.0.4 based. You might want to pause upgrade until Tasselhof create new root script for 4.0.4.

Thanks,

Piggy

#32 NyuIsHappy

NyuIsHappy

    Newbie

  • Jr. Member
  • Pip
  • 4 posts

Posted 14 August 2012 - 09:56 AM

I've ugraded my G9T to 20120726 after having some stability issues on the factory firmware, but the new firmware won't launch the browser or google play.

Serial number series is 0252SL231---- so that could have a lot to do with it. Having some trouble finding older firmware. If someone could point me in the right direction I would greatly appreciate it :)

#33 bradlad

bradlad

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 17 August 2012 - 06:05 PM

I have downloaded this latest firmware update, but when i try and extract it have all sorts of problems, rom unrecognized characters preventing the extraction to 'invalid .zip file' please can someone help. thanks.

#34 unbreakable84

unbreakable84

    Newbie

  • Jr. Member
  • Pip
  • 3 posts

Posted 19 August 2012 - 04:05 PM

I rooted my tablet using the script, updated the firmware to the latest one, got the video playback issue. Uninstalled flash, installed flash 11, now it only happens sometimes... which is weird.. Anybody run into the 'performing sd card check' problem?

#35 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 20 August 2012 - 02:39 AM

I rooted my tablet using the script, updated the firmware to the latest one, got the video playback issue. Uninstalled flash, installed flash 11, now it only happens sometimes... which is weird.. Anybody run into the 'performing sd card check' problem?


Yeap......

#36 unbreakable84

unbreakable84

    Newbie

  • Jr. Member
  • Pip
  • 3 posts

Posted 23 August 2012 - 02:23 PM

Yeap......


heres what i did, followed some steps from the aurora II Forum.

-formatted internal sd card(fat 32, 64k)
-delete fsck_msdos in root explorer(system/bin)
-installed some games, about a gb or 2 of data
-reconnect to computer and defragment the internal sd (my drive was 29% fragmented)

its been about a week and no problems so far..

anybody check out the 08/22 fiirmware update?

#37 ethaler

ethaler

    Newbie

  • Jr. Member
  • Pip
  • 4 posts

Posted 24 August 2012 - 08:56 AM

the new firmware Gt9404 (20120822) works fine!

#38 Jason Matsoukas

Jason Matsoukas

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 104 posts

Posted 24 August 2012 - 09:10 AM

the new firmware Gt9404 (20120822) works fine!


What do you mean by "fine"?

Root script works fine?

Any improvements?

#39 Mozzz

Mozzz

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 28 August 2012 - 03:38 PM

What do you mean by "fine"?

Root script works fine?

Any improvements?


So does anybody have the 4.0.4 based version rooted by now? Tasselhoff? Anybody else?

Thanks,
Mozzz

#40 olive

olive

    Newbie

  • Jr. Member
  • Pip
  • 4 posts

Posted 29 August 2012 - 03:31 AM

So does anybody have the 4.0.4 based version rooted by now? Tasselhoff? Anybody else?

Thanks,
Mozzz

Since a few days I have this 'performing sd card check' problem , I choose to install the new firmware. Hoping it will sove it.
For this moment I didn't see any visible improvements :
- two icons for sounds (what is the utility if you have hard buttons ?)
- some help in Android (4.0.4 version ?)

It's not possible to install Angry Birds or Chrome (then no improvements in compatibility), Youtube is not working directly on the google market. You have to download the specified version by Jason.
The upgrade procedure is different than the previous one. You have to create a boot sd card from .img. The software used can be found in english.

Best is to wait the JellyBean version ?
You can check on the gemeitech bbs forum (in chinese, but readable with google translate), there is some videos here
I understand that a root tools is also available on this chinese forum...