Jump to content


Photo

Icoo Touch Screen problems


  • Please log in to reply
14 replies to this topic

#1 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 23 March 2012 - 09:11 AM

I've just received my new icoo d90w and it was fantastic for the first hour or so screen is amazing to look at. Got it with about 70% battery life, then after about 2-3 hours the touch started to play up.. touching in one location is ok but if you touch and drag or scroll it will select or drop stuff whilst your dragging your finger(ghost touches).. seems to only do it when the battery is less than 1/2 full..when it gets really low on power sometimes touch stops working all together..(its not frozen cos the buttons still work) to get it working again i have to put it into suspend then wake it up again..if i leave the power plugged in it works fine no freezing touch or ghost touches at all works perfectly..CAN anyone help!!

sounds very similar to the problem the JXD S9000 is having..

I have reflashed the latest 4.03 firmware a couple of times but it does not help..

I'm in the middle of downloading the 2.3 rom from Icoo china taking for ever..
http://soft.aoicoo.c...show.asp?id=161
does anybody have a faster mirror I could try?

Edit 2.3 Mirror
http://www.mediafire...9kpoweyjcgm57e5

It does not fix the touch problem it gets quite bad at less than 15% battery..

Just waiting for China Grabber to tell me what to do..Hope they look after me..
pretty shaw its hardware..

I've tried so far....
-New fresh Rom 4.0.39 and 2.3
-calabrating battery
- Activate the "Show Touches"...Re-boot(was a little better but still touch froze)
-Changing Build.prop lines
debug.performance.tuning=1
windowsmgr.max_events_per_sec=300
view.touch_slop = 30 (again maybe a little better but touch is still eratic and freezes under 15%)
-Tried Nook Screen Recalibrate and SGS touchscreen Booster (still the same)
I'm at a loss after this I've searched everywhere.. any other suggestions i'll give anything a go..
would rather not send it back..and wait another 2 months for a new one..

Edited by coreo, 27 March 2012 - 09:12 AM.

Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#2 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 23 March 2012 - 09:28 AM

This is certainly not good news for me :(
Where did you get your ICOO D90W? I got it from focalprice.(shipped, not yet received)
And btw, are you sure it is an ICOO D90W?
It has to look exactly like this one: http://detail.zol.co...05856/pic.shtml
I have seen people posting videos on youtube saying it's an ICOO D90W, while it's actually a oem version of the UPPO PO8003...
You can easily mix it up.
I haven't seen any complaints about the ICOO D90W yet, so it might just be a manufacturing problem...
I also heard some sellers on dhgate or aliexpress sell broken tablets which don't always work...

Edited by LVL, 23 March 2012 - 09:32 AM.


#3 will567

will567

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 469 posts
  • LocationNJ USA

Posted 23 March 2012 - 05:32 PM

Sorry to hear about your problem, I originally tried to get the ICOO but it was out of stock, and I ended up with the JXD. Which I have had no problems with regarding the touchscreen, so far. Maybe there's just the occasional bad unit.

Sent from my JXD S9000 using tapatalk

ASUS Vivotab Smart
Barnes & Nobles Nook HD+
Amazon Kindle Fire HDX 8.9"

JXD S7800B


#4 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 23 March 2012 - 07:51 PM

Yes it's definately an Icoo looks exactley the same, it has "d90w Icoo designed by ICOO made in China SN:16g**&*&^&&**" with the 2M camera on the back..

Got it from CHINA Grabber..

As i say it works beautifully when charged up or plugged in..
Its my first charging cycle too just charged it over night I ll let you know if it's any better by the end of the day...
But i think i'll have too send it back, such a shame.
Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#5 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 23 March 2012 - 07:57 PM

Yes it's definately an Icoo looks exactley the same, it has "d90w Icoo designed by ICOO made in China SN:16g**&*&^&&**" with the 2M camera on the back..

Got it from CHINA Grabber..

As i say it works beautifully when charged up or plugged in..
Its my first charging cycle too just charged it over night I ll let you know if it's any better by the end of the day...
But i think i'll have too send it back, such a shame.

This must be common problem with 9.7" A10 tablets. So far, these tablets have had touchscreen issues:
- Onda VI40
- Teclast A10t
- JXD S9000
- ICOO D90W

Funny thing is that Onda and Teclast have 5 points multitouch and a completely different chip...
Could it be the allwinner A10 that is failing from time to time?
Or maybe the same power management chip. They all have the same power management chip.
So far I think these problems where all due to low power of the battery.
Maybe a battery calibration DOES work. :)

Hmmm, lets just hope that both my Onda VI40 and ICOO D90W WILL work. :unsure:

Edited by LVL, 23 March 2012 - 08:00 PM.


#6 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 24 March 2012 - 12:35 AM

Is definately stuffed it freezes quite regularly as well but if you send it to sleep then wake it back up the touch will work again for a while..



Edited by coreo, 24 March 2012 - 02:14 AM.

Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#7 Christian Troy

Christian Troy

    Advanced Member

  • FW Developer
  • PipPipPip
  • 6,728 posts

Posted 24 March 2012 - 03:33 AM

it may be a faulty driver/kernel which make it sleep in the wrong moments (while te screen is alive for example)?

If you appreciate my work and would like to support me with a donation you can follow this link. Thank you very much.

* Actions ATM7029 - CM10.2 - CM10.1 - AOKP (4.3) - AOKP (4.2) - ParanoidAndroid (4.3)
* Allwinner A31 - OmniRom 4.4 - CM11 - CM10.2 - CM10.1 - CM10 - AOKP (4.3) - AOKP (4.2) - ParanoidAndroid (4.3) - ParanoidAndroid (4.2)
* Amlogic 8726-MX - OmniRom 4.4 - CM11 - CM10.2 - CM10.1 - CM10 - CM9 - AOKP (4.3) - AOKP (4.2) - ParanoidAndroid (4.3) - ParanoidAndroid (4.2)
* Allwinner A10 - CM10 - CM9 - AOKP

tmF4C.png


#8 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 24 March 2012 - 04:49 PM

There might be a slight issue with the power management chip.
I suggest you do this:
1. Fully charge your tablet.
2. Flash latest firmware from www.aoicoo.com.
3. Fully discharge the tablet by letting it play a movie for instance. Just let it do some stuff with full brightness and wifi ON.
4. Fully charge it.
5. Again fully discharge it.
6. Fully charge it.
7. Use it like you would use it.
8. Post back if you have any problems :)

#9 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 27 March 2012 - 08:13 AM

There might be a slight issue with the power management chip.
I suggest you do this:
1. Fully charge your tablet.
2. Flash latest firmware from www.aoicoo.com.
3. Fully discharge the tablet by letting it play a movie for instance. Just let it do some stuff with full brightness and wifi ON.
4. Fully charge it.
5. Again fully discharge it.
6. Fully charge it.
7. Use it like you would use it.
8. Post back if you have any problems :)

i have charged and discharged it several times.. but not discharged completely only to about 7% or so.. do i have to drain it completely till it turns itself off?
willing to give anything a go.. i'll try it.

Edited by coreo, 27 March 2012 - 08:15 AM.

Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#10 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 27 March 2012 - 03:09 PM

i have charged and discharged it several times.. but not discharged completely only to about 7% or so.. do i have to drain it completely till it turns itself off?
willing to give anything a go.. i'll try it.

Well, a full discharge means 0% :lol:
That 7% may actually mean 20% or even 30%, so let it die! :good:

Edited by LVL, 27 March 2012 - 03:10 PM.


#11 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 27 March 2012 - 11:44 PM

Well, a full discharge means 0% :lol:
That 7% may actually mean 20% or even 30%, so let it die! :good:

something weird is going on, on my second discharge from about 13% down the screen has turned it's brightness down all by itself and when i go and try and put it back up it puts it down itself..too about a 1/4 brightness.
then popped up saying low battery plug me in, then at 7% it powered itself off and it wont reboot.

anyway going to fully charge it now and see how it goes on my final charge..

don't know if this helps but here's a list of my voltages as it discharged;

72% 3934mv
63% 3885mv
56% 3848mv
47% 3810mv
42% 3781mv
41% 3786mv
36% 3770mv
29% 3744mv
15% 3687mv
12% 3644mv
10% 3642mv
9% 3637mv
7% powered down..something funny is going on with power management!!

i'll let you know if anything is better once i've charged it again.

Edited by coreo, 28 March 2012 - 12:04 AM.

Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#12 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 28 March 2012 - 11:58 AM

something weird is going on, on my second discharge from about 13% down the screen has turned it's brightness down all by itself and when i go and try and put it back up it puts it down itself..too about a 1/4 brightness.
then popped up saying low battery plug me in, then at 7% it powered itself off and it wont reboot.

anyway going to fully charge it now and see how it goes on my final charge..

don't know if this helps but here's a list of my voltages as it discharged;

72% 3934mv
63% 3885mv
56% 3848mv
47% 3810mv
42% 3781mv
41% 3786mv
36% 3770mv
29% 3744mv
15% 3687mv
12% 3644mv
10% 3642mv
9% 3637mv
7% powered down..something funny is going on with power management!!

i'll let you know if anything is better once i've charged it again.

That actually looks pretty good. The values are degrading every step. Sometimes, for example, 60% = 3800mV and 58% = 3820mV. These things happen. It's up to the power management to set the right % at the right mV reading. This is called battery calibration. This is done by doing the recharge sequence I told you before. Doing it more times means a better calibration. It's especially important that you fully charge the battery. I don't mean charge it to 100%, I mean charge it at least for 2 hours after it says 100%. This way you are sure that the li-ion battery voltage is maxed out.


Good luck!

#13 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 29 March 2012 - 07:30 PM

No it's still dicky as i say again really bad under 15% charge..unusable.
However it works fine if i turn wifi off under 15% battery and will run flat with no freezes at all, don't know if it's driver problem or hardware. or power management chip or drivers...
i've noticed it does get hotter as the battery goes down less than 20-15% aswell, whilst wifi is on.
Anyway really frustrated with this problem, any help would be great i'll try anything..
Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)

#14 LVL

LVL

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 339 posts

Posted 30 March 2012 - 05:06 AM

No it's still dicky as i say again really bad under 15% charge..unusable.
However it works fine if i turn wifi off under 15% battery and will run flat with no freezes at all, don't know if it's driver problem or hardware. or power management chip or drivers...
i've noticed it does get hotter as the battery goes down less than 20-15% aswell, whilst wifi is on.
Anyway really frustrated with this problem, any help would be great i'll try anything..

I am thinking this is a hardware failure. It probably has to do with low power that can't deliver enough power to the whole tablet.
Still, it could be the power management chip that is failing. I guess you got a bad manufactured unit.
Or the voltage could be to low to drive the goodix chips or the microcontroller next to it.

Edited by LVL, 30 March 2012 - 05:07 AM.


#15 coreo

coreo

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 224 posts

Posted 05 April 2012 - 08:34 AM

finally given in.. I've sent it back to China Grabber .. i tried everything ... hopefully they honor their warranty..can't wait for a working one... :-(
Devices
-Icoo D90w 9.7 inch ips A10 (good screen. but slow)
-Onda Vi30 8 inch (AML8726-MX A9 dual core)
-Ramos w17pro 7 inch (AML8726-MX A9 dual core)
-Samsung Galaxy 7.7 gt 6810 (Samsung Exynos 4210,beautiful screen)
-Ipad Mini ( don't know what all the hype is about...like android much better)
-Chuwi v88 (7.9 inch rk3188)
-Ifive x2 (8.9 inch rk3188)
-Ramos i9 (8.9 inch intel z2580)
-Nexus 5
-Teclast p89(7.9 inch intel Z2580.. little beauty)