Jump to content


Aurora - USB 3G Data Sticks (UMTS) - Compatibility


  • Please log in to reply
56 replies to this topic

#21 frmbhb

frmbhb

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 170 posts

Posted 14 March 2012 - 04:39 AM

I'm in India, have USB datacard (tataphoton plus) (i believe its not 3G). I use this on my laptop and pc to connect to internet. This has a setup which needs to be installed in windows based PC/Laptop.

will this work on Aurora. The dongle is Huawei EC1260 HSIA usb Stick.

Any idea on how to make this work on Aurora.

Thanks in advance.

#22 Sendy

Sendy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 48 posts

Posted 14 March 2012 - 07:41 AM

Hi Koncsik,

Can I ask where in android settings did you enable the 3G stick? I am a newbie and also want I ask how to use 3G on Aurora. Thanks

#23 Joosth

Joosth

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 132 posts

Posted 14 March 2012 - 03:49 PM

Also E230 reported to work.. any1 tryed E1750 yet

Sent from my GT-I9100 using Tapatalk


Huawei E1750 works here.
Ainol Novo 7 Advanced / Ainol Novo 7 Advanced II / Ainol Novo 7 Elf / Ainol Novo 7 Elf II / Ainol Novo 7 Aurora I / Ainol Novo 7 Aurora II / Ainol Novo 7 Fire / Ployer Momo 9 Enhanced / Onda Vi40 Elite / OEM Eken A90 Advanced / OEM Visture V3

#24 jiggykillauk

jiggykillauk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 237 posts
  • LocationLondon UK

Posted 14 March 2012 - 05:20 PM

Huawei E1752 doesn't/didn't work for me on any firmware I've tried, it just didn't , but the E156G works flawlessly. I'm in the UK by the way.
Tablet C8 Running Tsunami v1.9- Almost retired
My Novo7 Aurora arrived from China today 23/2/12!!!-Sold

My C8t/A8T arrived from China on wed 6/6/12- close to retiring
My Aurora II was PURCHASED in the UK

Sony Tablet S {4.03r5a}

#25 frmbhb

frmbhb

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 170 posts

Posted 14 March 2012 - 11:10 PM

Can you tell me how to save apn settings. Once I give apn name, user name etc. it does not allow me to save. Only 2 options, new apn and reset to default. If I tap on new apn, and give details, it doesn't have any save button.

Any idea how to do this?

#26 jiggykillauk

jiggykillauk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 237 posts
  • LocationLondon UK

Posted 15 March 2012 - 06:32 AM

When you plug the dongle in, if it's supported the aurora does all the work for you! It would list all available apn and you just choose the right one from the list
Tablet C8 Running Tsunami v1.9- Almost retired
My Novo7 Aurora arrived from China today 23/2/12!!!-Sold

My C8t/A8T arrived from China on wed 6/6/12- close to retiring
My Aurora II was PURCHASED in the UK

Sony Tablet S {4.03r5a}

#27 frmbhb

frmbhb

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 170 posts

Posted 16 March 2012 - 01:06 AM

When you plug the dongle in, if it's supported the aurora does all the work for you! It would list all available apn and you just choose the right one from the list


Thank you. And then it appears my dongle doesn't work.

#28 Sendy

Sendy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 48 posts

Posted 16 March 2012 - 06:17 AM

When you plug the dongle in, if it's supported the aurora does all the work for you! It would list all available apn and you just choose the right one from the list


Damn. So it means my expensive 3 g dongle does not work

#29 jiggykillauk

jiggykillauk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 237 posts
  • LocationLondon UK

Posted 17 March 2012 - 12:32 PM

Damn. So it means my expensive 3 g dongle does not work

If you have pin enabled on your sim card you will need to disable it and did you scan for available apn? if its not supported, it should give you an error message. <_< my e1752 didn't work so I guess its not supported yet.
Tablet C8 Running Tsunami v1.9- Almost retired
My Novo7 Aurora arrived from China today 23/2/12!!!-Sold

My C8t/A8T arrived from China on wed 6/6/12- close to retiring
My Aurora II was PURCHASED in the UK

Sony Tablet S {4.03r5a}

#30 koncsik

koncsik

    Member

  • Jr. Member
  • PipPip
  • 21 posts

Posted 17 March 2012 - 04:47 PM

Hi Koncsik,

Can I ask where in android settings did you enable the 3G stick? I am a newbie and also want I ask how to use 3G on Aurora. Thanks

Sorry for the delay (official holiday in my country)
I tried:settings/ wireless & networks / more... - mobile networks: when touching this it says: Unfirtunately, Settings has stopped.
Good luck
But I think normally I shouldn't do anything, you just plug in 3G stick and it works without any abracadabra.

Edited by koncsik, 17 March 2012 - 04:49 PM.


#31 Sendy

Sendy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 48 posts

Posted 17 March 2012 - 10:15 PM

If you have pin enabled on your sim card you will need to disable it and did you scan for available apn? if its not supported, it should give you an error message. <_< my e1752 didn't work so I guess its not supported yet.


My sim has no password. My stick is dlink brand.

I finally got my Huawei E156 to work! Dlink does not work ;(

Edited by Sendy, 20 March 2012 - 01:15 AM.


#32 jiggykillauk

jiggykillauk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 237 posts
  • LocationLondon UK

Posted 20 March 2012 - 01:40 PM

I can also confirm that the E169G works. Took me a few tries after unlocking the dongle.
Tablet C8 Running Tsunami v1.9- Almost retired
My Novo7 Aurora arrived from China today 23/2/12!!!-Sold

My C8t/A8T arrived from China on wed 6/6/12- close to retiring
My Aurora II was PURCHASED in the UK

Sony Tablet S {4.03r5a}

#33 Sergey_F1

Sergey_F1

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 97 posts

Posted 21 March 2012 - 06:28 AM

Setup for not supported 3G USB Modem from ExIM@4pda.ru
Sorry for Chrome translation. You can find original post (Russian) here.

Setup for not supported 3G USB Modem! from ExIM@4pda.ru

So Experimental: Ainol Novo 7 Aurora c Android 4.0.3 0.6V to androkun + ZTE MF626 advance unlocked to any network (you can do without unlocking).

Step One: Defining Modem and its Model Vid / Pid.


To determine the modem we need to know the vid / pid. If you have Linux user , this data you can get by typing in the console

$ Lsusb
If you have Windows user , I can not accurately describe the receipt of these data, and just advise you to download a utility called Market Usb Device Info from the developer alt236 . After installation, connect the modem to the USB port on your tablet.
In the utility, right, tab, Linux, and (probably 1-1) this will be your modem. Otherwise, hit upon a logical port to which your modem is connected with the name of ZTE and Huawei. Show will be on your case. My log of this program:
Device Info 
Device Path: /sys/bus/usb/devices/1-1/
Device Class: Use class information in the Interface Descriptors (0x0)
Vendor ID: 19d2
Vendor Name (reported): ZTE, Incorporated
Vendor Name (from DB): 
Product ID: 0016
Product Name (reported): ZTE CDMA Technologies MSM
Product Name (from DB): 

Additional Info 
USB Version: 2.00
Speed: 480
Protocol: 00
Maximum Power: 500mA
Serial Number:

Remember the Vendor ID (aka vid): 19d2; and Product ID (pid): 0016. Please note, your vid / pid will be different!

[Edit System Files]
WARNING: Further actions you perform at your own risk! None of them are liable, except yourself!
We need ES File Explorer.
In the settings you want to allow root access, and allow the system to change the data!

[Edit first file 3g_dongle]



In Explorer, open the file ES / etc/3g_dongle.cfg Open Text as needed, and preferably in the ES Editor!
At the end of the file add:

[MF626]
dongle_name=MF626
production_name=MF626
vendor_name=zte
network_type=GSM_MODE
pid_vid_origin= 0x19d20016
bcdDevice_origin=0x0
pid_vid_now= 0x19d20016
bcdDevice_now=0x0
at_port=2
ppp_port=0
Replacing the data on your own. Instead, you write your MF626 modem model, and so on. BUT! For some reason, then the sequence specified pid / vid where pid is asked to write to the vid, which is wrong! And the very definition of the device goes through the sequence, first vid, then the pid. Therefore, ignoring the recommended sequence, pid_vid you fill in like this pid_vid_origin = 0xVidPid


[Create a configuration file for your modem]


Create the file / etc / usb_modeswitch.d / vid _ PID substitute in the name of your vid / pid. contents of the file:

######################################################## 
# ZTE MF626

DefaultVendor= 0x19d2
DefaultProduct=0x0016

TargetVendor= 0x19d2
TargetProduct= 0x0016

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

CheckSuccess=20
Vendor - Substitute Vid, Product - Pid. Save.

[Settings APN]

Copy the file / etc / apns-conf.xml in a safe place, open the original file and delete all that is.
leave only the data for your operator (the most important thing - MCC & MNC) - even though they appear automatically after podklyuchetsya modem to the network. Go to the APN settings and add your data operator. The most important thing to enter a name, apn, mcc mnc (these two parameters should be automatically setted the modem finds a network).



#34 Polv89

Polv89

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 86 posts

Posted 21 March 2012 - 10:22 AM

Huawei E1750 work?
thanks

#35 TheJoker71

TheJoker71

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 21 March 2012 - 10:53 PM

My USB dongle is MF627... when i plug it to my aurora it goes to initialize then on standby... when i check my mobile network i have a list of APN then select the one who have internet access... after that... nothing... my aurora just sit there doing nothing... my usb dongle seems waiting for any instruction to connect... status LED is okay... recheck my mobile network... APN still there and selected...

how come? is the MF626 solution will work? but i thought that method is for something nothing happens or not detected or not compatible in the aurora... mine seems detected by aurora but it seems doing nothing...

AURORA 4.03 the latest from official ainol March 7, 2012...

thanks a lot...

#36 TheJoker71

TheJoker71

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 22 March 2012 - 12:28 PM

I tried sergey_f1 solutions... modify all the files and follow all the steps... but still cannot get a connection... hope someone can englighted some solutions...

thanks

#37 chepito

chepito

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 118 posts

Posted 23 March 2012 - 01:12 AM

I tried sergey_f1 solutions... modify all the files and follow all the steps... but still cannot get a connection... hope someone can englighted some solutions...

thanks


Me too, no succes with MF110, something missing.

#38 TheJoker71

TheJoker71

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 23 March 2012 - 01:47 AM

Based on sergey_f1 solutions, i found out that there is also a duplicate files on our AURORA...

one inside /etc/ folder and one inside /system/etc/ folder also...

i will try to edit both folder if this will solve the problem with not connecting with other usb dongle...

stay tuned...

#39 chepito

chepito

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 118 posts

Posted 23 March 2012 - 02:33 AM

Based on sergey_f1 solutions, i found out that there is also a duplicate files on our AURORA...

one inside /etc/ folder and one inside /system/etc/ folder also...

i will try to edit both folder if this will solve the problem with not connecting with other usb dongle...

stay tuned...


It's the same folder mounted twice

#40 TheJoker71

TheJoker71

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 59 posts

Posted 23 March 2012 - 10:14 AM

yup... figure it also when i tried... thanks for the headsup...

still no success in using my 3g dongle modem... hayysss...