Jump to content


Photo

WEP WIFI connection OK?


  • Please log in to reply
10 replies to this topic

#1 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 04 October 2011 - 12:21 PM

I have Hannspad 10.1 with Flashback 8.1
Connects fine to my WIFI and says it is WPA/WPA2 PSK.

Went to mates house and try connecting to their network. Pick it, type in password and it forever says obtaining IP.
Theirs is reported as WEP.
Iphone connects straight away to theirs if password is entered (hence password is OK).

Is there some extra setting or issue with WEP?
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#2 alga

alga

    Newbie

  • Jr. Member
  • Pip
  • 8 posts

Posted 05 October 2011 - 08:22 AM

I have Hannspad 10.1 with Flashback 8.1
Connects fine to my WIFI and says it is WPA/WPA2 PSK.

Went to mates house and try connecting to their network. Pick it, type in password and it forever says obtaining IP.
Theirs is reported as WEP.
Iphone connects straight away to theirs if password is entered (hence password is OK).

Is there some extra setting or issue with WEP?



I'm running Flashback 8.1 on a WEP network. It may be that your friend is on WiFi Channel 13 or 14 which is an issue with most custom ROMs. When I first put Flashback on I couldn't connect as my network was on 13. Changing channels fixed it.

#3 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 05 October 2011 - 10:09 AM

I'm running Flashback 8.1 on a WEP network. It may be that your friend is on WiFi Channel 13 or 14 which is an issue with most custom ROMs. When I first put Flashback on I couldn't connect as my network was on 13. Changing channels fixed it.

Thanks. I had read that using AUTO on the router caused problems as it might pick 12 or 13.
I don't really want to start messing around with his router, but if no other choice I shall ask.

Just after I wrote that my WPA connection was fine, I then lost it for an hour and it would not find my connection.
I had hidden SID and it just sat there saying my network was out of range even though iphone was happy to find it.
I thought I too was suffering from the virgin router being on auto sowas about to pick a channel when I tried turning on SID.
My tablet immediately saw the connection no trouble at all.

The WEP wifi is also visible SID, so can't use that trick there.
Will try more tonight.
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#4 redd7333

redd7333

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 05 October 2011 - 10:42 AM

i just brought a craig 7" touchscreen tablet and i can't seem to connect to the internet and ideas?

#5 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 06 October 2011 - 12:38 PM

i just brought a craig 7" touchscreen tablet and i can't seem to connect to the internet and ideas?

Why not start a new thread (as its not related this this one). Is there a Craig forum?
Gather up info about what steps you took, what screens you saw, what was expected, and what error message you had.
Hope you get this sorted. We are here to help each other.
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#6 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 06 October 2011 - 12:46 PM

Further tests were done at mates.
He has a Belkin router. Not sure if it is set on auto channels or fixed. I cant find the channel number.
If the router was 14, then I presume the hannspad just does not see it at all.
However I do see the named wifi, and can click it to then enter a password.
Does this mean it is not a problem with an out of range channel?

Tablet reports:
Authentication is WEP
connected at -1Mbps (whereas my laptop is at 56Mbps, and tablet at home is 30Mbps)
Strength is: Poor (even when I go in same room. Other devices such as iphone and laptop say GOOD)

Tablet at home says:
WPA/WPA2
30Mbps
GOOD

What does this lead to? Should I change belkin for another? I do have a spare netgear so could try doing piggy back out of that to run a WPA signal, as well as their existing WEP.
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#7 NightSt@lk3r

NightSt@lk3r

    Member

  • Jr. Member
  • PipPip
  • 19 posts

Posted 06 October 2011 - 01:06 PM

I get the same problem with WEP encryption on my Hannspad and Netgear router, encryption disabled or WPA/WPA2 works fine, but with WEP it just hangs on obtaining IP address.

Roms tested GtabComb 3.3 refresh, Vegacomb 3.2 alpha

Tablet reports:
Authentication is WEP
connected at -1Mbps (whereas my laptop is at 56Mbps, and tablet at home is 30Mbps)
Strength is: Poor (even when I go in same room. Other devices such as iphone and laptop say GOOD)

This is exactly the same as what my Hannspad reports when WEP is enabled.

Edited by NightSt@lk3r, 06 October 2011 - 01:08 PM.


#8 punchafeng

punchafeng

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 07 October 2011 - 11:41 PM

To use the Wifi, i have to clear the WEP password, seems it is a known issue.

#9 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 09 October 2011 - 06:31 AM

To use the Wifi, i have to clear the WEP password, seems it is a known issue.

Do you mean disbale WEP like nightst@lker suggested?
Wonder how Alga managed to get WEP working in flashback 8.1
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#10 Simon Hughes

Simon Hughes

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 13 October 2011 - 10:45 AM

Just did some further tests. The router that fails is Belkin N1 in WEP mode.
The signal might be auto or manual channel. I used an android wifi scanner app and see it is channel 11.
If I forget the connection it shows up as good signal.
I read another forum about wifi problem: http://android.modac...i-wont-connect/
So tried using static ip, 192.168.0.33, mask 255.255.255.0, length 24, dns blank
It still said obtaining IP and didn't progress.
The only other tricks I read was to reboot router AFTER android sees it.
Also to change a setting in router to enable anonymous access.
I can't do either of these as I don't want to go messing with the router.
Maybe someone will get a result with it.
Hannspad 10.1 1653, Flashback 8.1, ab_kernel4alpha6, ClockWorkMod Recovery v4.0.1.4

#11 mossy500

mossy500

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 13 October 2011 - 10:25 PM

this has happened to mine a few times, normally i just disable and re enable the wifi and it connects.