Jump to content


Photo

Newbie struggling to upgrade out of build 1030


  • Please log in to reply
11 replies to this topic

#1 Tomen8r

Tomen8r

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 30 August 2011 - 06:26 PM

Model ZT180102ASRTA1020S6. It is a 512/2 GB pad. Firmware android2.1-update 1 – 20101030 / Kernel 2.6.32.9 usbandroid = 1608

Hi .. I am a relative newbie with several questions. What is the best way to flash my epad? I can’t flash using the TF micro-SD card slot. I rec’d this as a Xmas gift last year. After opening the box, I quickly realized it was useless out of the box. Too slow (Ex. Push settings icon, wait up to 2-3 seconds for highlight and audible click. Then wait up to 2-3 seconds for settings screen to appear. Most of the time the settings appeared. Other times it went back to where I started). It is next to impossible to swipe up/down and left/right, as it takes 5 seconds of moving finger to make it work. It is too slow to use without nothing really loaded on it. It is stock except for the firmware upgrade of 8 months ago.

Model ZT180102ASRTA1020S6. It is a 512/2 GB pad. Firmware android2.1-update 1 – 20101030 / Kernel 2.6.32.9 usbandroid = 1608

After a month, I used the burntool to upgrade to 1030 from the Zenithink site. No issues. No change in speed. I understand I can’t use the burntool for the newer builds (or shouldn’t). I think I will have to as the flash card (3 of them) isn’t recognized (Kingston, Sandisk but large 16 and 32 gb cards). I have version 1, as you can see by my model #. I haven’t opened it up and probably won’t open it up. It will never go back together right if I do open it up. Chances are it is version G0, as it is kinda old now (November purchase, October build). I would use the burntool but I don’t know which files should go in which settings screen. If the tool was in English, I might be able to figure it out.

I have spent about 24 hours (16 hours testing, 8 hours reading these threads) and have tried just about everything. My flash card isn’t recognized. After each being formatted in Fat32 dozens of times. I have tried many of the boot up flash tricks (power/round button – power / down volumn, etc) to no avail. When I hit the power/round button, the screen goes black for about 5 minutes before normally booting. Using the volume button does nothing as it boots up normally. I tried using just the zt-update folder, in the root, loaded with *.spl files only to see which one would load and nothing happened. I have tried multiple builds using multiple versions of files, according to this site, and placed all files in the zt-update folder. I have tried every build out there (downloaded from multiple sites) and I can’t flash from the TF card slot. Period.

I looked for the mnt/sdcard folder but can’t find it. And without a flash card in the TF slot, I can’t see any files in ES File Explorer anymore. With OI File Mgr, I can see the nand directory but no /mnt directory. The udisk directory is empty. I was hoping the *.img file (located in the mnt/sdcard folder ) deletion trick I read on this forum would help, but a search came up empty.

I think I can’t upgrade to a newer build using a micro sd flash card until I reach a certain build point. I could be wrong. With my model info, could you please point me in the right direction and instruct how to upgrade using the burntool utility. I need to know which files are entered in each of the five linux command boxes. Or if you believe I can upgrade using the TF slot, please let me know. I have a feeling I will have to upgrade, then upgrade, then upgrade again using the TF flash method.

Thanks, so much, for your assistance. :clapping: :clapping: :clapping: I have spent some time on this forum. I probably missed a key step somewhere along the line. As the forum goes back in time, it can get a little confusing after several days of reading all this stuff …

Model ZT180102ASRTA1020S6. It is a 512/2 GB pad. Firmware android2.1-update 1 – 20101030 / Kernel 2.6.32.9 usbandroid = 1608

Sincerely,

Tomen8r

#2 omarahum

omarahum

    Zenithink Tablet User / Information Transmitter

  • Global Moderators
  • 6,520 posts
  • LocationNYC

Posted 30 August 2011 - 06:48 PM

Did you read my response to your initial post in the 0503 ROM thread? - http://www.slatedroi...320#entry228697

Hey All ..

I am in need of help.. 20 hours and I am still stuck with the same pos I rec'd when I first opened this box (click on an icon, wait 2-4 seconds before icon lights up and clicks. 6-10 seconds later the app might eventually launch, but many times it just goes back to the main screen). I am trying to salvage this piece of crap. have followed every step in this thread to no avail. I can't boot from the flash drive.

I have read this thread 5 times. I have tried the various files/folder configurations using an sd card listed on this thread. When I power up the pad, nothing flashes. It just boots up normally. I have tried pressing all the buttons at one time or another. I tried pushing the front button when I see the ePad logo, when I see the linux penguin, when I see the small android text and when I see the flashing animated android text. Rinse and repeat for every button on this thing. I have tried adding/removing various versions of files per this thread. My flash drive isn't being recognized and I rec no errors. Over 100 times, the pad has just booted normally. I figured I would waste another day during Hurrican Irene. I was successful in that aspect.

Is it because I have such an old build? Firmware is 20101030. Kernel is 2.6.32.9 USBandroid #1608 and it's running android 2.1 Is it possible for me even to flash using the sd card????? I don't think so at this point. I have tried flahsing with the sbl file .. I have looked at other forums but there is a lot of conflicting stuff out there. I just want Froyo 2.2 on this thing to see if it actually works. In the current state, this pad is so slow it is useless. It shouldn't take 20 seconds to executed one command at a time ... I have the 512k / 2MB model ..model is ZT180102ASRTA102086 and I have not opened it up ..

Thanks in advance for your input. And I apologize for this negativity. It has been a frustrating 10 hours trying to flash this thing today. All I want to do is see if it actually works normally ...

;-)


Yeah, if you have an original 10" ZT-180 (256MB RAM/2GB internal nand storage) and currently have the 20101030 ROM on it, you don't have SDcard flashing capability yet (btw, when you do, you have to turn on the tablet and then press the left volume/toggle key when you see the Epad logo to enter flashmode).

You will first need to use the burntool to update the spl (ZT_Bx.spl) from a later ROM (any from 1126 Beta to the 0324/0328), and then you will have sdcard flashability......

You will need to install the secbulk driver on a Windows 32 bit computer for the burntool (v7.41) to recognize the tablet when it's in flashmode, it's best to configure the burntool first and then attach the tablet and go into flashmode to give the tablet the greatest amount of time to finish the burning process - ore else the tablet may come out of flashmode before the process completes. To enter flashmode on the 1030 ROM or earlier, you need to hold the round button in front and then turn on the tablet - the tablet's screen will be dark, but if you attached the tablet to the computer via the OTG USB, Device10 will turn green in the burntool.

You can read through the older ROM threads or the wiki if you need more info, or maybe this thread may help you - http://www.slatedroi...rom-fware-1030/


zenithinklogosforsignature3.png
Zenithink ZT-180-101 Original 10" Epad (Ruby 1.2 / 576 - B0) (0603 Froyo) - {July 2010} R.I.P. - May 2013
Zenithink ZT-180-701A 7" Upad (Cameo - E3) (0613/0618 Froyo) - {April 2011}
Zenithink ZT-180-102 10" v2 Zepad (Jade 2.3-Blue - G0) (0613/0618 Froyo) - {April 2011}
Zenithink ZT-280-C91 10" Zepad (H1_2n : 0217 GB
@ 900MHz w/ 2GB Data Partition) - {Sept. 2011}
Zenithink ZT-280-C71 7" Upad (E7_1n : 0217 GB @ 900MHz w/ 1.5GB Data Partition) - {Sept. 2011}
Zenithink ZT-283-C93 10" ZTPad (H6_1f : 0911 ICS w/ 2GB Data Partition and working (pl2303) USB GPS)
- {Oct. 2012}
Zenithink ZT-283-C97 9.7" ZTPad (I1_2a :
0910 ICS w/ 2GB Data Partition and working (pl2303) USB GPS) - {Nov. 2012}

SlateDroid ZT-180 WIKI \ Zenithink Website \ Zenithink FTP \ Stock ROMs \ ZT-28* Modified Kernels & RecoveriesM \ Donations Accepted!
If I've helped you or are using an overclocked kernel I've uploaded, and wish to help support my efforts, please consider leaving me a donation. Thank you!
btn_donate_SM.gif ॐ 
Please click on the Like This button for any posts you like or have helped you to show your appreciation...
Also know that all the staff here are volunteers, we don't get paid for our time spent here, so please be patient with us... Thank you!


#3 Tomen8r

Tomen8r

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 30 August 2011 - 08:12 PM

Thanks so much. I appreciate your quick response. I already have the driver installed on a Winxp machine and will try the steps above you mentioned. From there, I should be all set upgrading, but I will be quick to return to this great source of info for more guidance ... Thanks again.

Sincerely,

Tomen8r

#4 Tomen8r

Tomen8r

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 31 August 2011 - 08:20 PM

Thanks so much. I appreciate your quick response. I already have the driver installed on a Winxp machine and will try the steps above you mentioned. From there, I should be all set upgrading, but I will be quick to return to this great source of info for more guidance ... Thanks again.

Sincerely,

Tomen8r



I used my WinXp machine to run burntool 7.41 (yay, it is in English!). I loaded the ZT*.spl file only. The WinXP box would BSOD everytime, sometimes after 10 seconds or after 90 seconds, right after I click start for the burn. This happened 6 times. Ugh .. I then decided to add the files from build 324/328 along with the *.zpl file and got different results.

I would get the green light icon and I would see that the image file was running, the epad was recognized and burn was supposedly starting. But the progress bar never moved and eventually (after 10 minutes?) the Zt180 would boot normally, after spending 8 minutes in the discovery mode. I did the boot process correctly as the burntool registered the fact it communicated with the pad. I tried this another 10 times to no avail. From multiple BSOD’s to nothing happening. Turns out, the burn tool was running several processes. When I shut it down, it still ran in the background many times. And it thought it was still connected to the pad. And I couldn’t kill those processes unless I rebooted, regardless of the process-killing steps I took. So I had to reboot every time I tried the burntool once. What a pain …

I then realized I had a Win7 32 bit machine, out of the five I have. I installed the secbulk drivers, the pad was recognized and I instantly burned the new image (324/328). Success! Finally. I then updated using the TF flash card method to the 603 build. This pad is now brand new, as it works like it should, not like I rec’d it out of the box with the old build on it ..It is not slow anymore and it can now serve a purpose. What a frustrating few days with this thing ..I think we are good, even though I am finishing it up ... :yahoo: :yahoo:

Thanks again for your help. I did a ton of reading but you mentioned two items which triggered success for me, which I appreciate. I hope I can return the favor some day ..

Sincerely,
Tom

#5 Retro

Retro

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 04 September 2011 - 11:22 AM

I am new to the forums here so I'm not allowed to post until I respond to 3 post so I will post my question here as its along the same lines of help needed. :)


A friend of mine gave his son a zt-180 ePad for xmas and the kid doesn’t like it. I had never touched any kid of tablet before this so curious I started it up once to play with it for a few minutes and liked it even though it seems a bit sluggish. I asked to borrow it since the kids doesn’t use it. When I was using it briefly I do vaguely remember seeing it had Android os 2.2 on it. I shut it off and bring it home. Later at home I turn it on to see it load up to a black screen with ANDROID_ in white sitting there but nothing else.
The original model and serial sticker was luckily still on the epad.
Model: ZT180102ASRTA1020S6
Serial: SD101216N60000010464
I read a lot of forums and eventually found a OEM epad rom to try via http://www.mediafire...gnvh6q7nn9k95,1 just to get the tablet working again if nothing else. Burntool would start and just sit there never finishing the flash in even over an hour. So I using the sd card method with no issue what’s so ever. :) I had the pad up and running right after that, but now I am wondering if a newer rom and or adroid os version would help the speed a little. Even to remove a little of the sluggishness would be great.
I had found another rom to possibly upgrade to next via http://www.epad.hk/Specs.asp?M=ZT-180

The only rom description for the newest one I think I can use from that link is:

Original FW - Android - 2.2 - 0324 - Flash Support

If anyone knows of a newer one that is possibly safe to use and works well and speedy please advise me.

Thanks to anyone for any help you can give.



Right now this is the info I have on the epad:
MODEL: ZT180102ASRTA1020S6
SERIAL: SD101216N60000010464

Model number: zt180
Firmware version: 2.1-update 1
Kernel version: 2.6.32.9 usbandroid#1608
Build number: zt180-eng 2.1-update 1 ERE27 eng.root.20101204.113523 test-keys

#6 abtekk

abtekk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 301 posts
  • LocationGoole, United Kingdom

Posted 04 September 2011 - 01:04 PM

Later at home I turn it on to see it load up to a black screen with ANDROID_ in white sitting there but nothing else.
The original model and serial sticker was luckily still on the epad.
Model: ZT180102ASRTA1020S6
Serial: SD101216N60000010464

If anyone knows of a newer one that is possibly safe to use and works well and speedy please advise me.

Thanks to anyone for any help you can give.


Try out my custom rom, find it here:
http://www.slatedroi...astest-release/

It is very fast to use, and very stable. It can be flashed using the TFCard method.

Edited by abtekk, 04 September 2011 - 01:04 PM.

My projects

Abtekk's Custom ROM - For ZT-180 V1.

Abtekk's Custom ROM - For ZT-180 V2.

Abtekk's Custom ROM - For ZT-280 C91

Project: Linux Reborn - BETA-3 (Debian) - For ZT-180 V1 + 2


#7 Retro

Retro

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 04 September 2011 - 03:29 PM

I just might try it abtekk. I flashed it again this morning to android 2.2 / kernel 2.6.32.9 / build 0324 and it will freeze after playing almost any game after 5 minutes or so requiring me to hit the reset button. The owner of this tablet doesn't care if I break it or not, but his kid is going to want to play games and that's unlikely the way it is currently. Everything else seems to work really well otherwise.



Try out my custom rom, find it here:
http://www.slatedroi...astest-release/

It is very fast to use, and very stable. It can be flashed using the TFCard method.



#8 abtekk

abtekk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 301 posts
  • LocationGoole, United Kingdom

Posted 04 September 2011 - 03:44 PM

I just might try it abtekk. I flashed it again this morning to android 2.2 / kernel 2.6.32.9 / build 0324 and it will freeze after playing almost any game after 5 minutes or so requiring me to hit the reset button. The owner of this tablet doesn't care if I break it or not, but his kid is going to want to play games and that's unlikely the way it is currently. Everything else seems to work really well otherwise.


May I ask what games?

My projects

Abtekk's Custom ROM - For ZT-180 V1.

Abtekk's Custom ROM - For ZT-180 V2.

Abtekk's Custom ROM - For ZT-280 C91

Project: Linux Reborn - BETA-3 (Debian) - For ZT-180 V1 + 2


#9 Retro

Retro

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 04 September 2011 - 04:01 PM

Ok.. well that didn't go so well. I used your 3.6 release and it looks like nothing has changed except now I have no touch screen function at all.

The games where Dungeon Hunter, and Shoot Bubble Deluxe.. I stopped trying after that.

When I ran the update via the sdcard the epad complained about not seeing a system or user pack img. Should I copy my old ones in with your files before I flash it?

Update: it seems the touch screen is working but with 15 to 30 seconds of lag.

Edited by Retro, 04 September 2011 - 04:35 PM.


#10 abtekk

abtekk

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 301 posts
  • LocationGoole, United Kingdom

Posted 04 September 2011 - 05:39 PM

Ok.. well that didn't go so well. I used your 3.6 release and it looks like nothing has changed except now I have no touch screen function at all.

The games where Dungeon Hunter, and Shoot Bubble Deluxe.. I stopped trying after that.

When I ran the update via the sdcard the epad complained about not seeing a system or user pack img. Should I copy my old ones in with your files before I flash it?

Update: it seems the touch screen is working but with 15 to 30 seconds of lag.


Oh, I see. The reason of that is because you need to update the SPL. Refer to the thread about updating to the 0603 ROM first and then flash mine again, that should solve your issue.

http://www.slatedroi...gb-22-rom-0603/

(Please be careful when flashing the SPL, if it goes wrong the ePad will be rendered useless. But it needs to be done anyway if you wish to update as your on an old firmware.)

Edited by abtekk, 04 September 2011 - 05:43 PM.

My projects

Abtekk's Custom ROM - For ZT-180 V1.

Abtekk's Custom ROM - For ZT-180 V2.

Abtekk's Custom ROM - For ZT-280 C91

Project: Linux Reborn - BETA-3 (Debian) - For ZT-180 V1 + 2


#11 Retro

Retro

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 04 September 2011 - 06:39 PM

Ok sounds good... I should flash the SPL alone 1st right? Just the spl in the zt-update folder correct or can I do the SPL with everything else before flashing yours again?

Also right here in the wiki for zt-180 it says:
"DO NOT put the ZT_Bx.spl file in your /sdcard/zt-update folder, flashing spl from sdcard can brick the device)"

Is this true? This is the only option that seems to work for me using the sdcard.

Update: Apparently i had a older version of burntool 7.2 so maybe thats why i could flash that way earlier? I used v7.42 with just ZT_Bx.boot & ZT_Bx.spl from the 0603 but it seems to work for a second then the tablet says:"Prepare enter mmc update mode" and at the bottom under that "Press ENTER when insert, other exit. No card insert!"

WTF.. lol Maybe I should just do it from the sdcard after all? I did end up opening it up to confirm it is a Zenithink Ruby_V1.4. I later tried to just update the 0603 ZT_Bx.spl via burntool and just failed.




Oh, I see. The reason of that is because you need to update the SPL. Refer to the thread about updating to the 0603 ROM first and then flash mine again, that should solve your issue.

http://www.slatedroi...gb-22-rom-0603/

(Please be careful when flashing the SPL, if it goes wrong the ePad will be rendered useless. But it needs to be done anyway if you wish to update as your on an old firmware.)


Edited by Retro, 04 September 2011 - 09:19 PM.


#12 Retro

Retro

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 04 September 2011 - 09:47 PM

..I just bit the bullet, put all the 0603 files in the zt-update folder on the sdcard including the 0603 spl and all went fine!