Jump to content


Photo

Please, help me get my head on straight!


  • Please log in to reply
7 replies to this topic

#1 RobP

RobP

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 14 August 2011 - 07:33 PM

Here's my new PD:

Hardware platform: RD101-2GB-W
Description: BPDN (Black PanDigital Novel)
Model: R70E200
Serial: 7013000311103551
Kernel Version: 2.6.27 Kobo@Android)
Firmware version: S64N_SLST_KOBO_BBB_2010_11_04

Went to the PD web site and used their PC app to upgrade the firmware. Chose the Canadian update (I'm in Canada) Not sure what it installed, but the Kobo app was removed a B&N app replaced it. The B&N app didn't run - crashed every time.

Found a posting somewhere offering a direct link to the proper fw for my Canadian system. Got my Kobo app back, although it took a lot of screwing around with moving files around to get my books and cover thumbnails back in place. No idea what will happen next time I buy a book: will it put the files in the right place, or will I have to screw around figuring out where they belong and manually move them?

My brother's PD gives him the ability to simply tap on the right side of the screen to turn the page in a book, which helps oversome the rather poor touchscreen sensitivity. However, he's had his for a while - I have no idea what model he has or what firmware rev.

The folks in this forum seem pretty knowledgeable: maybe you can help me get my head on straight regarding what to install, what not to install, and what I should or shouldn't be expecting...

Am I currently using the right (most current) firmware?
Should I be concerned about getting the Canadian firmware, or can I make this work for me with the U.S. version?
If I did install a more recent U.S. package, could I get the Kobo app back on it (and uninstall the non-functional B&N app)?
Could I add my own PDF collection to it?
What are my other options for making this current/optimal?

I am a computer professional, but totally new to the Android OS. Interesting learning a new environment, but frustrating at times. (As learning always is...) I just don't have the time to spend constantly tinkering with it: I was lured to this device by its low price: I thought I'd be getting a low-end tablet at an eReader price. So far, after 5 days, I have been trying to get it working 100% of the time, and have had zero use of it.


Thanks for reading, and for any advice you can offer...


Rob P
London, Ontario
Canada

#2 edca2002

edca2002

    Advanced Member

  • Hero Member
  • PipPipPip
  • 188 posts

Posted 14 August 2011 - 08:22 PM

What firmware version does it say you have now? after the upgrade? I thought the latest Canadian version was 2011-06-02 (S64N_SLST_KOBO_PD_20110602.dat, from http://mirror.suppor...N_SLST_KOBO_PD/ ). I don't have that one installed though, so I can't be sure it has KOBO instead of B&N. The Canadian update from March 2011 got screwed up and had B&N for the reader, but it worked fine.

Mine also allows me to tap on the side of the screen to turn a page as well as swiping, but it has the B&N app.

If you're going to try to reflash again, you may want to try Terminander's version from this thread http://www.slatedroi...fw-with-market/ . It looks like you can install either reader, and you get the market and other goodies too. It's based on the latest Canadian upgrade from Pandigital.

I'm not sure what you paid for it, maybe you could just return it. Staples has the Coby Kyros 7" Tablet for $159 this week. That has to be worth a second look.

Edited by edca2002, 14 August 2011 - 09:17 PM.


#3 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 15 August 2011 - 03:35 AM

Nov 2010 is an older firmware. The upgrade through Pandigital should have given you June 2011 for the Canadian version.

Here is a post that leads to the lastest version or has an unlocked version. The unlocked version allows rooting, which gives you more control of your tablet.

http://www.slatedroi...724#entry203724

The link in edca2002 posts, is the June 2011 firmware with full Android Market, Gmail, YouTube, etc. It is based on the lastest Canadian firmware, but I have given you the option to install Kobo or Barns & Noble but not both. You need Market if you really want to enjoy Android. The only real difference between Canadian or US firmware is Kobo versus Barnes & Nobel.The reader apps are the same, just a different bookstore.

The Novel has an older version of Android ( 1.5 ), which does limit a lots of apps that can be installed. However you won't see a lot of difference in Android until you get 3.0 Honeycomb. But Honeycomb tablets start around $400.
Live is not the breath you take, but the moments that take you breath away. Country singer George Strait

#4 RobP

RobP

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 15 August 2011 - 05:23 PM

Thanks for your replies.

I am currently installing the trm_unlock_S64N_SLST_KOBO_PD_20110602.dat file. Renamed it (leaving out the trm_unlock_ part) and it seems to have installed.

Took a long time for the first reboot, but it seems fine now.

What is the trm install bb.zip file for? Do I need it?

I have another question, regarding the Bookshelf display. Book covers aren't right. What are the correct locations of the various files required for the Kobo / eReader apps to look pretty? (Not too fussy, am I?)

If there are any primers on using, working with, playing with, installing new things on the Novel, could someone send me the links? The more I play with it, the more interesting it becomes...

Thanks for your help - I appreciate your quick response...

#5 RobP

RobP

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 15 August 2011 - 05:46 PM

Strange, when I first run the Kobo app, there are 4 books on the Bookshelf, although I have (and the number in parentheses up top verifies) 10 of them.

If I do a search, using just the letter "e" as a search term, all the books appear, although the covers are almost all plain white instead of the proper graphics.

It all seems kind of buggy to me, although it's certainly possible that I've scrambled something by flashing and reflashing the firmware.

Thanks again for your guidance - it's much better now.


Rob P.

#6 edca2002

edca2002

    Advanced Member

  • Hero Member
  • PipPipPip
  • 188 posts

Posted 15 August 2011 - 10:25 PM

How did you load the books? Did you load the cover art files with the books? Are the cover files all small (<10K)?

My covers are in places like /PD_Novel/Digital Editions/Thumbnails/eBooks/Kobo. They are all .png files, although there are comments that seem to say .jpg should work, but they must have the same name as the book, and be <10K apparently.

Did you load the books before or after the firmware upgrade? Can you load the books again?

Is it possible you're looking at the "Favorites" bookshelf instead of the "All" bookshelf?

Edited by edca2002, 16 August 2011 - 09:42 AM.


#7 RobP

RobP

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 17 August 2011 - 06:36 AM

Some books were on the PD when it was new. I loaded a free one from Kobo (to see how it worked) then bought one (when I thought it was working).

Since then, I messed with the file structure (moving files around to try to get it right) and it's better than it was, but it's still now quite right. Some books have a white cover with text title that's hard to read, one or two look right, the rest show or don't show depending on something - mood or weather or something.

They were loaded before the unlocked firmware (trm_unlock_S64N_SLST_KOBO_PD_20110602.dat) was installed.

Be nice to celan up the file structure and get it all right.

Have started reading with it finally - I like getting to tap one side of the page to turn the page.

Reading the manual is a pain - I can't scroll down the Table of Contents. It just selects and opens a pageonthe screen, instead of allowing me to scroll down to a page further down.

I like the price of this thing, but it's not a very good quality device.

#8 edca2002

edca2002

    Advanced Member

  • Hero Member
  • PipPipPip
  • 188 posts

Posted 17 August 2011 - 02:59 PM

but it's not a very good quality device.


True dat lol.

I'm not sure what to say about the file structure. If all your books show up on your bookshelves they must be close to being in the right place. My previous post had the location of my cover files, I'm not sure if yours are in that place or not.

The table of contents should scroll. It does on mine. Not sure if you can try scrolling slower or something.

Good luck with it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users