Jump to content


Photo

has anyone tried using their tablet with a HUAWEI E220 HSDPA UTMS 3G USB MODEM yet?


  • Please log in to reply
43 replies to this topic

#1 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 07 August 2011 - 11:23 PM

I snagged a unlocked HUAWEI E220 HSDPA UTMS 3G USB MODEM off ###########. I'm hoping that this is one of the supported modems that most of the chipad sellers refer to, when they say their android tablet is 3G capable.

I'll report back and give my results.

if it works I'm going to have to figure out if it's possible to get a prepaid sim card just for data so I can use my tablet when I need it without having to pay for another account sim from my cell provider AT&T.

Edited by Van Da Man, 07 August 2011 - 11:24 PM.


#2 derekgarn

derekgarn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 136 posts

Posted 08 August 2011 - 05:34 AM

would be intresting to know

#3 A8Pad

A8Pad

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 10 August 2011 - 11:57 AM

No experience but most sites I've seen have always mentioned E220 and E1750 together as working for 3G tablets. I remembered reading a while ago that one was a newer version of the other (i think E220 was newer?)

Btw...once you get it and test it out, can you report back and just let us know the following:
1) whether it was plug and play
2) which network sim card did you use (i.e. ATT)
3) if it's not plug and play, steps you took to resolve.

I would like to have this info updated to the wiki.

Thanks!

#4 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 10 August 2011 - 07:49 PM

No experience but most sites I've seen have always mentioned E220 and E1750 together as working for 3G tablets. I remembered reading a while ago that one was a newer version of the other (i think E220 was newer?)

Btw...once you get it and test it out, can you report back and just let us know the following:
1) whether it was plug and play
2) which network sim card did you use (i.e. ATT)
3) if it's not plug and play, steps you took to resolve.

I would like to have this info updated to the wiki.

Thanks!


will do. I've got several new things for my tablet coming (a new micro sd 32 gb card for the external slot, a 2.0 bluetooth adapter to try to get it to sync with a bluetooth gps, and the 3g usb modem I mentioned here)


can't wait for them to get here but I bet it takes a couple of weeks for them to arrive. most stuff I've won off ########### that ships from china doesn't get in any hurry to arrive. I'm still pleased with how fast ********* shipped my tablet to me through DHL

#5 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 12 August 2011 - 12:53 PM

just a quick update. I'm still waiting for this item to come in the mail. I'll try to post my results after I get it in.

#6 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 16 August 2011 - 01:08 PM

I got it in the mail today.

not having a lot of luck with it. it appears to be related to the APN settings, as when I put my sim card from my AT&T cell phone in the huawei E220 device and plugged it into the tablet running dmesg in a terminal indicated that it recognizes the device as a 3G modem and doesn't have any problems with setting it up.

I went into the APN settings and saw that it had a entry for t-mobile, which I then removed and attempted to setup the APN info for AT&T

For what ever reason the system will not let you save the info, after I hit save the APN I entered doesn't show up on the list.

here is what I put in for the at&t apn

Name: AT&T
APN: wap.cingular
Proxy: leave blank
Port: leave blank
Username:WAP@CINGULARGPRS.COM
Password:CINGULAR1
Server: leave blank
MMSC: http://mmsc.cingular.com
MMS Proxy: wireless.cingular.com
MMS Port: 8 0 (no spaces)
MCC:310
MNC:410
APN Type: leave blank

Edited by Van Da Man, 16 August 2011 - 01:10 PM.


#7 derekgarn

derekgarn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 136 posts

Posted 16 August 2011 - 06:11 PM

have you tried this
Steps for Huawei modem:
1. Plug the modem into the pc. Wait for modem auto detection and driver installation.
2. Run Teraterm Pro or Hyper Terminal, select serial then search the assigned com port for your modem (usually have two...try one).
3. Type "ATZ at u2diag ^ = 0" then press enter. If an "OK" message is displayed then go to step 5. If no message is displayed go to step 4.
4. Restart Teraterm or hyper terminal, select the other com port assigned for the modem then repeat step 3.
5. Unplug the modem from your PC.
6. Plug the modem into Herotab mid 816 wait until the signal bar appears at the top task bar.
7. Go to Settings > Wireless & Networks > Mobile Networks > Network Operators
8. It will search available 3G networks in your place. Select your specific Network operator.
9. Then Go to Settings > Wireless & Networks > Mobile Networks > Access Point Names and press menu button then select New APN
10. Configure your APN
11. Scroll down and check whether the MNC and MCC numbers are there, if not, press the menu and select the discard and repeat the steps 7-10 (for new APN).
12. Save the new APN.
13. Activate APN by selecting it (until the green circle at the right side)
14. Wait for the 3G logo at the top task bar.
15. Open your internet browser and enjoy surfing the net.

note: when using hyper Terminal or Teraterm Pro you will experience that when you type at the text editor it seems like your Keyboard is disabled but it is not.

for the hyper terminal to see what you are typing go to file menu > Properties then on the displayed dialog go to settings tab then click ascii setup button then check the "Echo typed characters locally" and click OK.

for the Teraterm Pro: i just typed "ATZ at u2diag ^ = 0" even it seems that the keyboard is disabled then i pressed enter then an "OK" message is displayed. Then I continued through the steps and I've got my Huawei E153 working.

By the way ryannining post is in Indonesian/Malay language (I'm not so sure) so I use the Google translator then I rewrite the English translation of Google. I just tried his steps because I'm hopeless...there is no Huawei E1750 here in the Philippines and I like to use my Herotab Mid 816 when I'm outside my home or work.

one more thing: My Herotab is the Metal Version using 03/21/2011 firmware version from adrenalynn post here: http://www.slatedroi...rse-date-order/

Thanks. I hope it will work with yours.

Ryannining...thanks again man!!!

commands you can use to change your modem's settings:
posted by: ridingshark

AT^u2diag=0 (all off)
AT^u2diag=1 (CD on, SD off)
AT^u2diag=256 (CD off, SD is on)
AT^u2diag=255 (all on - including SD Card)
  • vagoscarcito likes this

#8 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 16 August 2011 - 06:53 PM

when I attempt to run the command at step 3 all it says is "no carrier"
I tried this will all of my available comm ports and it gives this error message and doesn't say OK
  • vagoscarcito likes this

#9 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 16 August 2011 - 06:55 PM

because it keeps recreating the T-Mobile US APN when I tell it to reset to defaults, it makes me wonder if my modem isn't locked to the T-Mobile network, which may cause me to file a dispute with paypal if this is the case as it was sold as a "unlocked" device

#10 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 16 August 2011 - 11:12 PM

update: I tried entering this command
AT^u2diag=0
on the modem while connected to it in hyperterminal and now when I connect it to my A816 and go into the mobile networks setting it's not timing out. I currently have a unactivated AT&T sim in the device and it's staying on the Searching dialog box with the spinning circle. I'm going to try it with my AT&T sim and will report back in a few minutes.

Edited by Van Da Man, 16 August 2011 - 11:17 PM.


#11 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 16 August 2011 - 11:26 PM

OK, no change. I had to cycle power to even get it to go to the neverending searching dialog with the spinning circle. I unplugged the modem swapped the sim and then replugged it in and kept getting an error. After restarting the tablet it's still searching just not finding anything.

#12 derekgarn

derekgarn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 136 posts

Posted 17 August 2011 - 03:15 AM

Could be that it is not unlocked and that is why
Its not working

#13 derekgarn

derekgarn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 136 posts

Posted 17 August 2011 - 08:41 AM

have a look here might be of some help to you
http://3g-modem.wetp...bid=uPTL79h0aY8

#14 A8Pad

A8Pad

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 17 August 2011 - 09:39 AM

have you tried this
Steps for Huawei modem:
1. Plug the modem into the pc. Wait for modem auto detection and driver installation.
2. Run Teraterm Pro or Hyper Terminal, select serial then search the assigned com port for your modem (usually have two...try one).
3. Type "ATZ at u2diag ^ = 0" then press enter. If an "OK" message is displayed then go to step 5. If no message is displayed go to step 4.
4. Restart Teraterm or hyper terminal, select the other com port assigned for the modem then repeat step 3.
5. Unplug the modem from your PC.
6. Plug the modem into Herotab mid 816 wait until the signal bar appears at the top task bar.
7. Go to Settings > Wireless & Networks > Mobile Networks > Network Operators
8. It will search available 3G networks in your place. Select your specific Network operator.
9. Then Go to Settings > Wireless & Networks > Mobile Networks > Access Point Names and press menu button then select New APN
10. Configure your APN
11. Scroll down and check whether the MNC and MCC numbers are there, if not, press the menu and select the discard and repeat the steps 7-10 (for new APN).
12. Save the new APN.
13. Activate APN by selecting it (until the green circle at the right side)
14. Wait for the 3G logo at the top task bar.
15. Open your internet browser and enjoy surfing the net.

note: when using hyper Terminal or Teraterm Pro you will experience that when you type at the text editor it seems like your Keyboard is disabled but it is not.

for the hyper terminal to see what you are typing go to file menu > Properties then on the displayed dialog go to settings tab then click ascii setup button then check the "Echo typed characters locally" and click OK.

for the Teraterm Pro: i just typed "ATZ at u2diag ^ = 0" even it seems that the keyboard is disabled then i pressed enter then an "OK" message is displayed. Then I continued through the steps and I've got my Huawei E153 working.

By the way ryannining post is in Indonesian/Malay language (I'm not so sure) so I use the Google translator then I rewrite the English translation of Google. I just tried his steps because I'm hopeless...there is no Huawei E1750 here in the Philippines and I like to use my Herotab Mid 816 when I'm outside my home or work.

one more thing: My Herotab is the Metal Version using 03/21/2011 firmware version from adrenalynn post here: http://www.slatedroi...rse-date-order/

Thanks. I hope it will work with yours.

Ryannining...thanks again man!!!

commands you can use to change your modem's settings:
posted by: ridingshark

AT^u2diag=0 (all off)
AT^u2diag=1 (CD on, SD off)
AT^u2diag=256 (CD off, SD is on)
AT^u2diag=255 (all on - including SD Card)

Hi,
slightly off topic question. If you did the disable CD stuff. Does this mean the USB Modem will only work for the Android Tablet. And no longer work for a Windows laptop as plug and play?

I would like to buy a USB modem so I can use it on my tablet and also on my Windows laptop. But if it can only work for one and not the other almost defeats the purpose :(

#15 derekgarn

derekgarn

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 136 posts

Posted 17 August 2011 - 02:47 PM

You just have to enable it again to use with windows

#16 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 17 August 2011 - 06:20 PM

have a look here might be of some help to you
http://3g-modem.wetp...bid=uPTL79h0aY8


I'll give that a try, it'll be a few days before I can report back on it.

#17 A8Pad

A8Pad

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 18 August 2011 - 11:39 AM

I'll give that a try, it'll be a few days before I can report back on it.

Try downloading APN Manager from Market. Hopefully that fixes the APN side of the issue.

#18 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 20 August 2011 - 01:28 PM

Try downloading APN Manager from Market. Hopefully that fixes the APN side of the issue.


it didn't help either unfortunately.

I was able to unlock the modem and I've successfully configured it to work with my ubuntu 10.04 OS on my netbook as a mobile broadband device so I know the modem itself is now working.

I'm not sure what else to try, it may be a limitation with how the firmware is configured, it seems to be hard coded to only want to work with a t-mobile APN. if you remove the default APN and attempt to manually add a new one it doesn't want to save the config and won't show up. using APN manager doesn't work either. after I select the Cingular MMS entry and close it I still don't have an APN when I check in the APN section under the settings.

#19 gert

gert

    Member

  • Jr. Member
  • PipPip
  • 14 posts

Posted 23 August 2011 - 04:46 PM

Have you tried to enter APN Type: default?
It can sometime be neccessary to make th tablet understand it is tp be used for something (ie. default AP). Might helo with it forgetting it . The fact that only T-mobile shows up, doesn't mean anything except that they didn't bother to include more ready-made APNs in the ROMs, so you have to enter the settings yourself. But of course, there could also be an error with the ROM, But I would rather think there is something wrong with your APN settings, they seem like rather ld wap apn-settings. Not all carriers are very good at updating APN info. If you have an ANdroid phone, you can edit the APN you use there, and see what settings are actually set.

#20 Van Da Man

Van Da Man

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 23 August 2011 - 10:16 PM

Have you tried to enter APN Type: default?
It can sometime be neccessary to make th tablet understand it is tp be used for something (ie. default AP). Might helo with it forgetting it . The fact that only T-mobile shows up, doesn't mean anything except that they didn't bother to include more ready-made APNs in the ROMs, so you have to enter the settings yourself. But of course, there could also be an error with the ROM, But I would rather think there is something wrong with your APN settings, they seem like rather ld wap apn-settings. Not all carriers are very good at updating APN info. If you have an ANdroid phone, you can edit the APN you use there, and see what settings are actually set.


I have a samsung captivate running the cognition 5.2 rom on the AT&T network. I did try duplicating the APN info from my phone but when I attempted to save the new APN it didn't show up, the only APN I am able to see is the default t-mobile us APN. if I remove it, can't add a new APN, if I change it and try to set the settings for the AT&T APN it disappears when I save it. if I tell it to reset to default settings then the t-mobile APN shows back up.

I have a feeling it is a problem with how the default ROM is configured




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users