Jump to content


Photo

Rk29xx ImageTools V2.1


  • Please log in to reply
89 replies to this topic

#81 Aiah

Aiah

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 106 posts

Posted 14 February 2012 - 09:42 AM

Could you do a quick write up on this?

I have extracted the boot image, made the changes that i needed, then used cpio to repack the files, then gziped the image.

When I run rkcrc, all seems fine, but after flashing the new boot.img over its a no go.


____________________

# find . | cpio --create --format='newc' > /tmp/newboot

# gzip newboot

# rkcrc -p newboot.gz boot.img

Any suggestions?

Thanks


I had to modify the rkcrc sourcecode to get it working on my fview 7" pro tablet
for the fview 7" the rom uses/checks for the header tag "KRNL", different brands might use differend HEADER's

--- check 1 ---
To see if rkcrc works for you

* extracht the "raw" cpiofile from the boot.img
- aka remove the first 8 bytes and last 4 bytes
p.s. at this point the the cpio file should unpack without errors/warnings

* apply rkcrc to the raw cpio
If everything works as it should the original boot.img and new boot.img should be identical, if not there no use i going on,because the bootload will refuse the boot.img.


--- check 2 ---
unpack and recreate the boot.img without any modification
the boot.img should work (and boot)

NOTES:
* Modifying boot.img can be a very tricky thing, a minor mistake can result in your device not booting

* Als using adb logcat during boot can give a lot of information on the boot process, and where it failes
Try it first of a working rom , because there are ofter a lot of errors/warning during the boot process that are "normal"

#82 clamel

clamel

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 17 February 2012 - 06:24 AM

I had a look at these cramfs images mentioned here and elsewhere - the ones that give "cramfsck: bad root offset (0)" and report as "empty filesystem" when trying to mount.

With this small patch to cramfs you can extract the contents with cramfsck -x.

-	u32 namelen:CRAMFS_NAMELEN_WIDTH, offset:CRAMFS_OFFSET_WIDTH;
+	u32 pad:8, namelen:CRAMFS_NAMELEN_WIDTH;
+	u32 offset:CRAMFS_OFFSET_WIDTH;


thank you very much my friend, you solved a big problem for me

#83 heedna

heedna

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 02 March 2012 - 11:59 PM

Use of modded update.imag can result in bricking your tablet. To unbrick see http://www.slatedroi...unbrick-a-t760/

#84 voivod

voivod

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 10 March 2012 - 10:41 AM

Noontec A9 solving the problem is on the Polish forumMy link.Post 51

Edited by voivod, 10 March 2012 - 11:36 AM.


#85 Noce

Noce

    Member

  • Jr. Member
  • PipPip
  • 17 posts

Posted 22 March 2012 - 09:07 PM

Hi all i would like to take a look at the new firmware of my tab window N50 end it works ok rk29 but this tool is for win right? how can i open firmware in ubuntu?

TY GUYS!!!

#86 jackpale

jackpale

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 15 April 2012 - 08:39 AM

I am still confused with my mid, after install chineffire now can not open any applications

#87 Logseman

Logseman

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 122 posts
  • LocationTenerife, Spain

Posted 28 August 2012 - 05:15 PM

Maybe this borders necromancy, but I feel it's important to say it: your tools work perfectly with RK3066 devices as well! thanks a lot, Wendal!
  • Aino likes this

#88 feanor91

feanor91

    Member

  • Jr. Member
  • PipPip
  • 12 posts

Posted 02 January 2013 - 07:46 AM

Hello

Can someone look at this related thread : Problem to use Wendal's tools (I put a lot of informations and didn't want to make copy here)

I made a lot by finding informations here and there, but now, I'm totally stuck and didn't know hot to move forward.

If someone could help...

Edited by feanor91, 02 January 2013 - 07:47 AM.


#89 perjarles

perjarles

    Member

  • Jr. Member
  • PipPip
  • 11 posts

Posted 10 January 2013 - 03:56 AM

Thanks wendel, you have saved my job. +1 thank you. Posted Image

One correction for Yuandao N10, it's window N10 as most foreigner recognition.


Hello Wendal
I downloaded the RK29xxImageTools_v2.1 hoping I could get into the image for a MA-107 running RK2918_ANDROID4.0.4-sdk

At start everything seemed fine, but it got into trouble when comming to cramfsck.

Here is the output from the execution:
RK29xx Image Pack/Unpack Tools
Blog http://wendal.net
Project: https://github.com/wendal/teclast_tools
feedback: pad@wendal.net
Pls input: 1-Unpack 2-Pack 3-Exit
1
Pls copy Image file into this folder,and rename to wendal.img
Notify any errors!
Press any key to continue . . .
Reading file header...
File header: RKFWf
Read loader's offset
Read loader's len
Read update.img's offset
Read update.img's len
Output Loader
offset(0x66) len(0x282DA)
Output updata.img
offset(0x28340) len(0x14C4E804)
Unpack updata.img to Temp folder
Check file... OK
------- UNPACK ------
package-file    0x00000800      0x0000021B
RK29xxLoader(L)_V2.30.bin       0x00001000      0x000282DA
parameter       0x00029800      0x00000258
Image/misc.img  0x0002A000      0x0000C000
Image/kernel.img        0x00036000      0x006F7030
Image/boot.img  0x0072D800      0x000DD08E
Image/recovery.img      0x0080B000      0x00974000
Image/system.img        0x0117F000      0x13ACE800
update-script   0x14C4D800      0x000003A5
recover-script  0x14C4E000      0x0000010A
Unpack firmware OK!
------ OK ------
Unpack system.img to system folder
Cramfs 2 , Modify by Wendal Chen.
My blog    http://wendal.net
Sources    http://github.com/wendal/cramfs

cramfsck: superblock magic not found
Enable root permission
The system cannot find the path specified.
The system cannot find the path specified.
chmod: cannot access `system/*': No such file or directory
chmod: cannot access `system/bin/su': No such file or directory
chmod: cannot access `system/app/Superuser.apk': No such file or directory
Unpack -- All Done
Pls input: 1-Unpack 2-Pack 3-Exit

Can you identify what went wrong, and do you have a solution for it?

Any help is appreciated

Best regards
Per-Jarle

#90 mongoose

mongoose

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 68 posts

Posted 14 January 2013 - 05:54 AM

i got the same error when trying to root ampe a86 firmware , rk3066

cramfsck: superblock magic not found
Enable root permission
The system cannot find the path specified.
The system cannot find the path specified.
chmod: cannot access `system/*': No such file or directory
chmod: cannot access `system/bin/su': No such file or directory
chmod: cannot access `system/app/Superuser.apk': No such file or directory

Edited by mongoose, 14 January 2013 - 05:54 AM.