Jump to content


Photo

HT-PAD-1051 Tianfeng Tablet Firmware Upgrade Guide


  • Please log in to reply
175 replies to this topic

#21 songhengkaing

songhengkaing

    Member

  • Jr. Member
  • PipPip
  • 23 posts

Posted 05 July 2011 - 05:13 AM

The camera has been fixed on this firmware, it has worked everytime I flashed, can you try re-flashing songhengkaing.




Dear Navster,

Thanks for information, however, i have re-flashed it so many times, still can not get the camera work, every time I press the camera button, the message pop up
, sorry: The application camera (process com.android.camera) has stopped unexpectedly. Please try again.

Is there any way that I can try to make it work.

Thanks again.

#22 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 05:34 AM

Do you have an app to access to your root file system?
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#23 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 05 July 2011 - 07:13 AM

i have follow the instruction but no luck, i got update error (-22)?

anyone can help please?

#24 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 08:58 AM

i have follow the instruction but no luck, i got update error (-22)?

anyone can help please?


Can you provide a bit more detail please.
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#25 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 05 July 2011 - 09:16 AM

when i press start in mfgtool it begin, just after a few second when my device light up then it show 'Updater Error 0xffffffea (-22)', 1st i though is normal, after i wait 10minute i stop mfgtool and reset my device but nothing happen. i remove my sd card put in my pc and it show nothing in the card either.

#26 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 09:21 AM

when i press start in mfgtool it begin, just after a few second when my device light up then it show 'Updater Error 0xffffffea (-22)', 1st i though is normal, after i wait 10minute i stop mfgtool and reset my device but nothing happen. i remove my sd card put in my pc and it show nothing in the card either.


The update takes about three minutes, do you have 8GB internal Mirco SD card and is this the one you removed and put in your PC?
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#27 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 05 July 2011 - 09:31 AM

The update takes about three minutes, do you have 8GB internal Mirco SD card and is this the one you removed and put in your PC?

nope. is a brand new 16GB sdhc class 4 card i put in d internal micro SD(replace the 8GB), the original is a 8GB.

#28 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 09:41 AM

nope. is a brand new 16GB sdhc class 4 card i put in d internal micro SD(replace the 8GB), the original is a 8GB.


Are you using the update files from this guide or the ones in my 8GB>16GB guide?
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#29 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 05 July 2011 - 09:54 AM

Are you using the update files from this guide or the ones in my 8GB>16GB guide?

i'm using the other post 8GB to 16GB flash.zip. been trying many times till now still no luck.

#30 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 10:01 AM

i'm using the other post 8GB to 16GB flash.zip. been trying many times till now still no luck.


Have you removed all of the SD card partitions?

On a side note, this question would probably have been more appropriate to post in that thread!
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#31 songhengkaing

songhengkaing

    Member

  • Jr. Member
  • PipPip
  • 23 posts

Posted 05 July 2011 - 11:59 AM

Do you have an app to access to your root file system?



May you instruct me what to do if i can access to my root file system? Thanks!

#32 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 05 July 2011 - 04:18 PM

May you instruct me what to do if i can access to my root file system? Thanks!


Cannot guarantee this will work but I have attached a zip file of my working libcamera.so, libcamera_client.so and libcameraservice.so taken from the \sdcard\system\lib folder

Can you try renaming the above files on your tablet to .bak files, replace them with the contents of the zip, ensuring the permissions are set identical to current files and ownership is root:root, then delete your "data\dalvik-cache" folder and reboot

Attached File  libcam.zip   58.73KB   30 downloads
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#33 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 05 July 2011 - 07:32 PM

Have you removed all of the SD card partitions?

On a side note, this question would probably have been more appropriate to post in that thread!

i din't remove sd card partitions because in disk managment i right click on the sd card and it don't have any option of remove partition, so i assume is ok. after many times i try now my sd card is corrupted and can't read from my pc and i have formatted my card.

My question is, can i still use the formatted card to do the upgrade with this guide? if yes, what should i do to the sd card fisrt??

thank you

#34 songhengkaing

songhengkaing

    Member

  • Jr. Member
  • PipPip
  • 23 posts

Posted 05 July 2011 - 10:58 PM

Cannot guarantee this will work but I have attached a zip file of my working libcamera.so, libcamera_client.so and libcameraservice.so taken from the \sdcard\system\lib folder

Can you try renaming the above files on your tablet to .bak files, replace them with the contents of the zip, ensuring the permissions are set identical to current files and ownership is root:root, then delete your "data\dalvik-cache" folder and reboot

Attached File  libcam.zip   58.73KB   30 downloads



Thanks for advice. I can not get app that can access my system file, can you advise the app name that i should use? thanks.

#35 songhengkaing

songhengkaing

    Member

  • Jr. Member
  • PipPip
  • 23 posts

Posted 06 July 2011 - 02:18 AM

Thanks for advice. I can not get app that can access my system file, can you advise the app name that i should use? thanks.



Hi, i have used root explorer to do as your instruction, but still can not get my camera work. anyway thanks for instruction.

#36 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 06 July 2011 - 02:56 AM

Hi, i have used root explorer to do as your instruction, but still can not get my camera work. anyway thanks for instruction.


So it looks like the SSv5 firmware is still problematic for cameras on some of these tabs, might be worth continuing this discussion here:

http://www.slatedroi...arity-firmware/
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#37 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 06 July 2011 - 03:17 AM

i din't remove sd card partitions because in disk managment i right click on the sd card and it don't have any option of remove partition, so i assume is ok. after many times i try now my sd card is corrupted and can't read from my pc and i have formatted my card.

My question is, can i still use the formatted card to do the upgrade with this guide? if yes, what should i do to the sd card fisrt??

thank you


Try using the formatted card and see what happens, it won't break anything but I had problems when I formatted my SD card in Windows and did the firmware upgrade, which is why my instructions were to "remove any\all partitions and not to format the SD card", MfgTool formats\partitions the card during the initial stage of the install anyway

Your Windows PC will naturally see the SD card as a corrupt disk and will want to format it, by the way are you using Win7 or WinXP?
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#38 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 06 July 2011 - 04:15 AM

im using win 7 32bit, formatted my sd card to fat32 (primary partition). will give it a try again tonite.

thanks for the advised.

#39 navster

navster

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 150 posts
  • LocationLondon

Posted 06 July 2011 - 05:04 AM

im using win 7 32bit, formatted my sd card to fat32 (primary partition). will give it a try again tonite.

thanks for the advised.


Before you re-flash I would suggest deleting the mfgtool.log file in the gpad folder, re-flash and if it fails post the contents of the mfgtool.log here so we can analyse where\why the upgrade is failing

It may also be worth trying to remove the SD card partitions using Diskpart from within DOS

:)
Navster

HP Touchpad 32GB running Dual Boot WebOS 3.0.3 and CM7.1 Alpha

#40 foo1114

foo1114

    Member

  • Jr. Member
  • PipPip
  • 24 posts

Posted 06 July 2011 - 06:11 AM

Before you re-flash I would suggest deleting the mfgtool.log file in the gpad folder, re-flash and if it fails post the contents of the mfgtool.log here so we can analyse where\why the upgrade is failing

It may also be worth trying to remove the SD card partitions using Diskpart from within DOS

:)

1 - Panel A Start processing SD <LIST/>.

1 - Panel A Start <CMD/> type="find" body="BootStrap" file="" timeout="60" onError="" text="".

1 - Panel A Finished <CMD/> type="find" body="BootStrap" file="" timeout="60" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="init" body="Memory" file="mx51to2.ddr.xml" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="init" body="Memory" file="mx51to2.ddr.xml" timeout="10" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="load" body="" file="uImage" timeout="10" onError="" text="Doing Kernel.".

1 - Panel A Finished <CMD/> type="load" body="" file="uImage" timeout="10" onError="" text="Doing Kernel." SUCCESS code=0.

1 - Panel A Start <CMD/> type="load" body="" file="initramfs.cpio.gz.uboot" timeout="10" onError="" text="Doing Initramfs.".

1 - Panel A Finished <CMD/> type="load" body="" file="initramfs.cpio.gz.uboot" timeout="10" onError="" text="Doing Initramfs." SUCCESS code=0.

1 - Panel A Start <CMD/> type="load" body="" file="u-boot.bin" timeout="10" onError="" text="Loading OS image.".

1 - Panel A Finished <CMD/> type="load" body="" file="u-boot.bin" timeout="10" onError="" text="Loading OS image." SUCCESS code=0.

1 - Panel A Start <CMD/> type="jump" body="" file="" timeout="10" onError="" text=" Jumping to OS image. ".

1 - Panel A Finished <CMD/> type="jump" body="" file="" timeout="10" onError="" text=" Jumping to OS image. " SUCCESS code=0.

1 - Panel A Start <CMD/> type="find" body="Updater" file="" timeout="60" onError="" text="".

1 - Panel A Finished <CMD/> type="find" body="Updater" file="" timeout="60" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="pull" body="?" file="device.xml" timeout="10" onError="" text="Getting device info.".

1 - Panel A Finished <CMD/> type="pull" body="?" file="device.xml" timeout="10" onError="" text="Getting device info." SUCCESS code=0.

1 - Panel A Start <CMD/> type="show" body="" file="device.xml" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="show" body="" file="device.xml" timeout="10" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="mknod block,mmcblk0,/dev/mmcblk0,block" file="" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="push" body="mknod block,mmcblk0,/dev/mmcblk0,block" file="" timeout="10" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="pipe fdisk /dev/mmcblk0" file="fdiskcmd.txt" timeout="10" onError="" text="Create partition for SD Card".

1 - Panel A Finished <CMD/> type="push" body="pipe fdisk /dev/mmcblk0" file="fdiskcmd.txt" timeout="10" onError="" text="Create partition for SD Card" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="frf" file="" timeout="10" onError="" text="Finish Create partition".

1 - Panel A Finished <CMD/> type="push" body="frf" file="" timeout="10" onError="" text="Finish Create partition" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p1,/dev/mmcblk0p1,block" file="" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p1,/dev/mmcblk0p1,block" file="" timeout="10" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p2,/dev/mmcblk0p2,block" file="" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p2,/dev/mmcblk0p2,block" file="" timeout="10" onError="" text="" SUCCESS code=0.

1 - Panel A Start <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p3,/dev/mmcblk0p3,block" file="" timeout="10" onError="" text="".

1 - Panel A Finished <CMD/> type="push" body="mknod block,mmcblk0/mmcblk0p3,/dev/mmcblk0p3,block" file="" timeout="10" onError="" text="" FAIL code=-22.

Panel A: Updater Error 0xffffffea (-22) -

2 - Panel A Finished processing SD <LIST/> : FAIL code=-22.

Panel A: Operation stopped by user.

This is log file.