Jump to content


Photo

New Vestinious Builds


  • Please log in to reply
368 replies to this topic

#1 Roger Calver

Roger Calver

    Firmware Dev

  • Global Moderators
  • 2,737 posts
  • LocationUK

Posted 21 April 2011 - 10:07 AM

Late Credits to HCH for his earlier works on the Via 8650 tabets, In my testing at the very start I made a hybrid of a bunch of builds and forgot to add credit to him then - my error and so this is in some small way an attempt to give the proper credit.

Im putting together builds of Vestinious for the following tablets.
The current build number is 1.3.6 (for the M009s) and based on the Eken WMT 1.3.0 factory firmware, 1.2.2 and based on WMT 1.2.3 (for all other Ekens).

Posted Image

Vestinious M009s and similar Android tablets Firmware by Roger Calver is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License. Based on a work at Eken Group

All of these builds (apart from the M009s) are untested my end as I dont have any of these tablets, for me to do any more indepth work I will need to get a tablet to dev on.

Links,

I will be uploading from now on firmwares to my FTP server and thanks to MP4 for setting it up for me :)
http://173.255.228.138/~rogercalver/



 

Firmware Update Video
by: Tasselhof

http://www.youtube.com/watch?v=HZ8E97qXuQ0

Vestinious ROM Review - Version 1.3.4 - Newer Version Available Now
by: Tasselhof
- Video has been updated with text annotations due to latest ROM version 1.3.5

http://www.youtube.com/watch?v=Fj9thL668CU

Edited by Roger Calver, 07 June 2011 - 09:39 AM.
Adding credit to HCH for his work I forgot to give.

Slatedroid Singularity

#2 Stu-e

Stu-e

    Member

  • Jr. Member
  • PipPip
  • 14 posts

Posted 28 April 2011 - 10:17 AM

Roger
Unzipping using 7zip under WinXP Vestinious M009s ROM 1.1.6.zip results in 2 errors and a statement something like:
"CRC failed...fs_patch\root_patch\.restore\data.tar'. File is broken."

Should I be concerned?
1.1.5 unzips without errors

Stu-e

#3 Roger Calver

Roger Calver

    Firmware Dev

  • Global Moderators
  • 2,737 posts
  • LocationUK

Posted 28 April 2011 - 11:30 AM

Yeah I dont know whats up with that link but try this one.
http://www.4shared.c...9s_ROM_116.html
Slatedroid Singularity

#4 serpentshead

serpentshead

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 28 April 2011 - 12:37 PM

Hi Roger

Thanks for the uploads.

I have tried both the 1.1.1 and 1.1.5 roms, they install fine but I the touchscreens stop working.
I have a green LED Build 1.2.2
any help would be appreciated.

#5 classicalguy

classicalguy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 390 posts

Posted 28 April 2011 - 01:43 PM

Isn't the Viapad V7 (or M7007T) for the green LED v the M009 for the blue?

#6 Guest_dragon2knight_*

Guest_dragon2knight_*
  • Guests

Posted 28 April 2011 - 03:10 PM

The Viapad is a green led unit :)

#7 serpentshead

serpentshead

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 28 April 2011 - 04:30 PM

hi

got my green LED touch screen to work ;-) turned out to be a M70007T
used rogers 1.1.5 ROM and then made changes as explained by 1onyx

Edit FirmwareInstall/env/uboot_env_head
Find: setenv wmt.audio.i2s vt1603:f1:f2:ff:ff
Change: wmt.audio.i2s wm8900:ff:ff:ff:ff
Find: setenv touchcodec vt160
Change to: setenv touchcodec uor615x
Find: setenv wmt.io.touch 1:vt1603:2:800:480
Change to: setenv wmt.io.touch 1:uor615x:0:800:480

Cool work guys!! thanks

#8 classicalguy

classicalguy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 390 posts

Posted 28 April 2011 - 09:33 PM

Can you please clarify where you type those commands? Is that typed in the tablet after you install the firmware or editing the install files?

#9 serpentshead

serpentshead

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 29 April 2011 - 01:53 AM

hi

the file changes are made before you update the tablet. I copied 1.1.6 to SDcard, navigated to the files and opened with notepad. Made the changes and flashed the ROM.
Now the touch screen works but having issues with battery life. Just about to try some configuration changes for the battery will let u know how I get on.

#10 serpentshead

serpentshead

    Member

  • Jr. Member
  • PipPip
  • 26 posts

Posted 29 April 2011 - 02:10 AM

battery problem resolved by using 1onyx file uboot_env_head - thanks

so now using M70007T (Green LED) with Rogers 1.1.6 ROM and 1onyx config changes!!! :yahoo:

#11 WesB

WesB

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 43 posts
  • LocationGeorgia

Posted 29 April 2011 - 07:41 PM

I am downloading the M70007t version now. I have the green LED and I will be willing to test if needed on new versions. THANKS Roger!
Always have your stuff when you need it with @Dropbox. 2GB account is free! http://db.tt/uoZhg0e

#12 gene02

gene02

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 29 April 2011 - 07:44 PM

hello sir, i tried your vestinous build on my m008s but after the upgrade it only gave me a blank screen, anyway thanks for modding a firmware for this, will be waiting for your update =)

#13 WesB

WesB

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 43 posts
  • LocationGeorgia

Posted 30 April 2011 - 08:04 AM

OK I am very confused. I have a 7" tablet that the manual is labeled M70007T, in the about screen it is labeled a WM8650. I have tried the ROM for M70007T and M009s also with and without 1onyx's edits and I can not get the touchscreen to work at all. The ROMS seem to be installing (comes up with Rogers background time and everything, menu button works - but no touch screen). I need HELP. LOL I bought this for my wifes birthday today and I wanted to enhance it by getting the google app market working and get the chinese stuff off of it. I even tried downloading the Eken M009s ROM from their website and no touchscreen. Any help would be greatly appreciated!

I forgot to say that it looks exactly like the Eken M009s it has green LED and vibrates when turned on. Here are the specs -
# 7-inch TFT touch panel
# 800 x 480 resolution (WVGA)
# Google Android OS 2.2 pre-installed
# VIA 8650 800 MHz processor
# 256 MB RAM
# 2 GB internal memory

Edited by WesB, 30 April 2011 - 08:34 AM.

Always have your stuff when you need it with @Dropbox. 2GB account is free! http://db.tt/uoZhg0e

#14 WesB

WesB

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 43 posts
  • LocationGeorgia

Posted 30 April 2011 - 10:02 AM

Update - I have got Rogers 1.1.6 version to work somewhat - the touchscreen works sporadically (you have to press multiple times to get one click, also almost impossible to scroll) I am not going to stop until I get this thing working!!!!
Always have your stuff when you need it with @Dropbox. 2GB account is free! http://db.tt/uoZhg0e

#15 marino

marino

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 30 April 2011 - 10:48 AM

Hi to all, i'try to update my Eken M003S with "Vestinious M003s ROM 1.1.5 - Google Edition", but after remove sd card tablet not start. :(
Thanks
BR
Marino

#16 classicalguy

classicalguy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 390 posts

Posted 30 April 2011 - 11:26 AM

WesB: Are you sure you put 1Onyx's changes in correctly (and they took)? Maybe download his version and try to install it to make sure? Mine is supposedly on a slow boat from china - I'm hoping we get the problems figured out before it gets here :-)

#17 WesB

WesB

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 43 posts
  • LocationGeorgia

Posted 30 April 2011 - 11:38 AM

Yes I copied exactly. I did not DL his version but I can try it. I restored the original just to make sure the screen wasn't the problem and original ROM works fine. I am in the process of tweaking the original with the help of Rogers ROM. I will keep you guys posted.


Updated - My hybrid seems to be working. I mixed and matched the files from Rogers ROM into the original. I get everything working with mostly Rogers ROM. Screen works great! Everything so far seems to be working or at least everything I tested. If anyone is interested I can upload and post a link.

Edited by WesB, 30 April 2011 - 12:45 PM.

Always have your stuff when you need it with @Dropbox. 2GB account is free! http://db.tt/uoZhg0e

#18 classicalguy

classicalguy

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 390 posts

Posted 30 April 2011 - 01:02 PM

Just a question - how did you save your original rom before installing Roger's rom (to revert)?

#19 Guest_dragon2knight_*

Guest_dragon2knight_*
  • Guests

Posted 30 April 2011 - 01:31 PM

Hi to all, i'try to update my Eken M003S with "Vestinious M003s ROM 1.1.5 - Google Edition", but after remove sd card tablet not start. :(
Thanks
BR
Marino

The M003S needs work,its already known :) Hopefully we can figure it out soon.

#20 rainblood

rainblood

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 30 April 2011 - 10:50 PM

ViaPad V7 - (Confirmed working) Vestinious ViaPad 7 Firmware
Eken M003s - Vestinious M008s Firmware
Eken M009s (This I can test) - Vestinious M009s Firmware
M70007T - Vestinious M70007T Firmware
Eken M003s - Vestinious M003s Firmware


Mr. Roger, I downloaded the on for M70007T but after downloading, the files inside the zip file Vestinious M70007T ROM 1.1.6.zip are "ViaPad V7"

Are these correct or is the M70007T is also the same as ViaPad V7?

Thanks.