Jump to content


Photo

ZT-180 Adhoc Switcher


  • Please log in to reply
101 replies to this topic

#61 Leona23

Leona23

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 45 posts
  • LocationExeter, Devon, United Kingdom.

Posted 05 July 2011 - 02:03 PM

Hum, Failed at first hurdle, first I couldn't find it in the Market do downloaded and transferred it via dropbox, then it wouldn't run as my device isn't rooted, so I guess I need to go and find how to do that first :)

╓────────────┐
Kind Regards
♥ Leona. ♥
╚════════════╛

Tablet: Elonex eTouch 1000ET (ZT-180) Android: Froyo 2.2 Abtekk's Custom ROM 3.6 Rooted.
Phone: Sony Ericsson Xperia Pro Model: MK16i Build: 4.0.1.A.0.283 Android: 2.3.4 Carrier: 02

Former / Retired Phones. (1999 -> 2011)
Philps C12 (Cellnet), Motorola C520 (Orange), Nokia 6110, 6210, 6310, 7250, Sony P900, HTC Wizard (02), HTC Tytn 2, LG GW620 EVE (wo0ty Froyo 2.2 Rooted)

#62 gianluca.tomat

gianluca.tomat

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 618 posts

Posted 05 July 2011 - 02:21 PM

It's pretty simple.. just install universal androot 1.6.1 (not1.6.2) and before rooting choose do not install superuser in stead of superuser for 2.1/2.2 and you are done!! :)
ZT-180v1(256Mb/2Gb):

-HW: ruby 1.4/576 screen
-ROM: 0603


MODS to do:

-GPS stick to buy and maybe put the GPS + 3G stick inside with a HUB ( soldered where the wifi stick is)

P.S. I'm still waiting for the GPS since I haven't still understood if Zenithink wants to support it or not in official ROM :)

ZT-280/E98

If you need a DROPBOX account (you know you do XD) pleas use this link ;)

Posted Image

#63 Leona23

Leona23

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 45 posts
  • LocationExeter, Devon, United Kingdom.

Posted 05 July 2011 - 03:03 PM

It's pretty simple.. just install universal androot 1.6.1 (not1.6.2) and before rooting choose do not install superuser in stead of superuser for 2.1/2.2 and you are done!! :)

Thank you, yes I used the search (though had to resort to google) and found the instructions on how to do it, and yes that was easy, though again not in market so had to go search for the app and transfer it via Dropbox, (really handy!).
So all done and installed now, its not finding my phone, so will have to search another forum to work out what is going on there, I am sure I had this working with my notebook before, will keep trying, (I am not one of those who gives up easy :) ).

╓────────────┐
Kind Regards
♥ Leona. ♥
╚════════════╛

Tablet: Elonex eTouch 1000ET (ZT-180) Android: Froyo 2.2 Abtekk's Custom ROM 3.6 Rooted.
Phone: Sony Ericsson Xperia Pro Model: MK16i Build: 4.0.1.A.0.283 Android: 2.3.4 Carrier: 02

Former / Retired Phones. (1999 -> 2011)
Philps C12 (Cellnet), Motorola C520 (Orange), Nokia 6110, 6210, 6310, 7250, Sony P900, HTC Wizard (02), HTC Tytn 2, LG GW620 EVE (wo0ty Froyo 2.2 Rooted)

#64 Leona23

Leona23

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 45 posts
  • LocationExeter, Devon, United Kingdom.

Posted 05 July 2011 - 04:14 PM

OMG! I've got it working! Its taken some fiddling, mostly on the ICS side, for anyone else trying this. IE using your Old Windows Mobile phone (Version 6.0, 6.1, 6.5) to as a Internet Gateway, You need to download and install the ICS Control Application from here, follow the instructions at this page to set up the ICS service, once done, follow the instructions to setup the AdHoc network in this thread, enable Wifi and ICS on the phone, and switch to AdHoc on the tablet (it might take a while for it to fine the phone, enable and disable a few times), but it should then connect, if not, check your ICS settings. It works, I can not believe I got it working!

Edited by Leona23, 06 July 2011 - 03:05 AM.


╓────────────┐
Kind Regards
♥ Leona. ♥
╚════════════╛

Tablet: Elonex eTouch 1000ET (ZT-180) Android: Froyo 2.2 Abtekk's Custom ROM 3.6 Rooted.
Phone: Sony Ericsson Xperia Pro Model: MK16i Build: 4.0.1.A.0.283 Android: 2.3.4 Carrier: 02

Former / Retired Phones. (1999 -> 2011)
Philps C12 (Cellnet), Motorola C520 (Orange), Nokia 6110, 6210, 6310, 7250, Sony P900, HTC Wizard (02), HTC Tytn 2, LG GW620 EVE (wo0ty Froyo 2.2 Rooted)

#65 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 07 July 2011 - 05:25 PM

According to some comments I received, it seems like the Wi-Fi cannot "see" the ad-hoc hot spot when the SSID has an apostrophe (for example "Hal's Phone"). If somebody is having problems to connect and have an apostrophe on the SSID just change the SSID and it should connect fine.

I don't know yet if it's a problem of the Wi-Fi itself or a problem of the application. In the second case it should be fixed on the next release. Meanwhile (or if not it's a problem of the application) just not use apostrophes as said.

#66 Grizzylemon

Grizzylemon

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 10 July 2011 - 12:19 PM

Hi Hal and any others who may be able to help me. I am new to android, rooting and the like, so be slow and deliberate and kind. ;)

I have a rooted htc hero running cyanogenmod and have downloaded an app called wireless tether. This tethering works no problem on my laptop. I also have a rooted (I will describe and you tell me if it is rooted) sprint galaxy tab. I bought it second hand and it has the superuser icon. I downloaded zt-180 ad hoc switch and installed it and the galaxy tab said it had been granted superuser status, so I assume it is rooted also. On the galaxy tab I can "see" my wireless tether as "android tether" and I get the cannot use ad hoc connections message which is how I stumbled onto the zt-180 ad hoc switcher. When I open the ad hoc switcher on the tab, I get the message others talked about in this post "missing some files to modify, blah blah". I have generated the report and will send it to Hal at his email address. I know others have been able to get this to work on the tab. One thing I am ignorant about is where I find and where I would put in the ssdi information? I haven't been able to get to any point with the adhoc app to enter this but I see where others have posted about making sure you have that information entered and it matches on both devices. Sorry to be such a noob, it would be great to take the galaxy on the road with a connection. Thanks in advance. Let me know if there is anymore information needed from me to help solve my problem. I really appreciate all of you who come onto this forums and help those of us who are more challenged in the technology dept.

#67 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 10 July 2011 - 03:01 PM

Hi Hal and any others who may be able to help me. I am new to android, rooting and the like, so be slow and deliberate and kind. ;)

I have a rooted htc hero running cyanogenmod and have downloaded an app called wireless tether. This tethering works no problem on my laptop. I also have a rooted (I will describe and you tell me if it is rooted) sprint galaxy tab. I bought it second hand and it has the superuser icon. I downloaded zt-180 ad hoc switch and installed it and the galaxy tab said it had been granted superuser status, so I assume it is rooted also. On the galaxy tab I can "see" my wireless tether as "android tether" and I get the cannot use ad hoc connections message which is how I stumbled onto the zt-180 ad hoc switcher. When I open the ad hoc switcher on the tab, I get the message others talked about in this post "missing some files to modify, blah blah". I have generated the report and will send it to Hal at his email address. I know others have been able to get this to work on the tab. One thing I am ignorant about is where I find and where I would put in the ssdi information? I haven't been able to get to any point with the adhoc app to enter this but I see where others have posted about making sure you have that information entered and it matches on both devices. Sorry to be such a noob, it would be great to take the galaxy on the road with a connection. Thanks in advance. Let me know if there is anymore information needed from me to help solve my problem. I really appreciate all of you who come onto this forums and help those of us who are more challenged in the technology dept.

Hello Grizzylemon.

Does the message says that all the needed files are missing and the application cannot continue or does it says that only some files are missing and offer the possibility to continue on "just to try" mode? In the second case please continue and try to connect.

You don't have to put anything special on the SSID. If you haven't changed it on Wireless Tether on your Hero it should be "Android Tether". Anyway, changed or not, you only look at it on the Wireless Tether's settings on your Hero and configure ZT-180 Adhoc Switcher to use exactly the same SSID.

In addition both applications on each device should be using the same configuration for encryption. So both have to be using no-encryption, or both have to be using WEP encryption with exactly the same key.

Edited by HAL9000, 10 July 2011 - 03:02 PM.


#68 Grizzylemon

Grizzylemon

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 10 July 2011 - 09:11 PM

No, it does not give me an option to try anyway, just says either to close application or to go to report generation dialog.

#69 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 11 July 2011 - 04:00 AM

No, it does not give me an option to try anyway, just says either to close application or to go to report generation dialog.

OK then. I've had a few others similar reports from GT devices and I'm still looking into the problem. I would like to know what's the difference between the GT on which the application worked for and the ones which cannot find the files... :unsure:

Edited by HAL9000, 11 July 2011 - 04:01 AM.


#70 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 11 July 2011 - 12:44 PM

FOR PEOPLE WITH DEVICES WHICH GOT WI-FI "BROKEN" (CANNOT ENABLE) AFTER TRYING ZT-180 ADHOC SWITCHER

Due to a permission/ownership problem on some devices the Wi-Fi may refuse to enable after using ZT-180 Adhoc Switcher. I plan to try and fix this on a next release, but in the meanwhile the application will not work for these devices and it's negative effect has to be fixed manually.

To do so, the first thing is to start ZT-180 Adhoc Switcher and ensure that the device is currently on "infrastructure" mode, if it's on "ad-hoc" mode then change to "infrastructure". After that, close the app.

Then you will need to use ADB (part of Android SDK tools) on your PC or a terminal emulator application on your device (if your device has not such app, there is a very good one on the Market called "Android Terminal Emulator", by Jack Palevich). If you'll use ADB then you must connect your device to the PC and start a session by opening a shell command prompt window on the PC and typing these two lines:

adb remount
adb shell

After that you'll be on a command prompt in the form of "#".

If you'll use a terminal emulator then you need to open the terminal app on your device and then type:

su

After that you'll get the "#" command prompt.

Once you have your root "#" command prompt by one of the two methods, follow these steps (write things without the quotes):

1) type "cd /data/misc/wifi" to go to that folder (a "pwd" command will show you the current folder to confirm)

2) then type "ls -l" (both are lowercase "L", to ensure you type it right I recommend to copy and paste from this text)

3) there should be a file "wpa_supplicant.conf", if there is too a file called "wpa_supplicant.conf.ZT180_AS_Original" then do the following, if that second file is not there skip to step 4:
...3-a) type "rm wpa_supplicant.conf"
...3-b ) type "busybox cp wpa_supplicant.conf.ZT180_AS_Original wpa_supplicant.conf"
...3-c) type "rm wpa_supplicant.conf.ZT180_AS_Original"

4) now type "chown wifi.wifi wpa_supplicant.conf"

5) go to the application or to Android settings and try to enable Wi-Fi and connect, if it still doesn't work follow with step 6

6) type "cd /data/misc"

7) type "chown wifi.wifi wifi"

8 ) again try to enable Wi-Fi and connect

If the application on your device only offered to work on "just to try" mode then it should be connecting fine after this.

Edited by HAL9000, 16 July 2011 - 07:51 PM.


#71 Leona23

Leona23

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 45 posts
  • LocationExeter, Devon, United Kingdom.

Posted 15 July 2011 - 03:39 AM

Hi there
I am using auto switcher, I've selected Ad Hoc mode, I need to setup the SSID and WEP codes again, but all the options under the Ad Hoc mode section in Settings are grey'd out, I have disabled WiFi before entering settings, also if I enable the wifi the tablet freezes up completely requiring a reset, but this might be a separate issue, not sure, why is this happening?

Edited by Leona23, 15 July 2011 - 04:12 AM.


╓────────────┐
Kind Regards
♥ Leona. ♥
╚════════════╛

Tablet: Elonex eTouch 1000ET (ZT-180) Android: Froyo 2.2 Abtekk's Custom ROM 3.6 Rooted.
Phone: Sony Ericsson Xperia Pro Model: MK16i Build: 4.0.1.A.0.283 Android: 2.3.4 Carrier: 02

Former / Retired Phones. (1999 -> 2011)
Philps C12 (Cellnet), Motorola C520 (Orange), Nokia 6110, 6210, 6310, 7250, Sony P900, HTC Wizard (02), HTC Tytn 2, LG GW620 EVE (wo0ty Froyo 2.2 Rooted)

#72 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 15 July 2011 - 04:22 AM

Hi there
I am using auto switcher, I've selected Ad Hoc mode, I need to setup the SSID and WEP codes again, but all the options under the Ad Hoc mode section in Settings are grey'd out, I have disabled WiFi before entering settings, also if I enable the wifi the tablet freezes up completely requiring a reset, but this might be a separate issue, not sure, why is this happening?

You cannot change ad-hoc settings while in ad-hoc mode, switch to infrastructure mode first.
  • Leona23 likes this

#73 Leona23

Leona23

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 45 posts
  • LocationExeter, Devon, United Kingdom.

Posted 15 July 2011 - 04:55 AM

You cannot change ad-hoc settings while in ad-hoc mode, switch to infrastructure mode first.

Arr, thank you, did that, inserted new SSID and WEP (as I'm at work, better put some security in) and switched back and it burst into life, thank you.
Do you have any plans to add the WPA protocal?

Edited by Leona23, 15 July 2011 - 04:56 AM.


╓────────────┐
Kind Regards
♥ Leona. ♥
╚════════════╛

Tablet: Elonex eTouch 1000ET (ZT-180) Android: Froyo 2.2 Abtekk's Custom ROM 3.6 Rooted.
Phone: Sony Ericsson Xperia Pro Model: MK16i Build: 4.0.1.A.0.283 Android: 2.3.4 Carrier: 02

Former / Retired Phones. (1999 -> 2011)
Philps C12 (Cellnet), Motorola C520 (Orange), Nokia 6110, 6210, 6310, 7250, Sony P900, HTC Wizard (02), HTC Tytn 2, LG GW620 EVE (wo0ty Froyo 2.2 Rooted)

#74 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 15 July 2011 - 05:45 AM

Arr, thank you, did that, inserted new SSID and WEP (as I'm at work, better put some security in) and switched back and it burst into life, thank you.

You're welcome.

Do you have any plans to add the WPA protocal?

Yes, I would like to add it, but I didn't look into it yet.

#75 niallb

niallb

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 16 July 2011 - 07:28 PM

7) type "chwon wifi.wifi wifi"


That line above should read
7) type "chown wifi.wifi wifi"

Pity to have a little typo in such a good solution!
Worth editing if you still can.
zt-180 v1 256MB/2G ruby v1.4 1024x600

#76 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 16 July 2011 - 07:54 PM

That line above should read
7) type "chown wifi.wifi wifi"

Pity to have a little typo in such a good solution!
Worth editing if you still can.


Oops... fixed! Thanks niallb.

#77 FoxxOTG

FoxxOTG

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 80 posts

Posted 12 August 2011 - 02:22 AM

I have a Dropad A8X with the 705 firmware, Android 2.2 rooted with Gingerbreak, and can confirm that ZT-180 AdHoc Switch works just dandy. Though I must playfully shake my fist in disregard for your use of AdMob, HAL9000. I use ZT-180 AdHoc to connect to my HTC Magic which runs Wifi Tether, there are a few hiccups with connecting now and again but I dont put any blame on either device, I am making both of them do something beyond their original concept. Once connected its quite stable.

Many thanks HAL.

#78 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 12 August 2011 - 02:29 AM

I have a Dropad A8X with the 705 firmware, Android 2.2 rooted with Gingerbreak, and can confirm that ZT-180 AdHoc Switch works just dandy. Though I must playfully shake my fist in disregard for your use of AdMob, HAL9000. I use ZT-180 AdHoc to connect to my HTC Magic which runs Wifi Tether, there are a few hiccups with connecting now and again but I dont put any blame on either device, I am making both of them do something beyond their original concept. Once connected its quite stable.

Many thanks HAL.


You're welcome. As for the ads, well, may be I could make a donation version without ads, but I think people still would download much more the free version with ads.

#79 aemps 0n xeperia x10i

aemps 0n xeperia x10i

    Newbie

  • Jr. Member
  • Pip
  • 4 posts

Posted 01 September 2011 - 01:16 AM

hi there

im using an xperia x10i rooted phone ver 2.3 and i took the risk of trying your app out, i read all the warnings and took the chance and blame only myself, i need help with your steps in the fix for incompatible gadgets, i cant get past adb remount i get a "operation not permitted" on my command prompt ive -rw on root explorer but still not permitted, would appreciate any help for fix, and will still try any versions u come out with, (i used the zt version 1.4c) i really am desparate to connect to adhoc coz i travel a lot and would like to use the ad hoc from my laptop to phone

thanks

aemps

#80 HAL9000

HAL9000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 454 posts

Posted 01 September 2011 - 04:22 AM

hi there

im using an xperia x10i rooted phone ver 2.3 and i took the risk of trying your app out, i read all the warnings and took the chance and blame only myself, i need help with your steps in the fix for incompatible gadgets, i cant get past adb remount i get a "operation not permitted" on my command prompt ive -rw on root explorer but still not permitted, would appreciate any help for fix, and will still try any versions u come out with, (i used the zt version 1.4c) i really am desparate to connect to adhoc coz i travel a lot and would like to use the ad hoc from my laptop to phone

thanks

aemps

Well, I'm sorry for the problems you're having. Usually that message on ADB appears when the device is not rooted, but you said that you get RW access on Root Explorer, which is weird. May be the phone is not fully rooted, in such case you may try to repeat the root process. Another thing to try is not use ADB and make the steps using a terminal emulator on the device.

Let me know. Good luck!

Edited by HAL9000, 01 September 2011 - 04:23 AM.