Jump to content


Photo

BadPad won't hold a charge


  • Please log in to reply
1 reply to this topic

#1 eriel.ramos

eriel.ramos

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 35 posts

Posted 17 February 2011 - 01:55 PM

Jim, I got my BadPad last October, and I've been very pleased with it. About two weeks ago I upgraded to the HaiPad Nov 24 firmware with excellent results

However, over the last two days, no matter how long I leave the unit charging, I get to no more than 40% capacity, and as soon as I unplug the adapter, it drops to 10%.

I've tried a different power adapter with the same specs (9v, 2A), with the same result.

Any ideas on what's wrong?

Eriel
(Puerto Rico)

#2 BUYaDROID

BUYaDROID

    Advanced Member

  • SlateDroid Business Sellers
  • PipPipPip
  • 144 posts

Posted 20 February 2011 - 03:14 PM

Hi

Can you try a few things.

1.  How long does the unit run before switch off?
2.  Can you revert to older firmware?  Is the problem still there
3.  Is it possible you have charged the unit more than 300 times?
4.  Is the device getting hot during use,
5. Is the device getting hot during charging,
6. Is the charger getting hot during use,

I will  send a note off to the supplier aswell.