Jump to content


Photo

Pandigital's 9-inch Novel


  • Please log in to reply
349 replies to this topic

#21 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 08 February 2011 - 10:33 PM

Okay, I did a temporary root with z4root. Tried adb again. It doesn't say offline any more but it won't let me mount it. I get remount failed: No such file or directory. If I try the command ./adb shell "cat /system/bin/sh > /system/bin/su" it says permission denied. Is that because I only did a temp root? Hope someone can explain because I don't know a lot about adb.

#22 jackbox

jackbox

    Banned Member

  • Banned
  • PipPipPip
  • 1,336 posts

Posted 08 February 2011 - 10:38 PM

Okay, I did a temporary root with z4root. Tried adb again. It doesn't say offline any more but it won't let me mount it. I get remount failed: No such file or directory. If I try the command ./adb shell "cat /system/bin/sh > /system/bin/su" it says permission denied. Is that because I only did a temp root? Hope someone can explain because I don't know a lot about adb.


The default.prop has to be modified as I explain in the post linked below. The only way to do that is to reflash it or try installing root explorer and trying to edit the file on the PDN itself. You cannot do a remount as the system boots mounted writable. On Black PDNs you don't do a remount command. But you need to change the following two lines in the default.prop. The default is secure is 1 and debuggable is 0, thereby preventing you from modding the system and preventing adb from working.

ro.secure=0
ro.debuggable=1

Link to post: http://www.slatedroi...34115#msg134115

#23 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 01:01 AM

Okay, got that done. Which version of gapps can I put on here?

#24 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 01:29 AM

So Adb by Wifi doesn't work either?

Does it have any memory reporting under Settings or can you add an app for that?

#25 jackbox

jackbox

    Banned Member

  • Banned
  • PipPipPip
  • 1,336 posts

Posted 09 February 2011 - 05:27 AM

Nothing on this forum since you  have Android 2.1. Go get GAPPS for old Cyanogen mod when 2.1 and try that.

Okay, got that done. Which version of gapps can I put on here?


Sent from my Boston using Tapatalk

#26 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 05:56 AM

I'm totally confused now. Are you sure that it has 2.1? The only reason I ask is because I called Pandigital and asked them about the two different models, the R90L200 and the R91L256. Because Walmart states it does come with 2.1 and the BBB states it's 2.0. Pandigital told me both models only had 2.0 on them. So maybe Pandigital doesn't even know what they are talking about?

#27 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 06:14 AM

Never mind, you are right, I just found this here http://tipstir.the-t...rogress-review. I should have know people at Pandigital are ignorant about their own products.

Specs:
MODEL: PRD09T | R90L200
Weight: Mid-way Heavy not fully heavy like the 7" White
Panel: Glass
360d: Yes
270d: Yes
TS: RTS
VIS: Sharp Image 9" inch 480x800 Color TFT touch panel screen
HDMI: No
HD: 360p & 480p Supported
AUDIO: 1x Stereo Speaker & Stereo headphones included
MIC: No
CAM: No
MODE: 802.11(b,g,n) N300
TX/RX:150/300
FREG: 2.4GHz
Battery: Lithium Ion Battery 4046 - 4110mAH
OS: Android 2.1 Update 1
UI: 1x Mini USB 2.0
RAM: 256MB DDR2
FLASH: 512MB
CPU: 800MHz / 800MHz (measured)
CM3: 832 Benchmark Score
Storage: 2GB Internal can't be upgraded
Expandable Storage: Yes Full SDHC or microsSDHC with SD adapter 32GB is the MAX
e-Book: Yes (EPUB, PDF)
Media: MP4, 360P (tested)
Image: JPG, GIF, BMP, PNG

#28 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 06:17 AM

See if you can list your build.prop  /system/build.prop

The Can 9" FW shows ro.build.version.sdk=5  which I believe is 2.0 as 2.1 should be 7

#29 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 03:27 PM

yes, it says ro.build.version.sdk=5 so that is 2.0?

#30 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 05:10 PM

Sdk 5 & 6 are Android 2.0 and considered obsolete. But you should be able to use the Market apps from the White PDN. Worst case change it to 7 and you can install any 2.1 apps. But it will be problematic if they will run. I think the White is really 2.0

But the White guys should know more about this.

Check your /build.prop you need security=0 and debug?=1 on for rooting and major changes. But if they are not that you can't set the system as r/w and change them. You would need a new flash.

#31 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 05:21 PM

Sdk 5 & 6 are Android 2.0 and considered obsolete. But you should be able to use the Market apps from the White PDN.


But which White PDN? 11/19 1/14 1/17 ? I do not want to brick this one because it was $219. And I've already returned two of the white ones to BBB and I don't imagine they would be too thrilled with me.

#32 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 05:27 PM

No you don't want to flash it with the White flasjes and I don't think you can.

You need a flash for the 9" and tje only one around is Can. The same as tje US, but with Kobo Books.

#33 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 05:30 PM

Oh, I think I misunderstood you. I thought you meant I could put the market on it with one of the white pdn mods. Another words I thought you meant I could install with adb. I don't want to flash but if I could figure out what to use with adb. Or is that not a good idea either? I have all of my apk's saved but I won't be able to get any more from the market.

#34 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 05:40 PM

jackbox has a adb batch file for adding Market fpr the 7" Black, I don't know if he has one for the White, but that would be the easiest. You could pull them from the White flashes.

I thought Adb didn't work ??

#35 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 05:43 PM

Yes, Adb works if you modify the default.prop

#
# ADDITIONAL_DEFAULT_PROPERTIES
#
ro.secure=0
ro.allow.mock.location=1
ro.debuggable=1
persist.service.adb.enable=1

#36 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 05:57 PM

iAdb works, that's great.

Next time I flash my 7" with the 9" flash, I'll rset the build first and see if I can connect.

You solved a lot of questions for me here, ram, flash, adb. It appears the only reason we can't upgrade the 7" Black from 1.5 to 2.0 is memory.

I am sure jackbox can help yoi out with market.

#37 terminander

terminander

    Advanced Member

  • Moderator
  • PipPipPip
  • 784 posts

Posted 09 February 2011 - 06:43 PM

Sprry just to clarify.

Adb works Usb or WiFi  ?

#38 jackbox

jackbox

    Banned Member

  • Banned
  • PipPipPip
  • 1,336 posts

Posted 09 February 2011 - 06:54 PM


Sdk 5 & 6 are Android 2.0 and considered obsolete. But you should be able to use the Market apps from the White PDN.


But which White PDN? 11/19 1/14 1/17 ? I do not want to brick this one because it was $219. And I've already returned two of the white ones to BBB and I don't imagine they would be too thrilled with me.


The Market update is the same on all of them but you cannot use them as is as they push a modified build.prop to the device. Your Black PDN will not work properly with a build.prop from a White PDN. You can try one but open the zip and delete the build.prop first. Also you need to modify the batch script and remove the remount command as it is not needed by the Black PDN or just ignore the error when it says remount command not found. Other than that you cannot brick the device pushing GAPPS to it using an ADB push method. You cannot run any of the SD type updates as they won't work on the Black PDN. Keep in mind that the Black 9 inch PDN is almost identical inside to the Black 7 inch PDN. The difference is that it is running either Android 2.0 or 2.1 based on which SKU you purchased. The only firmware that PD has on their site right now is one running 2.0 (Canadian Kobo version). No firmware has been posted for the US one yet which is reported by many to be running 2.1.

#39 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 06:56 PM

Adb works Usb. I don't know about WiFi

#40 krash1220

krash1220

    Advanced Member

  • Hero Member
  • PipPipPip
  • 414 posts
  • LocationCalifornia

Posted 09 February 2011 - 07:04 PM



Sdk 5 & 6 are Android 2.0 and considered obsolete. But you should be able to use the Market apps from the White PDN.


But which White PDN? 11/19 1/14 1/17 ? I do not want to brick this one because it was $219. And I've already returned two of the white ones to BBB and I don't imagine they would be too thrilled with me.


The Market update is the same on all of them but you cannot use them as is as they push a modified build.prop to the device. Your Black PDN will not work properly with a build.prop from a White PDN. You can try one but open the zip and delete the build.prop first. Also you need to modify the batch script and remove the remount command as it is not needed by the Black PDN or just ignore the error when it says remount command not found. Other than that you cannot brick the device pushing GAPPS to it using an ADB push method. You cannot run any of the SD type updates as they won't work on the Black PDN. Keep in mind that the Black 9 inch PDN is almost identical inside to the Black 7 inch PDN. The difference is that it is running either Android 2.0 or 2.1 based on which SKU you purchased. The only firmware that PD has on their site right now is one running 2.0 (Canadian Kobo version). No firmware has been posted for the US one yet which is reported by many to be running 2.1.


Okay, good to know about the build.prop for white not working. So just to clarify if I delete the build.prop first I can't brick my novel correct?

And I wanted to ask you JB, if I run the adb script from nchntrman create your own backups, custom firmware thread, and uploaded it for you would you be able to mess around with it and check stuff out for the 9"?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users