Jump to content


Photo

Cruz Reader: Rom rooted with market, busybox and app2sd script


  • Please log in to reply
960 replies to this topic

#21 jagan_indian9

jagan_indian9

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 08 January 2011 - 05:05 PM

Going on reboot loop with white screen, cruz logo and white screen. Got restarted atleast 10 times and going on

#22 jimmychester

jimmychester

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 08 January 2011 - 05:41 PM

Hi

Firstly, Thanks for your hard work on the rom and getting app2sd sorted.

I have the same problem as RaliR. I am definitely rooted. When I type app2sd.sh and get the 3 options, no matter which one I choose I get this:

/system/bin/app2sd.sh:  [:  permission denied

/system/bin/app2sd.sh:  [:  permission denied

Not sure why it comes up twice. Just to rub it in I guess. :)

Any help would be greatly appreciated.

Cheers,

Jimmy

#23 mayday247

mayday247

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 08 January 2011 - 06:04 PM

Since I can't get the app2sd working for now, is there an app or way to uninstall some of the Google bloatware (i.e. voice, calendar, etc) from the internal drive?  I was able to uninstall a few of the standard programs like cruz market and Dr.Eye, but that only freed up about 8mb...still only gives me 32mb of the 256mb internal memory to use  :-

Thanks again everyone!

#24 Joe_Atlanta

Joe_Atlanta

    Member

  • Jr. Member
  • PipPip
  • 20 posts

Posted 08 January 2011 - 06:04 PM

After having such a hard time and getting nowhere with the Panda ROM (R103v3), I was surprised this one installed nicely. Thanks jgm!

Like others, I'm stuck at the jackpal terminal trying to get su.
1. open terminal - got error message
2. backed up terminal, uninstalled, then re-installed
3. open terminal, type su and enter
4. su: uid 10028 not allowed to su
5. type id and enter
6. uid=10028(app_28) gid=10028(app_28) groups=1015(sdcard_),3003(inet)

Any suggestions????

#25 RALIR

RALIR

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 35 posts

Posted 08 January 2011 - 06:37 PM

Dear JGM,

Thank you for your prompt responses and helpful suggestions.

Per your suggestion, I tried "id" after "su" and got the confirmation "uid=0(root) gid=0(root)".  Then I tried "sh/system/bin/app2sd.sh" and got the message "not found". Just as an experiment, I tried "/data/local/bib/app2sd.sh" and again got the message "not found".My unit is R103 V2.0.  Any thoughts you have? I will be glad to try.  I really like the thought of moving the apps to SD thus overcoming the 70 MB limit for apps.

Anybody else has any suggestions?  Please float them my way.

While I have played with PDN reader for a while before giving it off to my daughter and now am playing with Cruz Reader, I have used the Forum.  I have been very impressed with the helpful can-do spirit and decided to be a part of the forum.  So I just joined yesterday ( or today?  Time flies when you are having fun.)

Thank you again.

Best Regards,

RaliR

#26 Mark Adams

Mark Adams

    PDN Wiki Master, Speaker to n00bs

  • Global Administrator
  • 2,338 posts
  • Location41.6927560 / -83.5456899

Posted 08 January 2011 - 06:39 PM

If this isn't as sticky worthy as Macho, don't know what is.

#27 stang

stang

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 08 January 2011 - 07:13 PM

So it's looking like the BB $99 R103 v3 (which I currently am on, my second one today) will work with this ROM?

...yes? please?

#28 mayday247

mayday247

    Member

  • Jr. Member
  • PipPip
  • 22 posts

Posted 08 January 2011 - 07:19 PM

So it's looking like the BB $99 R103 v3 (which I currently am on, my second one today) will work with this ROM?

...yes? please?


It worked great on my R103 v3.  I can't get the app2sd working yet, but it definitely roots and you can overclock with SetCPU.  Also, you may want to uninstall/reinstall the Terminal Emulator app.  For $99 and with these mods it turns this EReader into a pretty decent "tablet"...just wish I could get the app2sd working which is the only thing holding this back.

#29 stang

stang

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 08 January 2011 - 07:24 PM

It worked great on my R103 v3.  I can't get the app2sd working yet, but it definitely roots and you can overclock with SetCPU.  Also, you may want to uninstall/reinstall the Terminal Emulator app.  For $99 and with these mods it turns this EReader into a pretty decent "tablet"...just wish I could get the app2sd working which is the only thing holding this back.


Just figured that out for myself. Wow. Just wow. Had I seen this a few hours earlier I would have saved myself a trip to Best Buy to return the one I bricked (although I got a free 4gb card out of it. I completely forgot to take out my 1gb card. Oops!)

#30 stang

stang

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 08 January 2011 - 07:27 PM

When I tap the market I'm thrown back into setting up a google account, and then it force-closes when I try to sign in. Anyone else having this problem? Granted I JUST booted up so I'm still playing with it.

EDIT: Got it working now. Had to get wifi working in order to get past...derp.

#31 BoSoxFan

BoSoxFan

    Newbie

  • Jr. Member
  • Pip
  • 9 posts

Posted 08 January 2011 - 07:34 PM

Has anyone gotten this working on the BB VM R103 V2.

I already bricked my last R103 V2 and I'm running out of Best Buys to exchange them at! lol

#32 ccyg8774

ccyg8774

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 08 January 2011 - 08:00 PM

It looks like I am experiencing the same problem that icedog97 had.

In the step:
2. Write su an press enter, after that superuser app will ask if  you want the terminal to access root priviliges, so press allow or always allow.
I got:
the superuser app didn't pop out, but I had a "#" sigh.

In the step:
3. Now write app2sd.sh and press enter, then follow the script instructions to enable the storage of applications into the sd.
I got:
permission denied

If I use sh /system/bin/app2sd.sh, it will be the same result as mayday247 got, when I select "1" to prepare the SD card for application storage it gives the "permission denied" error.

If I type id and enter, I got:
uid=10028(app_28) gid=10028(app_28) groups=1015(sdcard_),3003(inet)

What is the problem? Is it not rooted/not rooted properly?


I tried to root again with the z4root, this time the su step is fine, superuser app pop out and I choose "always allow", typing id and enter shows uid=0(root) gid=0(root), seems to be right, but the next step it is still "permission denied".

#33 Contra

Contra

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 77 posts
  • LocationSan Antonio

Posted 08 January 2011 - 08:25 PM

Actually after executing su if you write id and press enter you should see uid=0(root) gid=0(root)


dont know what this means, i did the reboot and it took well, just cant overclock

the fastes it gets is 532

#34 stang

stang

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 08 January 2011 - 08:32 PM


Actually after executing su if you write id and press enter you should see uid=0(root) gid=0(root)


dont know what this means, i did the reboot and it took well, just cant overclock

the fastes it gets is 532


532...for now.

Well it looks like I'm keeping this little tyke. 800mhz is the goa. Anyone know how to do it?

#35 Dymond

Dymond

    Member

  • Jr. Member
  • PipPip
  • 23 posts

Posted 08 January 2011 - 08:59 PM

JGM.. If you have data on your internal 4gb card, are you going to lose them during the partition? I have a bunch of my ebooks on there already. I don't mind backing them, just need to know if I need to.

#36 MiamiHeat

MiamiHeat

    Newbie

  • Jr. Member
  • Pip
  • 4 posts

Posted 08 January 2011 - 09:20 PM



Actually after executing su if you write id and press enter you should see uid=0(root) gid=0(root)


dont know what this means, i did the reboot and it took well, just cant overclock

the fastes it gets is 532


532...for now.

Well it looks like I'm keeping this little tyke. 800mhz is the goa. Anyone know how to do it?


I was able to get the speed up to 800mhz from 532 mhz by replacing the u-boot.bin file in JGM's PD_INX7E_ENG_6410POP.zip file with the one from PandaBomb's Macho Cruz rom file. Loaded the modified PD_INX7E_ENG_6410POP.zip and installed SetCPU and it ran at 800 MHZ

#37 gjbnh

gjbnh

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 210 posts

Posted 08 January 2011 - 09:22 PM

Dymond, always a good idea to back them up. The script is unstable at the moment till JGM figures it all out. But I understand that IF it works right, your data should be safe.

#38 Kib!

Kib!

    Newbie

  • Jr. Member
  • Pip
  • 8 posts

Posted 08 January 2011 - 09:32 PM

Hi everyone,

I am 2 issue after the flash and I need guidance.

1. Android Market - when downloading apps it get stuck on "Starting Download" and would not finish.

2. terminal emulator would not run and give me Error "process jackpal.androidterm has stopped unexpectedly. please try again."

I have R103 v3.

Thank you

#39 gjbnh

gjbnh

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 210 posts

Posted 08 January 2011 - 09:38 PM

Kib!, you need to use Astro to back the app up, then reinstall it. This usually works, but some are re[porting that it doesn't. Worked for me.

Start astro, then press menu;it is listed there.

#40 jgm

jgm

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 243 posts

Posted 08 January 2011 - 09:45 PM

Hi

Firstly, Thanks for your hard work on the rom and getting app2sd sorted.

I have the same problem as RaliR. I am definitely rooted. When I type app2sd.sh and get the 3 options, no matter which one I choose I get this:

/system/bin/app2sd.sh:  [:  permission denied

/system/bin/app2sd.sh:  [:  permission denied

Not sure why it comes up twice. Just to rub it in I guess. :)

Any help would be greatly appreciated.

Cheers,

Jimmy


in root mode or adb try:

chmod 4755 /system/bin/[




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users