Jump to content


Photo

Whats the procedure for installing ROM's?

elf ii

  • Please log in to reply
9 replies to this topic

#1 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 09 April 2017 - 06:27 AM

Hi all,

 

I'm trying to update my Elf II from the stock 0527 ROM to CM11 but running into issues.

 

I can load TWRP 2.6 from the SDCARD but when i attempt to wipe, factory reset or install the ROM files i'm getting

 

"unable to mount System, Data, etc..."

 

I realise this is an old device and probably nobody uses it these days but if anyone can recall the procedure they used for flashing ROMs i would really appreciate.



#2 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,084 posts

Posted 09 April 2017 - 06:52 AM

Use the TWRP for  UBIFS (v2.4.1.0)



#3 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 09 April 2017 - 07:01 AM

I tried TWRP for UBIFS v2.4.1.0 but when i attempt to flash anything i'm still getting

 

"unable to mount System, Data, etc..."

 

I have also tried CWM where i was able to flash the CM11 file but it wouldnt boot up afterwards.

 

Not sure what else to try, i've literally spent hours reading posts from 2012, tried different roms etc and out of all of them i have only been able to flash Dark Elf using CWM recovery.



#4 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,084 posts

Posted 09 April 2017 - 07:34 AM

Try that factory-reset.zip at CM11 page. It should at least make them mountable.

That is if your partitioning is not messed up.



#5 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 09 April 2017 - 08:18 AM

Is it safe to flash factory-reset.zip since there doesnt appear to be one listed for the elf ii?

 

If its any relevance i have been using the usb tool / sd card to restore back to factory 0527 after failed flashes so i would think if anything was messed up that should restore everything to normal.

 

Thanks



#6 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 09 April 2017 - 11:04 AM

So i finally got TWRP to mount System and Data, and was able to flash CM11 files but the device wouldnt boot after so i've gone back to 0527 again using the sd card restore method...

 

Now i'm just trying Elenari to see if i have any better luck there but already running into issues attempting to install stock 1018.

I have copied the files from the stock archive to the root of my SD card which includes- the rom file, u-boot.bin, and ulmage_recovery. Powering the device with volume down and power i see the android logo briefly while it boots up into recovery but then its just a black screen. I left it for 15 mins to see if anything happened but just remained on black screen with apparently nothing happening.

 

I then proceeded to try and flash the rom archive using the stock 0527 recovery but its failing on the device check with the following error:

 

assert failed getprop ("ro.product.device") == "g06refe1" | | ("ro.build.product") == "g06refe1"
E: Error in / tmp / sideload / package.zip
Status 7
Installation aborted.

 

Comparing the updater-script from 0527 it appears the device is set to "g06ref" which is why its failing above as its looking for "g06refe1".

 

Is there anyway to bypass this check using stock recovery?

 

Thanks



#7 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,084 posts

Posted 11 April 2017 - 03:55 AM

From where did you find stock 1018 nowadays?

 

If you use 0527 recovery on the sd card it should not abort.

Also you can edit that edify script and then just re-sign the zip.

http://www.slatedroi...pment/?p=827721



#8 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 11 April 2017 - 07:23 AM

I found the stock 1018 in the Elenari ROM thread:

http://www.slatedroi...y-fuser-invent/

and in his mediafire folder you will find 1018:

https://www.mediafir.../?wgn90smrwyqfb

 

The instructions provided in the Elenari thread state 1018 must be flashed first by copying the contents to the sdcard but i'm unable to get the recovery provided with 1018 to boot. I just get a black screen which is why i'm attempting to use the stock recovery from 0527.

 

I managed to sign the zip file- thanks for linking me to that. I'm no longer getting the assert failed error with the signed zip however its still not flashing 1018. Instead i'm now seeing:

Finding update package...
Opening update package...
Verifying update package...
Installing update...
Installation aborted....

So nothing to indicate why the installation aborted which is odd.

 

To summarise:

  • I'm on the stock 0527 ROM where i can boot up and everything works with the device.
  • I can always restore to 0527 using the SDCARD method but so far i have been unable to flash any other ROM sucessfully.
  • I have tried CM11 using TWRP UBIFS 2.4 which took many attempts until it eventually flashed but i was unable to boot afterwards so went back to 0527.
  • I then attempted to flash 1018 with the files on the root of my sdcard. Recovery would not boot and i would just get a black screen every time.
  • Tried to flash 1018 using the recovery from 0527 where i was getting the assert failed error for device =g06refe1
  • Unzipped 1018 and editted the updater script removing the g06refe1 lines, rezip and signed with the crystal signer. Proceed to flashing the editted and signed 1018 with the stock 0527 recovery and now its just saying installation aborted.


#9 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 11 April 2017 - 08:24 AM

Furthermore i have now tried stock 0926 found here https://mega.nz/#!qY...O4d00-TE4qLSnogand i'm running into the same issue where i'm only getting a black screen when attempting to boot the provided recovery. As always reverting back to the stock 0527 recovery and the recovery boots up fine but i just cant flash anything using the stock recovery...



#10 drkdeath5000

drkdeath5000

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 55 posts

Posted 21 April 2017 - 10:08 AM

UPDATE - I finally managed to get Elenari to flash. The exact steps i took where to revery back to stock 0527 using the SD card method and then install the 0717 ROM followed by Elenari. So it seems for what ever reason my device didnt like going straight from 0527 and needed 0717 flashing first.

 

I'm now on Elenari and its a much improvement over stock. Very quick and snappy ROM with all the bloat removed. My only issue is the internal and external SD card is not detected when booted to android so i'm having to use an OTG cable and a USB stick to copy files over. Any ideas what the issue could be?

 

Thanks