Jump to content


Photo

Yet Another Dumper for 7029 + ADB


  • Please log in to reply
2 replies to this topic

#1 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,091 posts

Posted 31 January 2017 - 03:50 PM

I have made some "dumpers" for Actions' 7029 devices before like
(adding examples some day here). Those are used in the recovery mode.

But what about those situations when the recovery doesn't work?
And device isn't rooted. Then this new dumper could save the day.

It's basically a CWM recovery run by using the Pad Product Tool.
See the Readme.txt file included (and below) for more info.
 
Warning! Don't use this if the device works okay. The partitions
can be dumped using recovery or by adb if firmware is rooted,
that is if adb root or su works. See the next post too.

PadProductToolDumper-for-ATM7029_[cxz].exe.7z 
Download: https://yadi.sk/d/5NjsK9xC3C8bEE
(to extract, remove ".7z" from the end and run)
 

Pad Product Tool Dumper for ATM7029 
-----------------------------------------
 
As usual, no guarantee of any kind. 
Use at your own risk.

 
Meant to be used when the tablet isn't rooted
and recovery is not available. This doesn't
help in those cases when a wrong firmware has
been flashed. (internal memory can be saved
if flash has not been erased - maybe).

The dumped partitions can then be examined
and possibly a new firmware can be created.
Also booting problems might be fixed with ADB. 
 
This might not work in every 7029 out there.
Uses the modules of Ainol Crystal2.
 
Enables the dumping of the partitions and also the 
usage of the ADB. Flash using the Pad Product Tool. 
If dump-these.txt is in the root of the sd card, 
partitions listed are dumped automatically 
to the sd card.
 
The screen will not work but the tablet will
vibrate when the BNMGUY's CWM based recovery
(with my modifications) starts. Also short
buzzes are given when partition is dumped.
Longer when the dump is done.
 
Partitions
-----------
RECOVERY(acta), MISC(actb), SYSTEM(actc), DATA(actd), 
CACHE(acte), DATA_BAK(actf), MNT_MEDIA(actg), 
VENDOR_APP(acth), UDISK(actj)=internal memory
 
dump-these.txt
---------------
acta
actb
actc
actd
acte
actf
actg
acth
actj
 
<snip>


Edited by cxz, 02 February 2017 - 07:43 AM.


#2 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,091 posts

Posted 31 January 2017 - 04:14 PM

Yes, it's supposed to stop at 26% when "DOWNLOAD VMLINUX" text is shown.
That happens when about 30 seconds has passed. And it takes about one
minute when the PAD Product Tool gives up trying.

0_1a2947_7ef38ae_L.jpg

0_1a2948_95ce5814_L.jpg

(It doesn't matter if the options are checked or not. They aren't used.)
Though, the files pushed before might mess the system. ???
More testing needed. See the next post.

ADB Drivers package (adb.exe included)
http://www.slatedroi...85-adb-drivers/
( http://adbdriver.com/downloads/ works as well )

Actions' PAD Product Tools (use v.1.09 or older)
http://www.slatedroi...ools/?p=1079673

Edited by cxz, 02 February 2017 - 08:45 AM.


#3 cxz

cxz

    Advanced Member

  • Moderator
  • PipPipPip
  • 1,091 posts

Posted 02 February 2017 - 07:48 AM

Update. This dumper should only used to save data from a bricked device.

Edit: After several tests made my tablet's recovery screen was messed like
it is when this dumper boots. But, only if booted when the device was off.
Recovery worked okay after booting the system and then rebooting into recovery.
Tried flashing the orig. boot, recovery and wiped the cache. But the problem
was still there. Then did factory reset in recovery and the device worked okay again.
I don't know what was the problem (on data?) but I haven't been able to repeat it now.
Maybe too many tests? IDK. Anyway, there might be a chance of similar peculiarities happening.

Edit2: Does not work with newer firmwares (=the latest(?), kernel build date March 2014. SDK v3.6)
It boots but cannot dump the block devices, i.e. partitions. ADB works but mount not.
Needs different set of modules to get job done.
(Edit3: and with kitkat 4.4.4 this dumper doesn't work at all)

Edited by cxz, 02 February 2017 - 10:55 AM.