Jump to content


Photo

[WIP] ClockworkMod Recovery/CyanogenMod for DAWA D7/Augen Gentouch78


  • Please log in to reply
78 replies to this topic

#1 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 18 November 2010 - 09:36 AM

hi

I tried my CM6 build (for Haipad/HSG tablets) on Dawa D7.
http://teamtelechips...xperimental/D7/
it booted but touchscreen didn't work so it is unusable state.

I'm curious about Gentouch78. any challenger here?

EDIT:
system.img is here.
it is nandroid backup image. don't use it with fastboot.
flash recovery.img into recovery, boot recovery, then flash boot.img and system.img from restore function.

EDIT2:
it is highly experimental. not for daily use.
please read all messages in the original thread.

Please stay away from this thread:
- If you never used ADB
- If you want production quality software
- If you cannot install a windows device driver
- If you're expecting this to be a final product.

Welcome to try our software:
- If you're familiar with ADB, flashing phones, rooting, etc etc.
- Love playing with technology
- Are aware this is an unfinished software product ported due to popular demand.

if you are OKay to destroy your device, go ahead;)


#2 mindwave

mindwave

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 146 posts

Posted 18 November 2010 - 10:02 AM

i MAY try it this evening

#3 mindwave

mindwave

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 146 posts

Posted 18 November 2010 - 10:18 AM

depends on how aggrevated my wife is when she gets home. she wont read the 300 page android how to manual i printed for her. so of course everything it WONT do the way she wants it is the machines fault.......

#4 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 20 November 2010 - 03:23 AM

I uploaded 11/20 build on my site. no changes for D7 in froyo but I added key map for SEARCH key in clockworkmod recovery.MENU: downSEARCH: upHOME: selectESC: backandPOWER: select

#5 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 22 November 2010 - 07:07 AM

Hi,Did test your newest rom 22.11. and got a blank screen (maybe Screen driver not loading?)

#6 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 22 November 2010 - 09:10 AM

Did test your newest rom 22.11. and got a blank screen (maybe Screen driver not loading?)

both boot.img and recovery.img are flashed? i.e. blank screen both normal mode and recovery mode?I'll make new image with latest (patchv3?) Gentouch78 kernel.anyway, thank you for your report!EDIT:GT78 images are added. please try!

#7 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 22 November 2010 - 10:21 AM

thanks,recovery mode was working with D7 rom. But got blank screen after flashing system.imgWill try new one.Edit: Did try new boot.img but still the same (Blank screen)

#8 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 22 November 2010 - 11:40 AM

[quote name='jlove;95521]thanks' date='recovery mode was working with D7 rom. But got blank screen after flashing system.imgWill try new one.Edit: Did try new boot.img but still the same (Blank screen)[/QUOTE']oh, recovery.D7.img worked on GT78? then D7 kernel can be used on GT78!all buttons ok?I'm not sure why normal boot is not worked... it uses same kernel as recovery.can you see logo on upper left corner while booting?can you see boot animation?can you use adb under blank screen?

#9 miraclemaker

miraclemaker

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 22 November 2010 - 12:12 PM

GREAT work guys - subscribed!

#10 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 23 November 2010 - 03:40 AM

just flashed it again:1. yes there is a logo while booting in to recovery2. there is a logo while booting into android3. then it freezes on the booting logo ( left side corner )4. no boot animation5. adb not working , no device found.thx for trying

#11 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 23 November 2010 - 05:48 AM

[quote name='jlove;95736]just flashed it again:1. yes there is a logo while booting in to recovery2. there is a logo while booting into android3. then it freezes on the booting logo ( left side corner )4. no boot animation5. adb not working ' date=' no device found.thx for trying[/QUOTE']thanks! it seems problem is in init.rc.did you flash system.img by restore menu in recovery?--this is just a note.below is (copy of) official Dawa D7 firmware. (25, Sep / eclair)http://pachimon.jp/i...D7_Firmware.zipI got kernel from it. I think it can be used on Augen Gentouch78.EDIT:if someone know newer firmware (kernel), please tell me.

#12 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 23 November 2010 - 06:37 AM

i just flashed it again ( only system.img ) with restore in recoveryanimation works :) (cyrogen with android on scateboard ) tryying to boot-.....black screen now, but adb works now.hope this will help :)edit: screen is online now :))))))))iam in the sytem and it works for now, screen offline again, semms like a bug, will make more research ...

#13 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 23 November 2010 - 06:50 AM

touchscreen dont works, on first screen ( where i can slide to unlock) nothing reacts, and display goes off after 5 seconds, then black screen, after 30 sec, power on button ( display on ) reacts again, 2 sec screen on, then off again, waiting 30 sec,same results... you know what is wrong?edit: i did a nandroid backup of the device when it came to me, it had a new software not available on the update site on it, but it was eclair 2.1, do you need it?ps: when i flash the nandroid backup i made , it wont boot, and boot img and recovery img seem to be the same size....

#14 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 23 November 2010 - 07:30 AM

[quote name='jlove;95793]touchscreen dont works' date=' on first screen ( where i can slide to unlock) nothing reacts, and display goes off after 5 seconds, then black screen, after 30 sec, power on button ( display on ) reacts again, 2 sec screen on, then off again, waiting 30 sec,same results... you know what is wrong?[/QUOTE']great thanks!it sounds Gentouch78 is really same as Dawa D7. touchscreen doesn't work on D7 too. use mouse for now;)to unlock, menu button can be used.how about G-sensor?our froyo is tweaked to fix incorrect axis for Haipad/HSG tablets. so it may be upside down when landscape position.--I don't have D7/GT78. Asure/VeNoMouS don't have it too.owner of D7/GT78 should setup team for froyo! :)

#15 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 23 November 2010 - 07:53 AM

no g sensor is integrated on this device :/cant play with it :) , screen doesnt work, hope you find a solution :)

#16 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 23 November 2010 - 08:17 AM

[quote name='jlove;95793]edit: i did a nandroid backup of the device when it came to me' date=' it had a new software not available on the update site on it, but it was eclair 2.1, do you need it?[/QUOTE']is it newer than patchv3 from augen? (#185 Aug 22)I'm not sure which firm is better (Augen Gentouch78/SmartBook Surfer/Dawa D7). D7 firm seems to be newest.[quote name='jlove;95793]ps: when i flash the nandroid backup i made ' date=' it wont boot, and boot img and recovery img seem to be the same size....[/QUOTE']boot.img and recovery.img are just dump of raw partition, it contains trailing unused area. maybe it is 10MB?system.img is just a archive like zip/tar. currently, system.img from official firmware and backuped system.img are NOT compatible. you need to use fastboot for official system.img, restore for backuped system.img.

#17 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 23 November 2010 - 08:35 AM

[quote name='jlove;95815]no g sensor is integrated on this device :/cant play with it :) ' date=' screen doesnt work, hope you find a solution :)[/QUOTE']oh, I didn't know it... maybe "D7 - HDMI - G-sensor = GT78"?sorry, I can't offer solution for now...--D7 runs at 720MHz with Sep 25 firmware. (was 600MHz with old firmware)I think you can use boot.img from official D7 firm (eclair) with your original system.img (eclair).please play with it until someone fix froyo/CM...

#18 jlove

jlove

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 50 posts

Posted 23 November 2010 - 09:16 AM

i dont know, but i think it is the newest update but i dont know for sure, the update3 was not the same. this sytem img has a back button on the screen notifation bar.i tried many installations , and got it work some how, but now i dont know how, maybe you can make something out of it i tried to upload it but it seems little bit too big... i will upload it in *rar pieces tomorrow.... if you want the files

#19 fun_

fun_

    Advanced Member

  • Hero Member
  • PipPipPip
  • 525 posts

Posted 23 November 2010 - 09:49 AM

[quote name='jlove;95856]i dont know' date=' but i think it is the newest update but i dont know for sure, the update3 was not the same. this sytem img has a back button on the screen notifation bar.i tried many installations , and got it work some how, but now i dont know how, maybe you can make something out of it i tried to upload it but it seems little bit too big... i will upload it in *rar pieces tomorrow.... if you want the files[/QUOTE']hmm, interesting. I want to see it but no hurry because I don't have D7/GT78 ;)here is Japanese bloghttp://blog.livedoor...es/3648545.htmlreviewed D7 Sep 25 firmware. it says "back button is added".

#20 jcannon

jcannon

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 41 posts

Posted 23 November 2010 - 11:02 AM

Anybody want to take a crack at the newest iMito firmware? Hotfile.com: One click file hosting: iMito iM7 Upgrade For 1.2.rar. Much faster, camera does not work. Boot image doesn't seem to work, used a dawa d7 boot image and it worked well, it isn't included. Maybe I was doing something wrong and the boot image works, didn't work for me though. Here is the link to the Dawa firmware, not as good as the iMito in my opinion. http://hotfile.com/d...AWA_OS.rar.html.